Initial import of gate-2.04c.

gate is a simple and unobtrusive line-oriented text editor.

PR: 19905
Submitted by: Christopher N. Harrell <cnh@ivmg.net>
Reviewed by: sobomax
This commit is contained in:
Kevin Lo 2000-07-21 10:11:44 +00:00
parent e7442d6aec
commit 02585bd39c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30930
12 changed files with 177 additions and 0 deletions

View File

@ -42,6 +42,7 @@
SUBDIR += flim-xemacs20
SUBDIR += flim-xemacs20-current
SUBDIR += fte
SUBDIR += gate
SUBDIR += gedit
SUBDIR += ghex
SUBDIR += gnotepad+

30
editors/gate/Makefile Normal file
View File

@ -0,0 +1,30 @@
# New ports collection makefile for: gate
# Date created: 15 June 2000
# Whom: James Howard
#
# $FreeBSD$
#
PORTNAME= gate
PORTVERSION= 2.04c
CATEGORIES= editors
MASTER_SITES= http://www.wwnet.net/~janc/software/
DISTNAME= ${PORTNAME}
MAINTAINER= howardjp@wam.umd.edu
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= gate gate.1
MAN1= gate.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gate ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/gate.1 ${PREFIX}/man/man1
${MKDIR} ${PREFIX}/share/gate
${INSTALL_DATA} ${WRKSRC}/gate.help ${PREFIX}/share/gate
.include <bsd.port.mk>

1
editors/gate/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (gate.tar.gz) = d7c10db9858cf6ad0a48cbb6dd2949de

View File

@ -0,0 +1,24 @@
--- Makefile.orig Wed Jul 24 02:23:43 1996
+++ Makefile Fri Jul 21 17:57:55 2000
@@ -150,17 +150,17 @@
#LIB= -ltermcap
# my Linux box with international ispell - Debugging only
-CFLAGS= -g \
+CFLAGS+= -g \
-DBSD \
-DYAPP \
-DNOVICE \
-DIISPELL \
-DPICO_BUG \
- -DSPELL_PATH='"/usr/local/bin/ispell"' \
- -DDICT_DIR='"/usr/local/lib"' \
+ -DSPELL_PATH='"$(LOCALBASE)/bin/ispell"' \
+ -DDICT_DIR='"$(LOCALBASE)/share/ispell"' \
-DLANG_DEFAULT='"english"'\
-DDEFAULT_EDITOR='"/usr/bin/vi"' \
- -DHELP_FILE='"/home/janc/src/gate/gate.help"'
+ -DHELP_FILE='"$(PREFIX)/share/gate/gate.help"'
LIB= -ltermcap
OBJS=main.o line.o syst.o util.o cmd.o file.o opt.o subs.o term.o proc.o spel.o

View File

@ -0,0 +1,31 @@
--- file.c.orig Mon Jul 17 23:05:48 2000
+++ file.c Mon Jul 17 23:12:29 2000
@@ -59,12 +59,12 @@
* open file descriptor.
*/
-FILE *copy_file(char *wname)
+FILE *copy_file(char *wname, int fd)
{
FILE *wfp;
int ch;
- if ((wfp= fopen(wname,"w+")) == NULL)
+ if ((wfp= fdopen(fd,"w+")) == NULL)
{
printf("Cannot open file %s\n",wname);
return(NULL);
@@ -84,10 +84,12 @@
void write_file(char *wname)
{
FILE *fp;
+int fd;
if (expand_tilde(wname)) return;
- if ((fp= copy_file(wname)) == NULL) return;
+ fd = open(wname, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+ if ((fp= copy_file(wname, fd)) == NULL) return;
fclose(fp);
printf("Saved in file %s\n",wname);
}

View File

@ -0,0 +1,11 @@
--- gate.h.orig Mon Jul 17 23:20:52 2000
+++ gate.h Mon Jul 17 23:21:15 2000
@@ -213,7 +213,7 @@
/* FILE.C */
void read_file(char *rname, int strip);
-FILE *copy_file(char *wname);
+FILE *copy_file(char *wname, int fd);
void write_file(char *wname);
void typefile(char *name);
void emptyfile(void);

View File

@ -0,0 +1,19 @@
--- proc.c.orig Mon Jul 17 23:13:54 2000
+++ proc.c Mon Jul 17 23:14:26 2000
@@ -57,13 +57,14 @@
char tmpname[20];
FILE *cfp;
long oldt;
+int fd;
/* We could use a call to make_copy() here, but this method survives
* interupts better
*/
strcpy(tmpname, "/tmp/gateXXXXXX");
- mktemp(tmpname);
- if ((cfp= fopen(tmpname,"w+")) == NULL)
+ fd = mkstemp(tmpname);
+ if ((cfp= fdopen(fd,"w+")) == NULL)
{
printf("Cannot open file %s.\n",tmpname);
return(NULL);

View File

@ -0,0 +1,20 @@
--- spel.c.orig Mon Jul 17 23:14:49 2000
+++ spel.c Mon Jul 17 23:15:57 2000
@@ -9,7 +9,7 @@
typedef struct dirent dirent;
#define dnamlen(d) strlen(d->d_name)
#else
-#include <sys/dir.h>
+#include <dirent.h>
typedef struct direct dirent;
#define dnamlen(d) (d->d_namlen)
#endif
@@ -298,7 +298,7 @@
#ifdef DICT_DIR
char buf[BUFSIZE+1];
DIR *ispd;
-dirent *de;
+struct dirent *de;
int n= 0;
int namlen;

View File

@ -0,0 +1,16 @@
--- subs.c.orig Mon Jul 17 23:16:19 2000
+++ subs.c Mon Jul 17 23:16:45 2000
@@ -40,10 +40,11 @@
{
char tmpname[18];
FILE *fp;
+int fd;
strcpy(tmpname, "/tmp/gateXXXXXX");
- mktemp(tmpname);
- fp= copy_file(tmpname);
+ fd = mkstemp(tmpname);
+ fp= copy_file(tmpname, fd);
unlink(tmpname);
return(fp);
}

1
editors/gate/pkg-comment Normal file
View File

@ -0,0 +1 @@
A simple and unobtrusive line-oriented text editor

20
editors/gate/pkg-descr Normal file
View File

@ -0,0 +1,20 @@
Gate is text-gatherer. A text-gatherer is like a text-editor, but much
more lightweight and unobtrusive.
If you have a program or shell script that asks people to enter a small
chunk of text, a text-gatherer like Gate is a good way to do it. It
doesn't clear the screen (annoying if there were just some instructions
printed there). It doesn't require you to know a lot of obscure editing
commands. It doesn't make excessive demands on the intelligence of your
terminal emulation software.
It does provide a number of features that make it easier for novice users
to produce good text. It does word-wrap, prints a prompt on each new line,
and allows backspacing from the currently line onto previous lines. It
also provides features that a more experienced user can use. You can call
up normal editor, or use some of gate's simple-minded editing
commands. You can read in files, or save your text to a file. You can
filter your text through something like the unix "fmt" command. It
provides a nice spell-checking interface too.
WWW: http://www.wwnet.net/~janc/gate.html

3
editors/gate/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/gate
share/gate/gate.help
@dirrm share/gate