games/ecwolf: update to 1.4.0

Changelog:	https://maniacsvault.net/ecwolf/wiki/Version_history#2023
This commit is contained in:
Piotr Kubaj 2023-01-19 00:15:03 +01:00
parent cfd258bf06
commit 024e0ebe9f
5 changed files with 13 additions and 57 deletions

View File

@ -1,6 +1,5 @@
PORTNAME= ecwolf
PORTVERSION= 1.3.3
PORTREVISION= 1
PORTVERSION= 1.4.0
DISTVERSIONSUFFIX= -src
CATEGORIES= games
MASTER_SITES= http://maniacsvault.net/ecwolf/files/ecwolf/1.x/
@ -18,7 +17,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
USES= cmake compiler:c++11-lang gnome jpeg localbase:ldflags \
pkgconfig sdl tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk20
USE_SDL= mixer sdl
USE_SDL= mixer2 net2 sdl2
SUB_FILES= ecwolf pkg-message
SUB_LIST= PORTNAME=${PORTNAME}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1534522946
SHA256 (ecwolf-1.3.3-src.tar.xz) = 346b519745f399256463a7cf56d84c1315b1436c95e3a28aa287fc268ed96de9
SIZE (ecwolf-1.3.3-src.tar.xz) = 7641476
TIMESTAMP = 1674060889
SHA256 (ecwolf-1.4.0-src.tar.xz) = 49c1b8c787c0a5a58e100b4e9ea7ef0af1a20b5d7d40491ae0d77e0485ebbb21
SIZE (ecwolf-1.4.0-src.tar.xz) = 14703808

View File

@ -1,24 +0,0 @@
--- src/CMakeLists.txt.orig 2019-01-29 16:31:24 UTC
+++ src/CMakeLists.txt
@@ -40,9 +40,9 @@ else(GPL)
set(EXTRA_LIBRARIES)
endif(GPL)
-find_package(SDL REQUIRED)
-find_package(SDL_mixer REQUIRED)
-include_directories(${SDLMIXER_INCLUDE_DIR} ${SDL_INCLUDE_DIR} ${ZLIB_INCLUDE_DIR} ${BZIP2_INCLUDE_DIR} ${JPEG_INCLUDE_DIR})
+pkg_search_module(SDL REQUIRED sdl sdl)
+pkg_search_module(SDLMIXER REQUIRED SDL_mixer)
+include_directories(${SDLMIXER_INCLUDE_DIRS} ${SDL_INCLUDE_DIRS}/SDL ${ZLIB_INCLUDE_DIR} ${BZIP2_INCLUDE_DIR} ${JPEG_INCLUDE_DIR})
check_function_exists(stricmp STRICMP_EXISTS)
check_function_exists(strnicmp STRNICMP_EXISTS)
@@ -320,7 +320,7 @@ else(NOT ANDROID)
endif(NOT ANDROID)
add_dependencies(ecwolf lzma gdtoa revision_check)
-target_link_libraries(ecwolf ${EXTRA_LIBRARIES} ${SDL_LIBRARY} ${SDLMIXER_LIBRARY} ${ZLIB_LIBRARY} ${BZIP2_LIBRARIES} ${JPEG_LIBRARIES} lzma gdtoa)
+target_link_libraries(ecwolf ${EXTRA_LIBRARIES} ${SDL_LIBRARIES} ${SDLMIXER_LIBRARIES} ${ZLIB_LIBRARY} ${BZIP2_LIBRARIES} ${JPEG_LIBRARIES} lzma gdtoa)
set_target_properties(ecwolf PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_DIR})
# Install

View File

@ -1,11 +0,0 @@
--- src/thingdef/thingdef.cpp.orig 2020-08-24 18:22:35 UTC
+++ src/thingdef/thingdef.cpp
@@ -283,7 +283,7 @@ static const struct ExpressionFunction
{ "random", TypeHierarchy::INT, 2, true, ExprRandom },
{ "sin", TypeHierarchy::FLOAT, 1, false, ExprSin },
- { NULL, 0, false, NULL }
+ { NULL, 0, false, false }
};
////////////////////////////////////////////////////////////////////////////////

View File

@ -1,19 +1,11 @@
--- src/wl_iwad_picker.cpp.orig 2018-08-17 16:43:51 UTC
--- src/wl_iwad_picker.cpp.orig 2023-01-18 23:02:12 UTC
+++ src/wl_iwad_picker.cpp
@@ -1,6 +1,7 @@
// From ZDoom!
#include <algorithm>
@@ -27,6 +27,8 @@ void TXT_PickWad(TXT_UNCAST_ARG(widget), int wad)
int I_PickIWad_Cocoa (WadStuff *wads, int numwads, bool showwin, int defaultiwad);
#elif defined(__ANDROID__)
int I_PickIWad_Android (WadStuff *wads, int numwads, bool showwin, int defaultiwad);
+#elif defined(__FreeBSD__)
+#include <sys/wait.h>
#endif
#include "zdoomsupport.h"
@@ -227,7 +228,7 @@ int I_PickIWad (WadStuff *wads, int numwads, bool show
const char *str;
if((str=getenv("KDE_FULL_SESSION")) && strcmp(str, "true") == 0)
{
- FString cmd("kdialog --title \""GAMESIG" "DOTVERSIONSTR": Select an IWAD to use\""
+ FString cmd("kdialog --title \"" GAMESIG " " DOTVERSIONSTR ": Select an IWAD to use\""
" --menu \"" GAMENAME " found more than one IWAD\n"
"Select from the list below to determine which one to use:\"");
#ifndef NO_GTK