${PREFIX}/bin/ssleay -> ${PREFIX}/bin/openssl due to openssl upgrade.

Unfortunaly SSLtelnet doesn't work with openssl-0.9.2b at the moment.
We'll try to fix this as soon as possible.

OK'ed by:	Issei Suzuki <issei@jp.freebsd.org> (maintainer)
This commit is contained in:
Dirk Froemberg 1999-03-26 08:44:57 +00:00
parent 0d16fe8fa8
commit 022f745a66
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17396
2 changed files with 15 additions and 8 deletions

View File

@ -3,7 +3,7 @@
# Date created: Mar 29, 1998
# Whom: issei@jp.FreeBSD.ORG
#
# $Id: Makefile,v 1.5 1998/10/19 15:49:06 vanilla Exp $
# $Id: Makefile,v 1.6 1999/01/10 14:11:16 dirk Exp $
DISTNAME= SSLtelnet-0.13
CATEGORIES= net security
@ -11,6 +11,8 @@ MASTER_SITES= ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
MAINTAINER= issei@jp.FreeBSD.ORG
BROKEN= does not work with openssl-0.9.2b at the moment
.if defined(USA_RESIDENT) && ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
pre-fetch:
@echo
@ -27,8 +29,8 @@ pre-configure:
.endif
.endif
BUILD_DEPENDS= ssleay:${PORTSDIR}/security/openssl
RUN_DEPENDS= ssleay:${PORTSDIR}/security/openssl
BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
RUN_DEPENDS= openssl:${PORTSDIR}/security/openssl
RESTRICTED= "Cryptography"

View File

@ -1,5 +1,5 @@
--- Makefile.orig Sat Aug 2 15:08:25 1997
+++ Makefile Wed Sep 2 12:53:13 1998
--- Makefile.orig Thu Sep 24 23:50:59 1998
+++ Makefile Wed Mar 24 19:07:12 1999
@@ -47,7 +47,7 @@
# the location where SSLeay is installed ...
@ -47,14 +47,19 @@
@echo "*****************************************************"
@echo "* Do not forget to make the certificate for telnetd *"
@echo "* either manually or via \"make certificate\" *"
@@ -158,6 +161,7 @@
@@ -158,9 +161,10 @@
certificate:
(\
+ [ -f $(INSTALLTOP)/certs/telnetd.pem ] && exit; \
cd $(INSTALLTOP)/certs; \
ssleay req -new -x509 -nodes -days 365 -out telnetd.pem -keyout telnetd.pem; \
ln -s telnetd.pem `ssleay x509 -noout -hash < telnetd.pem`.0 ;\
- ssleay req -new -x509 -nodes -days 365 -out telnetd.pem -keyout telnetd.pem; \
- ln -s telnetd.pem `ssleay x509 -noout -hash < telnetd.pem`.0 ;\
+ openssl req -new -x509 -nodes -days 365 -out telnetd.pem -keyout telnetd.pem; \
+ ln -s telnetd.pem `openssl x509 -noout -hash < telnetd.pem`.0 ;\
chmod 600 $(INSTALLTOP)/certs/telnetd.pem; \
)
--- lib/Makefile.orig Wed Sep 2 13:11:39 1998
+++ lib/Makefile Wed Sep 2 13:11:49 1998
@@ -1,7 +1,7 @@