- Retire joe-devel. This is now official stable branch and is available in

editors/joe port.
This commit is contained in:
Pav Lucistnik 2005-10-21 08:22:32 +00:00
parent 094982a4a5
commit 020a2438df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145996
7 changed files with 0 additions and 176 deletions

View File

@ -87,7 +87,6 @@
SUBDIR += jext
SUBDIR += joe
SUBDIR += joe2
SUBDIR += joe-devel
SUBDIR += jove
SUBDIR += kate-plugins
SUBDIR += kile

View File

@ -1,44 +0,0 @@
# New ports collection makefile for: joe-devel
# Date created: 25 Jul 2001
# Whom: dwcjr@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= joe
PORTVERSION= 3.2
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}-editor
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= petef@FreeBSD.org
COMMENT= Development version of Joe's Own Editor
CONFLICTS= joe-2.*
LATEST_LINK= joe-devel
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -liconv"
ALL_TARGET= ${PORTNAME}
MAN1= ${PORTNAME}.1
.include <bsd.port.pre.mk>
post-install:
.for file in jmacsrc jpicorc jstarrc rjoerc joerc
.if !exists(${PREFIX}/etc/${PORTNAME}/${file})
@${CP} ${PREFIX}/etc/${PORTNAME}/${file} ${PREFIX}/etc/${PORTNAME}/${file}.dist
.endif
.endfor
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
MD5 (joe-3.2.tar.gz) = 07e8077ee4562256bb6a2bf03e3071c2
SIZE (joe-3.2.tar.gz) = 431843

View File

@ -1,42 +0,0 @@
--- syntax/diff.jsf.in.orig Fri May 6 18:14:53 2005
+++ syntax/diff.jsf.in Fri May 6 18:19:28 2005
@@ -6,6 +6,7 @@
# Color definitions
=Idle
+=Options blue
=FileNew bold green
=FileOld bold red
=DiffStuff magenta
@@ -15,6 +16,7 @@
:reset Idle
* goo
+ "d" goo
"-" preudiff buffer
"*" precdiff buffer
"0-9" ndiff recolor=-1
@@ -33,8 +35,14 @@
done
"*" precdiff
+:options Options
+ * options
+ "\n" reset
+
:goo Idle
- * goo
+ * goo strings
+ "diff" options recolor=-4
+done
"\n" reset
:udiff Idle
@@ -58,6 +66,7 @@
:udiffhunk Idle
* reset
+ "d" goo buffer
"-" udiffoldordel recolor=-1
"+" udiffadd recolor=-1
" " udiffctx recolor=-1

View File

@ -1,13 +0,0 @@
--- tty.c.orig Fri Mar 18 10:40:11 2005
+++ tty.c Fri May 6 16:58:38 2005
@@ -1074,8 +1074,10 @@
setsid(); /* I think you do setprgp(0,0) on systems with no setsid() */
#ifndef SETPGRP_VOID
setpgrp(0, 0);
+/*
#else
setpgrp();
+*/
#endif
#endif

View File

@ -1,17 +0,0 @@
JOE is the professional freeware ASCII text screen editor for UNIX.
It makes full use of the power and versatility of UNIX, but lacks
the steep learning curve and basic nonsense you have to deal with
in every other UNIX editor. JOE has the feel of most IBM PC text
editors: the key-sequences are reminiscent of WordStar and Turbo-C.
JOE is much more powerful than those editors, however. JOE has
all of the features a UNIX user should expect: full use of
termcap/terminfo, excellent screen update optimizations (JOE is
fully usable at 2400 baud), simple installation, and all of the
UNIX-integration features of VI.
JOE(-devel) now has UTF-8 support and Syntax Highlighting.
WWW: http://sourceforge.net/projects/joe-editor/
-Pete
petef@databits.net

View File

@ -1,57 +0,0 @@
bin/jmacs
bin/joe
bin/jpico
bin/jstar
bin/rjoe
bin/termidx
etc/joe/charmaps/klingon
@unexec if cmp -s %D/etc/joe/jmacsrc.dist %D/etc/joe/jmacsrc; then rm -f %D/etc/joe/jmacsrc; fi
etc/joe/jmacsrc.dist
@exec if [ ! -f %D/etc/joe/jmacsrc ]; then cp %D/etc/joe/%f %D/etc/joe/jmacsrc; fi
@unexec if cmp -s %D/etc/joe/joerc.dist %D/etc/joe/joerc; then rm -f %D/etc/joe/joerc; fi
etc/joe/joerc.dist
@exec if [ ! -f %D/etc/joe/joerc ]; then cp %D/etc/joe/%f %D/etc/joe/joerc; fi
@unexec if cmp -s %D/etc/joe/jpicorc.dist %D/etc/joe/jpicorc; then rm -f %D/etc/joe/jpicorc; fi
etc/joe/jpicorc.dist
@exec if [ ! -f %D/etc/joe/jpicorc ]; then cp %D/etc/joe/%f %D/etc/joe/jpicorc; fi
@unexec if cmp -s %D/etc/joe/jstarrc.dist %D/etc/joe/jstarrc; then rm -f %D/etc/joe/jstarrc; fi
etc/joe/jstarrc.dist
@exec if [ ! -f %D/etc/joe/jstarrc ]; then cp %D/etc/joe/%f %D/etc/joe/jstarrc; fi
@unexec if cmp -s %D/etc/joe/rjoerc.dist %D/etc/joe/rjoerc; then rm -f %D/etc/joe/rjoerc; fi
etc/joe/rjoerc.dist
@exec if [ ! -f %D/etc/joe/rjoerc ]; then cp %D/etc/joe/%f %D/etc/joe/rjoerc; fi
etc/joe/syntax/4gl.jsf
etc/joe/syntax/asm.jsf
etc/joe/syntax/c.jsf
etc/joe/syntax/conf.jsf
etc/joe/syntax/csh.jsf
etc/joe/syntax/css.jsf
etc/joe/syntax/diff.jsf
etc/joe/syntax/fortran.jsf
etc/joe/syntax/html.jsf
etc/joe/syntax/java.jsf
etc/joe/syntax/lisp.jsf
etc/joe/syntax/mail.jsf
etc/joe/syntax/mason.jsf
etc/joe/syntax/ocaml.jsf
etc/joe/syntax/pascal.jsf
etc/joe/syntax/perl.jsf
etc/joe/syntax/php.jsf
etc/joe/syntax/python.jsf
etc/joe/syntax/sh.jsf
etc/joe/syntax/sml.jsf
etc/joe/syntax/tcl.jsf
etc/joe/syntax/tex.jsf
etc/joe/syntax/verilog.jsf
etc/joe/syntax/vhdl.jsf
etc/joe/syntax/xml.jsf
etc/joe/doc/ChangeLog
etc/joe/doc/LIST
etc/joe/doc/HACKING
etc/joe/doc/HINTS
etc/joe/doc/NEWS
etc/joe/doc/README
@unexec rmdir %D/etc/joe/doc 2>/dev/null || true
@unexec rmdir %D/etc/joe/charmaps 2>/dev/null || true
@unexec rmdir %D/etc/joe/syntax 2>/dev/null || true
@unexec rmdir %D/etc/joe 2>/dev/null || true