add py-poker-eval

Python adaptor for the poker-eval toolkit
This commit is contained in:
Ying-Chieh Liao 2006-12-14 16:00:46 +00:00
parent 840ee4a79c
commit 01e53b475b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179764
6 changed files with 67 additions and 0 deletions

View File

@ -551,6 +551,7 @@
SUBDIR += primateplunge
SUBDIR += ptkei
SUBDIR += pvpgn
SUBDIR += py-poker-eval
SUBDIR += py-sgflib
SUBDIR += py-sgfsummary
SUBDIR += py-ski

View File

@ -0,0 +1,33 @@
# ex:ts=8
# Ports collection Makefile for: py-poker-eval
# Date created: Dec 14, 2006
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= poker-eval
PORTVERSION= 0.133
CATEGORIES= games python
MASTER_SITES= http://download.gna.org/pokersource/sources/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py${PORTNAME}-${PORTVERSION:E}.0
MAINTAINER= ijliao@FreeBSD.org
COMMENT= Python adaptor for the poker-eval toolkit
LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
USE_GNOME= gnometarget pkgconfig
USE_PYTHON= 2.3+
GNU_CONFIGURE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|{libdir}/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
test:
@cd ${WRKSRC} && ${MAKE} check
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (pypoker-eval-133.0.tar.gz) = 221ba23f829d41206b2f7181608c01a5
SHA256 (pypoker-eval-133.0.tar.gz) = 2d84848deffe5d37353a70a6577aaf2d00008cce313d774cef65378bf29160c5
SIZE (pypoker-eval-133.0.tar.gz) = 342305

View File

@ -0,0 +1,15 @@
--- config/ltmain.sh.orig Thu Dec 14 22:00:03 2006
+++ config/ltmain.sh Thu Dec 14 22:00:20 2006
@@ -6003,10 +6003,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,8 @@
This package is python adaptor for the poker-eval toolkit for writing
programs which simulate or analyze poker games as found at
http://gna.org/projects/pokersource/. The python interface is
somewhat simpler than the C API of poker-eval. It assumes that the
caller is willing to have a higher level API and is not interested in
a one to one mapping of the poker-eval API.
WWW: http://www.pokersource.org/pypoker-eval.php

View File

@ -0,0 +1,7 @@
%%PYTHON_SITELIBDIR%%/_pokereval_2_5.a
%%PYTHON_SITELIBDIR%%/_pokereval_2_5.so
%%PYTHON_SITELIBDIR%%/_pokereval_2_5.so.1
%%PYTHON_SITELIBDIR%%/pokereval.py
%%PYTHON_SITELIBDIR%%/pokereval.pyc
%%PYTHON_SITELIBDIR%%/pokereval.pyo
libdata/pkgconfig/pypoker-eval.pc