xjobs reads job descriptions line by line and executes them in parallel. It
limits the number of parallel executing jobs and starts new jobs when jobs finish. Therefore, it combines the arguments from every input line with the utility and arguments given on the command line. If no utility is given as an argument to xjobs, then the first argument on every job line will be used as utility. To execute utility xjobs searches the directories given in the PATH environment variable and uses the first file found in these directories. xjobs is most useful on multi-processor/core machines when one needs to execute several time consuming command several that could possibly be run in parallel. With xjobs this can be achieved easily, and it is possible to limit the load of the machine to a useful value. It works similar to xargs, but starts several processes simultaneously and gives only one line of arguments to each utility call. WWW: http://www.maier-komor.de/xjobs.html PR: ports/162109 Submitted by: Jason Helfman <jhelfman@experts-exchange.com>
This commit is contained in:
parent
22c27d2946
commit
01d2e72225
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285046
@ -972,6 +972,7 @@
|
||||
SUBDIR += xfsm
|
||||
SUBDIR += xfsprogs
|
||||
SUBDIR += xin
|
||||
SUBDIR += xjobs
|
||||
SUBDIR += xloadface
|
||||
SUBDIR += xlogmaster
|
||||
SUBDIR += xmbmon
|
||||
|
28
sysutils/xjobs/Makefile
Normal file
28
sysutils/xjobs/Makefile
Normal file
@ -0,0 +1,28 @@
|
||||
# New ports collection makefile for: xjobs
|
||||
# Date created: 28 October 2011
|
||||
# Whom: Jason Helfman <jhelfman@experts-exchange.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
#
|
||||
|
||||
PORTNAME= xjobs
|
||||
PORTVERSION= 20110730
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.maier-komor.de/xjobs/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= jhelfman@experts-exchange.com
|
||||
COMMENT= Utility reads job descriptions line by line and executes in parallel
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
PLIST_FILES= bin/xjobs
|
||||
MAN1= xjobs.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
2
sysutils/xjobs/distinfo
Normal file
2
sysutils/xjobs/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (xjobs-20110730.tgz) = 11461a4e7efe6b911d97f4541b353018818b1ce477a0b582ac8a8059e2746d23
|
||||
SIZE (xjobs-20110730.tgz) = 95147
|
14
sysutils/xjobs/files/patch-Makefile.in
Normal file
14
sysutils/xjobs/files/patch-Makefile.in
Normal file
@ -0,0 +1,14 @@
|
||||
--- ./Makefile.in.orig 2011-10-28 09:57:51.000000000 -0700
|
||||
+++ ./Makefile.in 2011-10-28 09:57:58.000000000 -0700
|
||||
@@ -40,11 +40,5 @@
|
||||
-$(RM) $(TARGET) config.h config.log \
|
||||
config.status Makefile core
|
||||
|
||||
-install: $(TARGET)
|
||||
- -$(INSTALL) -d $(DESTDIR)$(bindir)
|
||||
- $(INSTALL) $(TARGET) $(DESTDIR)$(bindir)
|
||||
- -$(INSTALL) -d $(DESTDIR)$(mandir)
|
||||
- $(INSTALL) xjobs.1 $(DESTDIR)$(mandir)
|
||||
-
|
||||
lint:
|
||||
lint $(CFLAGS) $(SOURCES)
|
16
sysutils/xjobs/pkg-descr
Normal file
16
sysutils/xjobs/pkg-descr
Normal file
@ -0,0 +1,16 @@
|
||||
xjobs reads job descriptions line by line and executes them in parallel. It
|
||||
limits the number of parallel executing jobs and starts new jobs when jobs
|
||||
finish. Therefore, it combines the arguments from every input line with the
|
||||
utility and arguments given on the command line. If no utility is given as an
|
||||
argument to xjobs, then the first argument on every job line will be used as
|
||||
utility. To execute utility xjobs searches the directories given in the PATH
|
||||
environment variable and uses the first file found in these directories.
|
||||
|
||||
xjobs is most useful on multi-processor/core machines when one needs to execute
|
||||
several time consuming command several that could possibly be run in parallel.
|
||||
With xjobs this can be achieved easily, and it is possible to limit the load of
|
||||
the machine to a useful value. It works similar to xargs, but starts several
|
||||
processes simultaneously and gives only one line of arguments to each utility
|
||||
call.
|
||||
|
||||
WWW: http://www.maier-komor.de/xjobs.html
|
Loading…
Reference in New Issue
Block a user