x11-wm/herbstluftwm update to 0.8.0
Port changelog: - use cmake build system - added textproc/asciidoc build depend - use xrandr - remove shell completions option as Porter's Handbook suggests Program changelog (https://herbstluftwm.org/news.html): - single window floating (every client has an attribute floating which can be set at run time and via the rule consequence floating=on) - monitor detection via xrandr - detection of external panels - new commands: apply_rules, drag, export - new client attribute: keys_inactive (negation of keymask) - some minor improvements and bug fixes PR: 245527 Submitted by: Zsolt Udvari <uzsolt@uzsolt.hu> (maintainer)
This commit is contained in:
parent
8b78f94cbd
commit
01c3e09bd2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531548
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= herbstluftwm
|
||||
PORTVERSION= 0.7.2
|
||||
PORTVERSION= 0.8.0
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://herbstluftwm.org/tarballs/
|
||||
|
||||
@ -10,50 +10,27 @@ COMMENT= Manual tiling window manager for X11
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
USES= compiler:c++11-lang gmake gnome pkgconfig shebangfix xorg
|
||||
BUILD_DEPENDS= asciidoc:textproc/asciidoc
|
||||
|
||||
USES= cmake compiler:c++11-lang gnome pkgconfig shebangfix xorg
|
||||
USE_GNOME= glib20
|
||||
USE_XORG= x11 xext xinerama
|
||||
USE_XORG= x11 xext xinerama xrandr
|
||||
|
||||
SHEBANG_FILES= scripts/*.sh share/*.sh
|
||||
|
||||
MAKE_ARGS= PREFIX=${PREFIX} SYSCONFDIR=${PREFIX}/etc \
|
||||
DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR} \
|
||||
FISHCOMPLETIONDIR=${PREFIX}/share/fish/completions \
|
||||
MANDIR=${PREFIX}/man LDXX=${CXX} \
|
||||
COLOR=0
|
||||
|
||||
OPTIONS_DEFINE= BASH FISH ZSH DOCS EXAMPLES
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
DOCS_CMAKE_ON= WITH_DOCUMENTATION
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
ALL_TARGET= all-nodoc
|
||||
INSTALL_TARGET= install-nodoc
|
||||
DOCS_ALL_TARGET= doc
|
||||
DOCS_INSTALL_TARGET= install
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e '/LICENSEDIR/d' ${WRKSRC}/Makefile
|
||||
.if ! ${PORT_OPTIONS:MBASH}
|
||||
${REINPLACE_CMD} -e '/BASHCOMPLETIONDIR/d' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
.if ! ${PORT_OPTIONS:MFISH}
|
||||
${REINPLACE_CMD} -e '/FISHCOMPLETIONDIR/d' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
.if ! ${PORT_OPTIONS:MZSH}
|
||||
${REINPLACE_CMD} -e '/ZSHCOMPLETIONDIR/d' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
.if ! ${PORT_OPTIONS:MEXAMPLES}
|
||||
${REINPLACE_CMD} -e '/EXAMPLESDIR/d' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
post-patch-EXAMPLES-on:
|
||||
@${REINPLACE_CMD} -e 's,$${DOCDIR}/examples,${EXAMPLESDIR},' ${WRKSRC}/CMakeLists.txt
|
||||
|
||||
do-install-DOCS-off:
|
||||
${MKDIR} ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
${MKDIR} ${STAGEDIR}${MANPREFIX}/man/man7
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/*.7 ${STAGEDIR}${MANPREFIX}/man/man7
|
||||
post-patch-EXAMPLES-off:
|
||||
@${REINPLACE_CMD} -e '\@$${DOCDIR}/examples@d' ${WRKSRC}/CMakeLists.txt
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/herbst*
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1559116941
|
||||
SHA256 (herbstluftwm-0.7.2.tar.gz) = dff613fc6d7883ea2011318ef8a7b15b92f7864eaf63229df9ce0e99a44281cd
|
||||
SIZE (herbstluftwm-0.7.2.tar.gz) = 245506
|
||||
TIMESTAMP = 1586589706
|
||||
SHA256 (herbstluftwm-0.8.0.tar.gz) = 5823f1c1a6a6ae6d4f843992658fcdb91a246e7f337570ac9b2091f57265c812
|
||||
SIZE (herbstluftwm-0.8.0.tar.gz) = 358434
|
||||
|
26
x11-wm/herbstluftwm/files/patch-CMakeLists.txt
Normal file
26
x11-wm/herbstluftwm/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,26 @@
|
||||
--- CMakeLists.txt.orig 2020-04-11 08:01:07 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -20,13 +20,13 @@ include(ccache)
|
||||
|
||||
## set install variables
|
||||
# prefix for systemwide configuration, accompanies CMAKE_INSTALL_PREFIX
|
||||
-set(CMAKE_INSTALL_SYSCONF_PREFIX "/etc" CACHE PATH
|
||||
+set(CMAKE_INSTALL_SYSCONF_PREFIX "${CMAKE_INSTALL_PREFIX}/etc" CACHE PATH
|
||||
"Top-level install path for configuration files. May be given relative to CMAKE_INSTALL_PREFIX.")
|
||||
|
||||
set(CONFIGDIR "${CMAKE_INSTALL_SYSCONF_PREFIX}/xdg/herbstluftwm")
|
||||
set(BINDIR bin)
|
||||
set(DATADIR share)
|
||||
-set(MANDIR ${DATADIR}/man)
|
||||
+set(MANDIR ${CMAKE_INSTALL_PREFIX}/man)
|
||||
set(DOCDIR ${DATADIR}/doc/herbstluftwm)
|
||||
set(LICENSEDIR ${DOCDIR}
|
||||
CACHE PATH "Install path for license file")
|
||||
@@ -47,7 +47,6 @@ add_subdirectory(share)
|
||||
|
||||
## install everything that was not installed from subdirectories
|
||||
install(FILES BUGS NEWS INSTALL DESTINATION ${DOCDIR})
|
||||
-install(FILES LICENSE DESTINATION ${LICENSEDIR})
|
||||
install(DIRECTORY scripts/ DESTINATION ${DOCDIR}/examples USE_SOURCE_PERMISSIONS)
|
||||
|
||||
# vim: et:ts=4:sw=4
|
@ -1,17 +1,16 @@
|
||||
--- share/autostart.orig 2019-05-09 09:04:33 UTC
|
||||
--- share/autostart.orig 2020-04-11 07:30:02 UTC
|
||||
+++ share/autostart
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env bash
|
||||
+#!/bin/sh
|
||||
@@ -62,18 +62,13 @@ hc keybind $Mod-Control-Down resize down +$resizest
|
||||
hc keybind $Mod-Control-Up resize up +$resizestep
|
||||
hc keybind $Mod-Control-Right resize right +$resizestep
|
||||
|
||||
# this is a simple config for herbstluftwm
|
||||
|
||||
@@ -66,14 +66,11 @@ hc keybind $Mod-Control-Right resize right +$resizes
|
||||
tag_names=( {1..9} )
|
||||
tag_keys=( {1..9} 0 )
|
||||
-# tags
|
||||
-tag_names=( {1..9} )
|
||||
-tag_keys=( {1..9} 0 )
|
||||
+# tags are 1..9
|
||||
|
||||
-hc rename default "${tag_names[0]}" || true
|
||||
-for i in ${!tag_names[@]} ; do
|
||||
-for i in "${!tag_names[@]}" ; do
|
||||
- hc add "${tag_names[$i]}"
|
||||
- key="${tag_keys[$i]}"
|
||||
- if ! [ -z "$key" ] ; then
|
||||
@ -19,10 +18,10 @@
|
||||
- hc keybind "$Mod-Shift-$key" move_index "$i"
|
||||
- fi
|
||||
+hc rename default "1" || true
|
||||
+for i in $(seq 1 9); do
|
||||
+for i in $(seq 1 9) ; do
|
||||
+ hc add "${i}"
|
||||
+ hc keybind "$Mod-$i" use_index "$i"
|
||||
+ hc keybind "$Mod-Shift-$i" move_index "$i"
|
||||
+ hc keybind "$Mod-$key" use_index "$i"
|
||||
+ hc keybind "$Mod-Shift-$key" move_index "$i"
|
||||
done
|
||||
|
||||
# cycle through tags
|
||||
|
10
x11-wm/herbstluftwm/files/patch-src_completion.cpp
Normal file
10
x11-wm/herbstluftwm/files/patch-src_completion.cpp
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/completion.cpp.orig 2020-04-11 07:35:02 UTC
|
||||
+++ src/completion.cpp
|
||||
@@ -1,6 +1,7 @@
|
||||
#include "completion.h"
|
||||
|
||||
#include <algorithm>
|
||||
+#include <iostream>
|
||||
#include <string>
|
||||
#include <vector>
|
||||
|
@ -1,20 +1,22 @@
|
||||
bin/dmenu_run_hlwm
|
||||
bin/herbstclient
|
||||
bin/herbstluftwm
|
||||
etc/bash_completion.d/herbstclient-completion
|
||||
etc/xdg/herbstluftwm/autostart
|
||||
etc/xdg/herbstluftwm/dmenu_run_hlwm
|
||||
etc/xdg/herbstluftwm/panel.sh
|
||||
etc/xdg/herbstluftwm/restartpanels.sh
|
||||
%%BASH%%etc/bash_completion.d/herbstclient-completion
|
||||
%%FISH%%share/fish/completions/herbstclient.fish
|
||||
man/man1/herbstclient.1.gz
|
||||
man/man1/herbstluftwm.1.gz
|
||||
man/man7/herbstluftwm-tutorial.7.gz
|
||||
share/fish/vendor_completions.d/herbstclient.fish
|
||||
share/xsessions/herbstluftwm.desktop
|
||||
share/zsh/site-functions/_herbstclient
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUGS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/herbstclient.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/herbstluftwm.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/herbstluftwm-tutorial.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/herbstluftwm.html
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dmenu.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dumpbeautify.sh
|
||||
@ -24,8 +26,8 @@ man/man7/herbstluftwm-tutorial.7.gz
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/floatmon.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/herbstcommander.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keychain.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layout.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lasttag.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layout.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/loadstate.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/maximize.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/q3terminal.sh
|
||||
@ -34,5 +36,3 @@ man/man7/herbstluftwm-tutorial.7.gz
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/toggledualhead.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/windowmenu.sh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wselect.sh
|
||||
share/xsessions/herbstluftwm.desktop
|
||||
%%ZSH%%share/zsh/functions/Completion/X/_herbstclient
|
||||
|
Loading…
Reference in New Issue
Block a user