update to version 2.6.2

PR:		10648
Submitted by:	me with help finding a new MASTER_SITE from #freebsd
This commit is contained in:
Michael Haro 1999-05-16 23:07:32 +00:00
parent 484d98218a
commit 01b817a515
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18833
5 changed files with 61 additions and 18 deletions

View File

@ -3,23 +3,27 @@
# Date created: 06 July 1998
# Whom: Bill Fumerola <billf@chc-chimes.com>
#
# $Id: Makefile,v 1.1.1.1 1998/07/11 18:32:05 steve Exp $
# $Id: Makefile,v 1.2 1998/12/29 18:22:58 billf Exp $
#
DISTNAME= bnc-web
PKGNAME= bnc-2.4.3
DISTNAME= bnc2.6.2
PKGNAME= bnc-2.6.2
CATEGORIES= net
MASTER_SITES= http://www.bridgenet.net/bnc/
MASTER_SITES= http://irc.themes.org/downloads/misc/
MAINTAINER= billf@FreeBSD.org
WRKSRC= ${WRKDIR}/bnc2.4.3
HAS_CONFIGURE= YES
GNU_CONFIGURE= YES
post-patch:
${SED} 's,@PREFIX@,${PREFIX},g' ${WRKSRC}/bncsetup > ${WRKSRC}/bncsetup.new
${MV} ${WRKSRC}/bncsetup.new ${WRKSRC}/bncsetup
do-install:
${CP} ${WRKSRC}/bnc ${PREFIX}/bin
${CP} ${WRKSRC}/bncchk ${PREFIX}/bin
${CP} ${WRKSRC}/example.conf ${PREFIX}/etc/bnc.conf
${INSTALL_PROGRAM} ${WRKSRC}/bnc ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/bncchk ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/bncsetup ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/mkpasswd ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/example.conf ${PREFIX}/etc/bnc.conf.sample
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (bnc-web.tar.gz) = eee6dcba1cb1ad42f576b46f9bf0c4a7
MD5 (bnc2.6.2.tar.gz) = 4fa45cdcda82998f5f73d17cff479a32

View File

@ -1,11 +1,11 @@
--- Makefile.in.old Mon Jul 6 16:56:21 1998
+++ Makefile.in Mon Jul 6 17:06:25 1998
--- Makefile.in.orig Thu Mar 18 01:09:25 1999
+++ Makefile.in Thu Mar 18 01:09:31 1999
@@ -4,7 +4,7 @@
CFLAGS = -DVERSION='"v2.4.3"' -O6
CFLAGS = -DVERSION='"v2.4.8"' -O6
CC = gcc
-ALL: bnc
+all: bnc
-ALL: bnc mkpasswd
+all: bnc mkpasswd
@echo "*** Done compiling required files"
@echo "Please read the README.TXT file included"
bnc.o: config.h common.h bnc.c Makefile
${CC} ${CFLAGS} -c bnc.c

37
irc/bnc/files/patch-ab Normal file
View File

@ -0,0 +1,37 @@
--- bncsetup.orig Wed Mar 17 07:31:19 1999
+++ bncsetup Thu Mar 18 01:51:47 1999
@@ -12,15 +12,9 @@
exit $1
}
-if ! [ -e ./mkpasswd ]
-then
- echo "You need to Make the package before you can use this script"
- echo "(required ./mkpasswd)"
- bsclean 0
-fi
echo "BAD\$" > $TMPFILE
-echo "Test" | ./mkpasswd -s >> $TMPFILE
+echo "Test" | mkpasswd -s >> $TMPFILE
CRCYS=$(cat $TMPFILE | grep '\$' | tail -1 )
@@ -149,13 +143,13 @@
if [ x$ERRORLEVEL = x0 ]
then
- if [ -x ./mkpasswd ]
+ if [ -x @PREFIX@/bin/mkpasswd ]
then
- SUPERPASS="+"$(echo "$SUPERPASS" | ./mkpasswd -s)
- BNCPASS="+"$(echo "$BNCPASS" | ./mkpasswd -s)
+ SUPERPASS="+"$(echo "$SUPERPASS" | mkpasswd -s)
+ BNCPASS="+"$(echo "$BNCPASS" | mkpasswd -s)
else
clear
- echo "You have not did ./configure and make so there is no ./mkpasswd"
+ echo "You have not did ./configure and make so there is no mkpasswd"
echo "This program is required to produce the encryption"
bsclean 0
fi

View File

@ -1,3 +1,5 @@
bin/bnc
bin/bncchk
etc/bnc.conf
bin/bncsetup
bin/mkpasswd
etc/bnc.conf.sample