dns/libasr: update to 1.0.4 release
Changes since 1.0.2: - add definition of MAXDNAME for systems that lack it - some libc require include of nameser_compat.h for rr types definition - add support for edns0 and dnssec - remove support for HOSTALIASES - remove support for non-standard [addr]:port syntax for nameserver - remove support for YP - always reload resolv.conf if pid changed - various bugfixes and improvements
This commit is contained in:
parent
ba7400cb87
commit
019e9182f2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=535866
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libasr
|
||||
PORTVERSION= 1.0.2
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 1.0.4
|
||||
CATEGORIES= dns
|
||||
MASTER_SITES= http://www.opensmtpd.org/archives/
|
||||
|
||||
@ -18,22 +17,15 @@ USES= cpe groff libtool
|
||||
|
||||
CONFLICTS= libasr-devel-[0-9]*
|
||||
|
||||
OPTIONS_DEFINE= CA_BUNDLE
|
||||
OPTIONS_DEFAULT= CA_BUNDLE
|
||||
|
||||
CA_BUNDLE_DESC= Use NSS CA bundle for SSL instead of /etc/ssl/cert.pem
|
||||
|
||||
CPE_VENDOR= openbsd
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --with-mantype="man"
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CA_BUNDLE_CONFIGURE_WITH= ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
|
||||
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e '/opensslv.h/d' ${WRKSRC}/openbsd-compat/includes.h
|
||||
# Obsoleted on RFC 2553bis-02
|
||||
${REINPLACE_CMD} 's|EAI_NODATA|EAI_NONAME|g' \
|
||||
${WRKSRC}/src/getaddrinfo_async.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (libasr-1.0.2.tar.gz) = a6f5d1c6306938156da3427525572b9b16c1e6be6c69845d390bb63f41a58b34
|
||||
SIZE (libasr-1.0.2.tar.gz) = 406428
|
||||
TIMESTAMP = 1589901956
|
||||
SHA256 (libasr-1.0.4.tar.gz) = 19fb6bed10d15c9775c8d008cd1130155917ae4e801c729fe85e6d88a545dab4
|
||||
SIZE (libasr-1.0.4.tar.gz) = 413258
|
||||
|
10
dns/libasr/files/patch-src_getnetnamadr__async.c
Normal file
10
dns/libasr/files/patch-src_getnetnamadr__async.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/getnetnamadr_async.c.orig 2019-09-28 14:09:47 UTC
|
||||
+++ src/getnetnamadr_async.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <arpa/nameser.h>
|
||||
#include <netdb.h>
|
10
dns/libasr/files/patch-src_res__search__async.c
Normal file
10
dns/libasr/files/patch-src_res__search__async.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/res_search_async.c.orig 2019-09-28 14:09:47 UTC
|
||||
+++ src/res_search_async.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/uio.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <arpa/nameser.h>
|
||||
#include <netdb.h>
|
||||
|
@ -2,5 +2,4 @@ include/asr.h
|
||||
lib/libasr.a
|
||||
lib/libasr.so
|
||||
lib/libasr.so.0
|
||||
lib/libasr.so.0.0.2
|
||||
man/man3/asr_run.3.gz
|
||||
lib/libasr.so.0.0.3
|
||||
|
Loading…
Reference in New Issue
Block a user