Update to 1.007004 (1.7.4)

- Add LICENSE_FILE
- Use USES=shebangfix
- Use COPYTREE_SHARE instead of CP -R
- Take maintainership

Changes:	https://metacpan.org/changes/distribution/BioPerl
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2019-02-20 20:46:53 +00:00
parent 5626718d76
commit 0181afcee3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493447
5 changed files with 189 additions and 998 deletions

View File

@ -2,94 +2,76 @@
# $FreeBSD$
PORTNAME= BioPerl
PORTVERSION= 1.007002
PORTVERSION= 1.007004
CATEGORIES= biology perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CJFIELDS
MASTER_SITE_SUBDIR= CPAN:CDRAUG
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-1.7.4
MAINTAINER= perl@FreeBSD.org
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Collection of Perl modules for bioinformatics
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Algorithm-Munkres>=0:math/p5-Algorithm-Munkres \
p5-Array-Compare>=0:misc/p5-Array-Compare \
p5-CGI>=0:www/p5-CGI \
p5-Clone>=0:devel/p5-Clone \
p5-Convert-Binary-C>=0:converters/p5-Convert-Binary-C \
p5-DBD-mysql>=0:databases/p5-DBD-mysql \
p5-DBI>=0:databases/p5-DBI \
p5-Data-Stag>=0.11:devel/p5-Data-Stag \
RUN_DEPENDS= p5-DBI>=0:databases/p5-DBI \
p5-Data-Stag>=0:devel/p5-Data-Stag \
p5-Error>=0:lang/p5-Error \
p5-GD>=0:graphics/p5-GD \
p5-Graph>=0.50:math/p5-Graph \
p5-GraphViz>=0:graphics/p5-GraphViz \
p5-HTML-Parser>=3:www/p5-HTML-Parser \
p5-HTML-TableExtract>=0:www/p5-HTML-TableExtract \
p5-Graph>=0:math/p5-Graph \
p5-HTTP-Message>=0:www/p5-HTTP-Message \
p5-IO-String>=0:devel/p5-IO-String \
p5-IO-stringy>=0:devel/p5-IO-stringy \
p5-Inline-C>=0.67:devel/p5-Inline-C \
p5-IPC-Run>=0:devel/p5-IPC-Run \
p5-List-MoreUtils>=0:lang/p5-List-MoreUtils \
p5-PostScript>=0:print/p5-PostScript \
p5-SVG>=2.26:textproc/p5-SVG \
p5-SVG-Graph>=0.01:graphics/p5-SVG-Graph \
p5-Module-Build>=0:devel/p5-Module-Build \
p5-Set-Scalar>=0:devel/p5-Set-Scalar \
p5-Sort-Naturally>=0:textproc/p5-Sort-Naturally \
p5-Spreadsheet-ParseExcel>=0:textproc/p5-Spreadsheet-ParseExcel \
p5-XML-DOM>=0:textproc/p5-XML-DOM \
p5-Test-Most>=0:devel/p5-Test-Most \
p5-Test-RequiresInternet>=0:devel/p5-Test-RequiresInternet \
p5-URI>=0:net/p5-URI \
p5-XML-DOM-XPath>=0:textproc/p5-XML-DOM-XPath \
p5-XML-DOM>=0:textproc/p5-XML-DOM \
p5-XML-LibXML>=0:textproc/p5-XML-LibXML \
p5-XML-Parser>=0:textproc/p5-XML-Parser \
p5-XML-SAX>=0.15:textproc/p5-XML-SAX \
p5-XML-SAX-Base>=0:textproc/p5-XML-SAX-Base \
p5-XML-SAX-Writer>=0:textproc/p5-XML-SAX-Writer \
p5-XML-Simple>=0:textproc/p5-XML-Simple \
p5-XML-SAX>=0:textproc/p5-XML-SAX \
p5-XML-Twig>=0:textproc/p5-XML-Twig \
p5-XML-Writer>=0.400:textproc/p5-XML-Writer \
p5-XML-Writer>=0:textproc/p5-XML-Writer \
p5-YAML>=0:textproc/p5-YAML \
p5-libwww>=0:www/p5-libwww \
p5-libxml>=0:textproc/p5-libxml
TEST_DEPENDS= p5-Test-Most>=0:devel/p5-Test-Most \
p5-URI>=0:net/p5-URI
TEST_DEPENDS= p5-Test-Memory-Cycle>=0:devel/p5-Test-Memory-Cycle \
p5-Test-Weaken>=0:devel/p5-Test-Weaken
USES= perl5 shebangfix
USE_PERL5= modbuild
NO_ARCH= yes
SHEBANG_FILES= scripts/Bio-DB-SeqFeature-Store/bp_seqfeature_load.pl
USE_PERL5= configure
PORTDATA= *
PORTDOCS= *
PORTEXAMPLES= *
NO_ARCH= yes
OPTIONS_DEFINE= DOCS EXAMPLES PGTEST SQLITETEST
PGTEST_DESC= Test PostGreSQL
SQLITETEST_DESC= Test SQLite
SQLITETEST_DESC=Test SQLite
PGTEST_RUN_DEPENDS= p5-DBD-Pg>=3:databases/p5-DBD-Pg
PGTEST_BUILD_DEPENDS= p5-DBD-Pg>=3:databases/p5-DBD-Pg
SQLITETEST_RUN_DEPENDS= p5-DBD-SQLite>=1:databases/p5-DBD-SQLite
SQLITETEST_BUILD_DEPENDS= p5-DBD-SQLite>=1:databases/p5-DBD-SQLite
post-patch:
@${FIND} ${WRKSRC}/examples ${WRKSRC}/deobfuscator -name "*.pl" -o -name "*.cgi" \
-o -name "*.PL" | ${XARGS} ${REINPLACE_CMD} -i '' -Ee \
'1s|(/usr)?/bin/perl|${PERL}|'
SHEBANG_FILES= examples/*.pl examples/*/*.pl
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${CP} -R ${WRKSRC}/scripts ${WRKSRC}/models ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/models && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in AUTHORS BUGS Changes DEPENDENCIES DEPRECATED INSTALL.md MANIFEST README.md
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
${CP} -R ${WRKSRC}/deobfuscator ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS Changes MANIFEST README.md ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1505232617
SHA256 (BioPerl-1.007002.tar.gz) = 17aa3aaab2f381bbcaffdc370002eaf28f2c341b538068d6586b2276a76464a1
SIZE (BioPerl-1.007002.tar.gz) = 12362741
TIMESTAMP = 1549651825
SHA256 (BioPerl-1.7.4.tar.gz) = 5a074947bba299cdb47cbf1c66689502db02c022fc138459e3393da45d7c707b
SIZE (BioPerl-1.7.4.tar.gz) = 7642013

View File

@ -1,80 +0,0 @@
--- Bio/Root/Build.pm.orig 2014-07-10 20:13:23 UTC
+++ Bio/Root/Build.pm
@@ -83,49 +83,9 @@
}
}
closedir($scripts_dir);
- my $question = $int_ok ? "Install [a]ll BioPerl scripts, [n]one, ".
- "or choose groups [i]nteractively?" : "Install [a]ll BioPerl scripts ".
- "or [n]one?";
-
- my $prompt = $accept ? 'a' : $self->prompt($question, 'a');
-
- if ($prompt =~ /^[aA]/) {
- $self->log_info(" - will install all scripts\n");
- $self->notes(chosen_scripts => 'all');
- }
- elsif ($prompt =~ /^[iI]/) {
- $self->log_info(" - will install interactively:\n");
-
- my @chosen_scripts;
- foreach my $group_dir (@group_dirs) {
- my $group = File::Basename::basename($group_dir);
- print " * group '$group' has:\n";
-
- my @script_files = @{$self->rscan_dir($group_dir, qr/\.PLS$|\.pl$/)};
- foreach my $script_file (@script_files) {
- my $script = File::Basename::basename($script_file);
- print " $script\n";
- }
-
- my $result = $self->prompt(" Install scripts for group '$group'? [y]es [n]o [q]uit", 'n');
- die if $result =~ /^[qQ]/;
- if ($result =~ /^[yY]/) {
- $self->log_info(" + will install group '$group'\n");
- push(@chosen_scripts, @script_files);
- }
- else {
- $self->log_info(" - will not install group '$group'\n");
- }
- }
- my $chosen_scripts = @chosen_scripts ? join("|", @chosen_scripts) : 'none';
-
- $self->notes(chosen_scripts => $chosen_scripts);
- }
- else {
- $self->log_info(" - won't install any scripts\n");
- $self->notes(chosen_scripts => 'none');
- }
+ $self->log_info(" - willt install all scripts\n");
+ $self->notes(chosen_scripts => 'all');
print "\n";
}
@@ -1153,22 +1113,9 @@
sub prompt_for_network {
my ($self, $accept) = @_;
- my $proceed = $accept ? 0 : $self->y_n( "Do you want to run tests that require connection to servers across the internet\n"
- . "(likely to cause some failures)? y/n", 'n');
-
- if ($proceed) {
- $self->notes('network' => 1);
- $self->log_info(" - will run internet-requiring tests\n");
- my $use_email = $self->y_n("Do you want to run tests requiring a valid email address? y/n",'n');
- if ($use_email) {
- my $address = $self->prompt("Enter email address:");
- $self->notes(email => $address);
- }
- }
- else {
- $self->notes(network => 0);
- $self->log_info(" - will not run internet-requiring tests\n");
- }
+ my $proceed = 0;
+ $self->notes(network => 0);
+ $self->log_info(" - will not run internet-requiring tests\n");
}
=head2 print_build_script

View File

@ -1,114 +0,0 @@
--- Build.PL.orig 2016-11-06 03:59:41 UTC
+++ Build.PL
@@ -226,7 +226,6 @@ my $build = Bio::Root::Build->new(
build_requires => {
'Module::Build' => 0.42,
- 'CPAN' => 1.81,
'Test::Harness' => 2.62,
'Test::Most' => 0,
'URI::Escape' => 0
@@ -413,101 +412,8 @@ sub test_biodbgff {
sub prompt_for_biodb {
my $accept = shift;
- my $proceed = $accept ? 0 : $build->y_n(
- "Do you want to run the Bio::DB::GFF or "
- . "Bio::DB::SeqFeature::Store live database tests? " . "y/n",
- 'n'
- );
-
- if ($proceed) {
- my @driver_choices;
- foreach my $poss ( 'SQLite', 'mysql', 'Pg', 'Oracle' ) {
- if ( grep {/$poss/i} @drivers ) {
- my $choice = $poss;
- $choice =~ s/^(.)/[$1]/;
- push( @driver_choices, $choice );
- }
- }
-
- my $driver;
- if ( @driver_choices > 1 ) {
- my ($default) = $driver_choices[0] =~ /\[(.)/;
- $driver = $build->prompt(
- "Which database driver should be used? "
- . join( " ", @driver_choices ),
- $default
- );
- } else {
- ($driver) = $driver_choices[0] =~ /\[(.)/;
- }
- if ( $driver =~ /^[mM]/ ) {
- $driver = 'mysql';
- } elsif ( $driver =~ /^[pP]/ ) {
- $driver = 'Pg';
- } elsif ( $driver =~ /^[oO]/ ) {
- $driver = 'Oracle';
- } elsif ( $driver =~ /^[sS]/ ) {
- $driver = 'SQLite';
- }
-
- my $test_db = $build->prompt(
- "Which database should I use for testing the $driver driver?\n"
- . "This database should already be present but doesn't have to "
- . "be preloaded for any schema",
- 'test'
- );
- my $test_host = $build->prompt(
- "On which host is database '$test_db' running (hostname, ip address or host:port)",
- 'localhost'
- );
- my $test_user = $build->prompt(
- "User name for connecting to database '$test_db'?", 'undef' );
- my $test_pass = $build->prompt(
- "Password for connecting to database '$test_db'?", 'undef' );
-
- my $use_host = 1;
- if ( $test_host eq 'undef' || $test_host eq 'localhost' ) {
- $use_host = 0;
- }
-
- my $test_dsn;
- if ( $driver eq 'Pg' || $driver eq 'SQLite' ) {
- $test_dsn = "dbi:$driver:dbname=$test_db";
- $mysql_ok = 0;
- } else {
- $test_dsn = "dbi:$driver:database=$test_db";
- $mysql_ok = 0;
- }
- if ($use_host) {
- $test_dsn .= ";host=$test_host";
- }
-
- $build->notes( dbd_driver => $driver );
- $build->notes( test_db => $test_db );
- $build->notes( test_host => $test_host );
- $build->notes(
- test_user => $test_user eq 'undef' ? undef : $test_user );
- $build->notes(
- test_pass => $test_pass eq 'undef' ? undef : $test_pass );
- $build->notes( test_dsn => $test_dsn );
-
- $build->log_info(
- " - will run tests with database driver '$driver' and these settings:\n",
- " Database $test_db\n",
- " Host $test_host\n",
- " DSN $test_dsn\n",
- " User $test_user\n",
- " Password $test_pass\n"
- );
- $build->log_info( " - will not run the BioDBSeqFeature live "
- . "database tests (requires MySQL or Pg driver)\n" )
- unless ( $driver eq 'mysql' or $driver eq 'Pg' );
- } else {
- $build->log_info(
- " - will not run the BioDBGFF or BioDBSeqFeature live database tests\n"
- );
- }
-
+ my $proceed = 0;
+ $build->log_info(" - will not run the BioDBGFF or BioDBSeqFeature live database tests\n");
$build->log_info("\n");
return $proceed;
}

File diff suppressed because it is too large Load Diff