- Update to version 3.99.4

PR:		57094
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-09-24 15:03:39 +00:00
parent 780db7e410
commit 0179d073c1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89240
23 changed files with 192 additions and 892 deletions

View File

@ -6,38 +6,38 @@
#
PORTNAME= elk
PORTVERSION= 3.0.3
PORTVERSION= 3.99.4
CATEGORIES= lang scheme
MASTER_SITES= http://www-rn.informatik.uni-bremen.de/software/elk/dist/
DISTNAME= elk-3.0
MASTER_SITES= http://sam.zoy.org/projects/elk/
MAINTAINER= ports@FreeBSD.org
COMMENT= An embeddable Scheme interpreter
USE_XLIB= yes
ALL_TARGET= default
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
elf.0:${PORTSDIR}/devel/libelf
USE_BZIP2= yes
USE_MOTIF= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= # none
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
MAN1= elk.1
post-patch:
@${CP} ${WRKSRC}/config/untested/386pc-freebsd2.1-cc \
${WRKSRC}/config/system
@${CP} ${WRKSRC}/config/sites/386pc-freebsd2.1 \
${WRKSRC}/config/site
CPPFLAGS= -I${LOCALBASE}/include/libelf -I${LOCALBASE}/include \
-DHAVE_SYS_TIMES_H
LDFLAGS= -L${LOCALBASE}/lib
pre-install:
@${MKDIR} ${PREFIX}/share/elk
#
# we install the scheme binary as ${PREFIX}/bin/elk
# to avoid a clash with mit-scheme.
#
post-install:
${INSTALL_PROGRAM} ${PREFIX}/share/elk/bin/scheme ${PREFIX}/bin/elk
@${MKDIR} ${PREFIX}/include/elk
${CP} -R ${PREFIX}/share/elk/include/* ${PREFIX}/include/elk
.for dir in bin include
@${RM} -rf ${PREFIX}/share/elk/${dir}
.endfor
@${INSTALL_MAN} ${WRKSRC}/doc/man/elk.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/man/elk.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
@${TAR} -C ${WRKSRC}/examples --exclude "*Makefile*" -cf - . | \
${TAR} -C ${EXAMPLESDIR} --unlink -xf -
@${CHOWN} -R ${SHAREMODE}:${SHAREGRP} ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (elk-3.0.tar.gz) = c70387e71c2f0041ccd41aecae6d308a
MD5 (elk-3.99.4.tar.bz2) = 673c9a3e6b449c2c1989ce39d1694cf6

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Sat Sep 13 15:34:23 2003
+++ Makefile.in Sun Sep 14 05:02:54 2003
@@ -167,7 +167,7 @@
target_vendor = @target_vendor@
NULL =
-SUBDIRS = include src lib scm doc examples
+SUBDIRS = include src lib scm
DIST_SUBDIRS = $(SUBDIRS) autotools debian
EXTRA_DIST = \

View File

@ -1,15 +0,0 @@
--- Makefile.orig Mon Jul 31 07:56:26 1995
+++ Makefile Sun Dec 12 16:29:07 1999
@@ -16,9 +16,9 @@
lib/unix\
lib/xlib\
lib/xt\
- lib/xaw\
- lib/xm\
- lib/xm/xt
+ lib/xaw
+# lib/xm\
+# lib/xm/xt
# ----------------------------------------------------------------------

View File

@ -1,32 +0,0 @@
--- doc/man/elk.1.orig Fri Aug 11 09:27:03 1995
+++ doc/man/elk.1 Sun Dec 12 16:29:07 1999
@@ -2,9 +2,9 @@
.TH ELK 1 "15 January 1991"
.UC 4
.SH NAME
-elk, scheme \- extensible Scheme interpreter
+elk \- extensible Scheme interpreter
.SH SYNOPSIS
-.B scheme
+.B elk
[
.B \-l \f2file\fP
] [
@@ -20,8 +20,6 @@
] [[
.B \-\^\-
] \f2args\fP]
-.LP
-.BR elk .\|.\|.
.SH DESCRIPTION
.I Elk
(Extension Language Kit) is a Scheme implementation designed
@@ -32,7 +30,7 @@
is linked with the application it serves, but a stand-alone version
of the Scheme interpreter is installed as well (usually under
the name
-.BR scheme ).
+.BR elk ).
This interpreter, together with the standard Scheme toplevel,
.I Elk
can be used as an ordinary, stand-alone implementation of the

View File

@ -1,83 +0,0 @@
--- config/sites/386pc-freebsd2.1.orig Sun Dec 12 16:29:07 1999
+++ config/sites/386pc-freebsd2.1 Sun Dec 12 16:29:07 1999
@@ -0,0 +1,80 @@
+# This is a shell script. It is sourced by the build scripts in the
+# various subdirectories to gather site- and installation-specific
+# information required for building the Makefiles.
+#
+# This script is read after the "system" file, therefore you can place
+# variable settings here to override those from "system".
+#
+# Some variables in this script are interpreted as boolean variables and
+# indicate presence or absence of one specific feature. The value "yes"
+# is regarded as "true", all other values (including no value or even
+# non-existence of the variable) are interpreted as "false".
+#
+# Do not forget to quote values that contain shell meta syntax.
+#
+# -----------------------------------------------------------------------
+
+
+# The directory where all files are installed by running "make install".
+# The subdirectories bin, lib, include, and runtime (with various
+# subdirectories) are created automatically, but $install_dir isn't.
+# Make sure $install_dir doesn't point to the top of the source tree
+# (i.e. choose a subdirectory or a directory outside the source tree).
+
+install_dir=${PREFIX}/share/elk
+
+
+# Libraries against which to link the X11 extension (typically -lX11).
+#
+# Any of the following library lists may be prefixed by something like
+# -L/usr/X11/lib if the X-libraries do not reside in a standard directory;
+# an additional -R/usr/X11/lib and -lsocket may be required in case of
+# SunOS 5.x/SysVR4).
+
+libxlib="-L${X11BASE}/lib -lX11"
+
+# Libraries against which to link the Xt extension (typically
+# -lXaw -lXmu -lXt -lSM -lICE -lXext -lX11). -lXaw is needed to get the correct
+# definition of the vendor shell widget class
+
+libxt="-L${X11BASE}/lib -lX11 -lXext -lICE -lSM -lXt -lXmu -lXaw"
+
+
+# Libraries against which to link the Athena widgets extension (typically
+# identical to libxt above)
+
+libxaw="-L${X11BASE}/lib -lX11 -lXext -lICE -lSM -lXt -lXmu -lXaw"
+
+
+# Libraries against which to link the Motif extension (typically like
+# libaw above with Xaw replaced by Xm)
+
+libxmotif="-L${X11BASE}/lib -lX11 -lXext -lICE -lSM -lXt -lXmu -lXm"
+
+
+# Additional flags (typically -Isomething) to be supplied to the C
+# compiler when compiling an X11 application, or a Motif application,
+# respectively.
+
+x11_incl=-I${X11BASE}/include
+motif_incl=-I${X11BASE}/include
+
+
+# Set "gdbm" to "yes" if you have the GNU gdbm library installed and
+# want the gdbm extension to be compiled. "gdbm_inc" gives additional
+# C compiler flags required to compile a program using gdbm.
+
+gdbm=
+gdbm_incl=-I${PREFIX}/include/gdbm
+
+
+# Do you want to use the generational garbage collector? If not, the
+# stop-and-copy garbage collector will be used.
+
+generational_gc=yes
+
+
+# The default heap size of the Scheme interpreter in KBytes (if the
+# stop-and-copy garbage collector is used).
+
+default_heap_size=1024

View File

@ -1,373 +0,0 @@
--- config/untested/386pc-freebsd2.1-cc.orig Sun Dec 12 16:29:07 1999
+++ config/untested/386pc-freebsd2.1-cc Sun Dec 12 16:29:07 1999
@@ -0,0 +1,370 @@
+# This is a shell script. It is sourced by the build scripts in the
+# various subdirectories to gather system-, compiler-, and OS-specific
+# information required for building the Makefiles.
+#
+# Most variables in this script are interpreted as boolean variables and
+# indicate presence or absence of one specific feature. The value "yes"
+# is regarded as "true", all other values (including no value or even
+# non-existence of the variable) are interpreted as "false".
+#
+# Do not forget to quote values that contain shell meta syntax.
+#
+# -----------------------------------------------------------------------
+
+
+# $system should contain the name of this file. It may be used by some
+# of the build scripts to do things that are specific to one single
+# type of system.
+
+system=386pc-freebsd2.1-cc
+
+
+# Does the system support the vprintf library function? If not,
+# availability of the (non-portable) _doprnt function is assumed.
+
+vprintf=yes
+
+
+# Does the directory(3) library follow the POSIX conventions (i.e.
+# requires the <dirent.h> include file and uses "struct dirent")?
+# If not, the (obsolete) BSD-style interface with <sys/dir.h> and
+# "struct direct" is assumed.
+
+dirent=yes
+
+
+# Does the system have the random/srandom library functions? If not,
+# rand/srand will be used instead.
+
+random=yes
+
+
+# Does the system have the index library function? If not, strchr
+# will be used.
+
+index=yes
+
+
+# Does the system have the bcopy, bzero, and bcmp library functions?
+# If not, memcpy/memset/memcmp will be used.
+
+bstring=yes
+
+
+# Does using the access system call require <unistd.h> to be included?
+# (Look into the manual page for access if in doubt.)
+
+include_unistd_h=yes
+
+
+# If the FIONREAD ioctl command is defined, which file must be included?
+
+fionread_include='<sys/ioctl.h>'
+
+
+# What is the name of the a.out include file?
+
+aout_h='<a.out.h>'
+
+
+# The following variables control how certain system limits are obtained
+# during runtime.
+#
+# If getdtablesize() is available to determine the maximum number of open
+# files per process, set getdtablesize=yes.
+# Alternatively, if POSIX-style sysconf() can be called with _SC_OPEN_MAX,
+# set sysconf_open_max=yes.
+# If neither is set to "yes", an educated guess will be made.
+
+getdtablesize=yes
+sysconf_open_max=yes
+
+# If POSIX-style pathconf() can be invoked with _PC_PATH_MAX to determine
+# the maximum pathname length, set pathconf_path_max=yes.
+
+pathconf_path_max=yes
+
+# If the system page size can be determined by calling getpagesize()
+# set getpagesize=yes.
+# Alternatively, if sysconf() can be invoked with _SC_PAGESIZE, set
+# sysconf_pagesize=yes.
+# These two variables are only required if the generational garbage
+# collector is used.
+
+getpagesize=yes
+sysconf_pagesize=no
+
+
+# Set reliable_signals=bsd if your system supports BSD-style reliable
+# signals (has sigblock and related functions); set reliable_signals=posix
+# for POSIX-style signals (sigprocmask, sigsets); otherwise old V7/SysV
+# signal semantics are assumed.
+
+reliable_signals=bsd
+
+
+# To support dynamic loading of object files and "dump", the system's
+# a.out format has to be known. Choose one of the following:
+#
+# coff ecoff xcoff elf macho hp9k convex
+#
+# Other values of "aout_format" are interpreted as BSD-style a.out format.
+
+aout_format=
+
+
+# Which mechanism should be used to dynamically load object files?
+# Possible values currently are:
+#
+# ld BSD-style incremental loading based on ld -A
+# rld NeXT-style rld_load()
+# shl HP-UX shl_load()
+# dl SysVR4/SunOS5 dlopen()
+#
+# Leave load_obj empty if dynamic loading is not supported.
+
+load_obj=dl
+
+
+ # The following variables are only relevant if load_obj is set.
+
+ # Linker options to produce a shared object from a .o file.
+ # Only used if load_obj=dl.
+
+ ldflags_shared='-Bshareable'
+
+ # The libraries against which dynamically loaded files are resolved
+ # at the time they are loaded.
+
+ load_libraries=
+
+ # Does the ld-option -x really do what the manual says it does (i.e.
+ # omit local symbols), or does it somehow render the resulting object
+ # file unsuitable for dynamic loading? If in doubt, leave it out
+ # (which may result in somewhat larger object files).
+
+ incremental_ldflags=-x
+
+ # Systems with "aout_format=ecoff" may require a call to the cacheflush
+ # system call after an object file has been loaded. Which include file
+ # has to be included in this case?
+
+ cachectl_h=unused
+
+ # Is the ANSI-C atexit function supported to register an exit handler?
+ # If not, the exit library function will be redefined and will end in
+ # a call to _exit.
+
+ atexit=yes
+
+
+# Do the names of external functions in the symbol table always begin
+# with a special character (such as underline)? If so, syms_begin_with
+# should hold this character, otherwise leave it empty.
+
+syms_begin_with=_
+
+
+# The symbol prefixes of extension initialization and finalization
+# functions (without the initial $syms_begin_with). Do not change
+# these unless the compiler or linker restricts the length of symbols!
+
+init_prefix=elk_init_
+finit_prefix=elk_finit_
+
+
+# Is the "dump" function supported?
+
+can_dump=no
+
+
+# The following variables are only relevant if "can_dump=yes".
+
+ # Is the fchmod system call broken or unavailable?
+
+ fchmod_broken=no
+
+ # These four variables are only relevant if the system has the BSD-style
+ # a.out format.
+ # segment_size is the segment size of the system's memory management
+ # unit, i.e. the number to a multiple of which the size of an a.out
+ # segment (e.g. .text) is rounded up.
+ # file_text_start is the file offset at which the text segment starts
+ # in an a.out file.
+ # mem_text_start is the starting address of the text segment in memory.
+ # text_length_adj must be set to "sizeof (struct exec)" if the length of
+ # the text segment stored in the a.out header includes the a.out header
+ # itself.
+
+ segment_size=__LDPGSZ
+ file_text_start='(N_TXTOFF(hdr) + sizeof(struct exec))'
+ mem_text_start='(sizeof(struct exec) + getpagesize())'
+ text_length_adj='(sizeof(struct exec))'
+
+ # Only relevant if "aout_format=coff": the system's pagesize.
+
+ coff_pagesize=
+
+ # Only relevant if "aout_format=hp9k" and "load_obj=shl"
+
+ hp_shared_libraries=yes
+
+ # Print debug messages when dumping
+
+ debug_dump=yes
+
+
+# Is the "termio" terminal interface supported by the system? If not,
+# BSD-style tty handling will be used.
+
+termio=yes
+
+
+# flush_stdio and flush_tty indicate how clear-input/output-port can
+# flush (purge) a FILE pointer and a TTY file descriptor.
+# Possible values of flush_stdio:
+# bsd assume old BSD-style FILE* (with _cnt, _ptr, _base)
+# fpurge use 4.4BSD-style fpurge stdio library function
+# linux use Linux-specific method
+# Possible values of flush_tty:
+# tiocflush use TIOCFLUSH ioctl from <sys/ioctl.h>
+# tcflsh use TCFLSH ioctl from <termio.h>
+# Leave the variable(s) empty if flushing is not supported.
+
+flush_stdio=fpurge
+flush_tty=tiocflush
+
+
+# The interpreter uses the getrlimit function to determine the maximum
+# stack size of the running program. If this function is not supported,
+# set max_stack_size to a (fixed) maximum stack size (in bytes).
+
+max_stack_size=
+
+
+# Is the mprotect system call supported? The generational garbage collector
+# requires mprotect to implement incremental GC. $mprotect is ignored if
+# generational_gc is set to "no" in the site file. Set mprotect=mmap if
+# mprotect is supported, but only for mmap()ed memory.
+
+mprotect=yes
+
+
+# How can a SIGSEGV or SIGBUS signal handler find out the address of
+# the faulting memory reference? This variable is only used if
+# $mprotect is "yes" or "mmap". Possible values are:
+#
+# siginfo handler is called with siginfo_t structure (enabled
+# by a call to sigaction)
+# sigcontext address is in the sigcontext structure (3rd arg, sc_badvaddr)
+# arg4 address is delivered to handler as argument #4
+# aix use an AIX-specific hack to get hold of the bad address
+# hpux use a HP-UX-specific hack
+
+sigsegv_addr=arg4
+
+
+# Does the system support the alloca library function, and does this
+# function actually extend the stack? If in doubt, extract alloca.o
+# from the C library and check if it contains the symbols malloc and free.
+# If this is the case, forget it.
+
+use_alloca=yes
+
+
+# Must <alloca.h> be included to use alloca? Is "#pragma alloca" required?
+
+include_alloca_h=no
+pragma_alloca=no
+
+
+# Does the system (or compiler) require certain objects (e.g. doubles)
+# to be aligned at 8-byte boundaries? If not, 4-byte alignment will
+# be assumed.
+
+align_8byte=yes
+
+
+# The C compiler used to compile the source code.
+
+cc=cc
+
+
+# The name of the linker. This is usually just "ld", or /usr/ccs/bin/ld
+# in SVR4-based systems.
+
+ld=ld
+
+
+# The C compiler flags used for all files.
+
+cflags=$CFLAGS
+
+
+# Are extra C compiler flags (such as -D_NO_PROTO) required to compile
+# Motif applications?
+
+motif_cflags=
+
+
+# Are extra C compiler flags (such as -G 0) required to compile
+# dynamically loadable files?
+
+obj_cflags='-fpic -DPIC'
+
+
+# Are extra linker flags (such as -G 0) required to link several object
+# files together to one dynamically loadable file?
+
+obj_ldflags=
+
+
+# The linker flags used to link the interpreter.
+
+ldflags='-lm'
+
+
+# The lint flags.
+
+lintflags='-abxh'
+
+
+# Are function prototypes in the header files required? If prototypes=yes,
+# prototypes are used unconditionally; if prototypes=no, prototypes are
+# not used; otherwise prototypes are only used if the source code is
+# compiled with an ANSI-C- or C++-compiler.
+
+prototypes=yes
+
+
+# Does your C preprocessor support the ANSI-C ## operator, although
+# __STDC__ is not defined?
+
+ansi_cpp=no
+
+
+# The UNIX extension likes to know which of the following system calls,
+# library functions, and include files are supported by the system.
+
+gettimeofday=yes
+ftime=
+vfork=yes
+gethostname=yes
+uname=yes
+mktemp=yes
+tmpnam=yes
+tempnam=yes
+getcwd=yes
+getwd=yes
+rename=yes
+waitpid=yes
+wait3=yes
+wait4=yes
+utime_h=yes
+regcomp=yes
+
+
+# Element type of the gidset argument of getgroups(); typically int
+# or gid_t. Only needed by the UNIX extension.
+
+getgroups_type=gid_t

View File

@ -1,30 +0,0 @@
--- src/dump-vanilla.c.orig Thu Jun 29 06:55:51 1995
+++ src/dump-vanilla.c Sun Dec 12 16:29:07 1999
@@ -12,6 +12,10 @@
extern void *sbrk();
+#if defined(__FreeBSD__)
+extern etext;
+#endif
+
#if defined(hp9000s300) || defined(__hp9000s300) || defined(__hp9000s300__)
static int getpagesize () {
return EXEC_PAGESIZE;
@@ -113,13 +117,15 @@
close (afd);
#if defined(__bsdi__)
data_start = N_DATADDR(hdr);
+#elif defined (__FreeBSD__)
+ data_start = (int) &etext;
#else
data_start = hdr.a_text;
+#endif
#if defined(sun) || defined(__sun__)
data_start += pagemask+1;
#endif
data_start = (data_start + SEG_SIZ-1) & ~(SEG_SIZ-1);
-#endif
data_end = (unsigned)sbrk (0);
#if !defined(__bsdi__)
data_end = (data_end + pagemask) & ~pagemask;

View File

@ -1,61 +0,0 @@
--- src/print.c.orig Thu Apr 4 15:25:04 1996
+++ src/print.c Thu Aug 7 18:42:43 2003
@@ -5,7 +5,8 @@
#include <errno.h>
#include <ctype.h>
-#include <varargs.h>
+#include <string.h>
+#include <stdarg.h>
#ifdef FLUSH_TIOCFLUSH
# include <sys/ioctl.h>
@@ -95,15 +96,11 @@
#endif
/*VARARGS0*/
-Printf (va_alist) va_dcl {
+Printf (Object port, char *fmt, ...) {
va_list args;
- Object port;
- char *fmt;
char buf[1024];
- va_start (args);
- port = va_arg (args, Object);
- fmt = va_arg (args, char *);
+ va_start (args, fmt);
if (PORT(port)->flags & P_STRING) {
vsprintf (buf, fmt, args);
Print_String (port, buf, strlen (buf));
@@ -555,10 +552,6 @@
char *p;
register c;
char buf[256];
- extern sys_nerr;
-#ifndef __bsdi__
- extern char *sys_errlist[];
-#endif
GC_Node;
Alloca_Begin;
@@ -573,13 +566,13 @@
} else if (c == '%') {
Print_Char (port, '\n');
} else if (c == 'e' || c == 'E') {
- if (Saved_Errno > 0 && Saved_Errno < sys_nerr) {
- s = sys_errlist[Saved_Errno];
- sprintf (buf, "%c%s", isupper (*s) ? tolower (*s) :
- *s, s+1);
- } else {
- sprintf (buf, "error %d", Saved_Errno);
+ if (strerror_r(Saved_Errno, buf, sizeof(buf)) != 0) {
+ snprintf(buf, sizeof(buf) - 1, "unknown error: %d",
+ Saved_Errno);
+ buf[sizeof(buf) - 1] = '\0';
}
+ if (isupper(buf[0]))
+ buf[0] = tolower(buf[0]);
Print_Object (Make_String (buf, strlen (buf)), port,
c == 'E', 0, 0);
} else {

View File

@ -1,13 +0,0 @@
--- src/load-dl.c.orig Fri Dec 22 08:46:24 1995
+++ src/load-dl.c Sun Dec 12 16:29:07 1999
@@ -4,6 +4,10 @@
extern char *strrchr();
extern char *getenv();
+#ifndef RTLD_NOW
+#define RTLD_NOW 1
+#endif
+
Dlopen_File (fn) char *fn; {
void *handle;
SYM *sp;

View File

@ -1,11 +0,0 @@
--- src/build.orig Mon Jan 24 10:12:31 1994
+++ src/build Sun Dec 12 16:29:08 1999
@@ -22,7 +22,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags
LDFLAGS= $ldflags
LINTFLAGS= $lintflags

View File

@ -1,11 +0,0 @@
--- lib/misc/build.orig Thu Jul 27 07:22:40 1995
+++ lib/misc/build Sun Dec 12 16:29:08 1999
@@ -15,7 +15,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags $obj_cflags
LINTFLAGS= $lintflags

View File

@ -1,11 +0,0 @@
--- lib/unix/build.orig Tue Jul 18 06:07:06 1995
+++ lib/unix/build Sun Dec 12 16:29:08 1999
@@ -7,7 +7,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags $obj_cflags
LINTFLAGS= $lintflags

View File

@ -1,11 +0,0 @@
--- lib/xaw/build.orig Tue Jul 18 06:29:49 1995
+++ lib/xaw/build Sun Dec 12 16:29:08 1999
@@ -7,7 +7,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags $obj_cflags
LINTFLAGS= $lintflags
SCMFLAGS= -p .:../../scm:../xt

View File

@ -1,11 +0,0 @@
--- lib/xlib/build.orig Tue Jul 18 06:19:11 1995
+++ lib/xlib/build Sun Dec 12 16:29:08 1999
@@ -7,7 +7,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags $obj_cflags
LINTFLAGS= $lintflags

View File

@ -1,11 +0,0 @@
--- lib/xm/build.orig Tue Jul 18 06:22:31 1995
+++ lib/xm/build Sun Dec 12 16:29:08 1999
@@ -9,7 +9,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags $obj_cflags $motif_cflags
LINTFLAGS= $lintflags
SCMFLAGS= -p .:../../scm:../xt

View File

@ -1,11 +0,0 @@
--- lib/xt/build.orig Tue Jul 18 06:21:52 1995
+++ lib/xt/build Sun Dec 12 16:29:08 1999
@@ -7,7 +7,7 @@
SHELL=/bin/sh
-CC= ${cc-cc}
+CC?= cc
CFLAGS= $cflags $obj_cflags
LINTFLAGS= $lintflags

View File

@ -1,44 +0,0 @@
--- src/error.c.orig Thu Aug 7 18:31:32 2003
+++ src/error.c Thu Aug 7 18:38:46 2003
@@ -1,5 +1,5 @@
#include <ctype.h>
-#include <varargs.h>
+#include <stdarg.h>
#include "kernel.h"
@@ -40,13 +40,11 @@
/*VARARGS1*/
Fatal_Error (foo) char *foo; { foo = foo; }
#else
-Fatal_Error (va_alist) va_dcl {
+Fatal_Error (char *fmt, ...) {
va_list args;
- char *fmt;
Disable_Interrupts;
- va_start (args);
- fmt = va_arg (args, char *);
+ va_start (args, fmt);
(void)fflush (stdout);
if (appname)
fprintf (stderr, "\n%s: fatal error: ", appname);
@@ -89,15 +87,14 @@
/*VARARGS1*/
Primitive_Error (foo) char *foo; { foo = foo; }
#else
-Primitive_Error (va_alist) va_dcl {
+Primitive_Error (char *fmt, ...) {
va_list args;
- register char *p, *fmt;
+ register char *p;
register i, n;
Object msg, sym, argv[10];
GC_Node; GCNODE gcv;
- va_start (args);
- fmt = va_arg (args, char *);
+ va_start (args, fmt);
for (n = 0, p = fmt; *p; p++)
if (*p == '~' && p[1] != '~' && p[1] != '%'
&& p[1] != 'E' && p[1] != 'e')

View File

@ -1,31 +0,0 @@
--- include/extern.h.orig Thu Aug 7 18:36:06 2003
+++ include/extern.h Thu Aug 7 19:00:01 2003
@@ -82,8 +82,8 @@
/* Error handling
*/
-extern Primitive_Error P_((ELLIPSIS));
-extern Fatal_Error P_((ELLIPSIS));
+extern Primitive_Error P_((char*, ...));
+extern Fatal_Error P_((char*, ...));
extern Range_Error P_((Object));
extern Panic P_((const char*));
extern Object P_Error P_((int, Object*));
@@ -313,7 +313,7 @@
extern Object P_Get_Output_String P_((Object));
extern Check_Output_Port P_((Object));
extern Discard_Output P_((Object));
-extern Printf P_((ELLIPSIS));
+extern Printf P_((Object, char*, ...));
extern Print_Object P_((Object, Object, int, int, int));
extern General_Print_Object P_((Object, Object, int));
extern Format P_((Object, const char*, int, int, Object*));
@@ -433,7 +433,7 @@
*/
extern void Register_Object P_((Object, GENERIC, PFO, int));
extern void Deregister_Object P_((Object));
-extern Object Find_Object P_((ELLIPSIS));
+extern Object Find_Object P_((int, GENERIC, MATCHFUN, ...));
extern void Terminate_Group P_((GENERIC));
extern void Terminate_Type P_((int));

View File

@ -1,31 +0,0 @@
--- src/terminate.c.orig Thu Aug 7 18:57:35 2003
+++ src/terminate.c Thu Aug 7 19:09:22 2003
@@ -1,7 +1,7 @@
/* Termination functions, weak pointers.
*/
-#include <varargs.h>
+#include <stdarg.h>
#include "kernel.h"
@@ -50,17 +50,11 @@
* Null is returned when the object has not been found.
*/
/*VARARGS*/
-Object Find_Object (va_alist) va_dcl {
+Object Find_Object (int type, GENERIC group, MATCHFUN match, ...) {
WEAK_NODE *p;
- int type;
- GENERIC group;
- MATCHFUN match;
va_list args;
- va_start (args);
- type = va_arg (args, int);
- group = va_arg (args, GENERIC);
- match = va_arg (args, MATCHFUN);
+ va_start (args, match);
for (p = first; p; p = p->next) {
if (TYPE(p->obj) != type || p->group != group)
continue;

View File

@ -0,0 +1,10 @@
--- configure.orig Sat Sep 13 15:34:27 2003
+++ configure Sun Sep 14 02:26:51 2003
@@ -18769,6 +18769,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View File

@ -9,4 +9,4 @@ inventing and implementing yet another extension language, application
programmers can integrate Elk into their application to make it
extensible and highly customizable.
WWW: http://www-rn.informatik.uni-bremen.de/software/elk/
WWW: http://sam.zoy.org/projects/elk/

View File

@ -1,91 +1,160 @@
bin/elk
include/elk/compat.h
include/elk/config.h
include/elk/cstring.h
include/elk/exception.h
include/elk/extensions/unix.h
include/elk/extensions/xlib.h
include/elk/extensions/xt.h
include/elk/extern.h
include/elk/funcproto.h
include/elk/gc.h
include/elk/intern.h
include/elk/kernel.h
include/elk/misc.h
include/elk/object.h
include/elk/param.h
include/elk/scheme.h
include/elk/site.h
include/elk/stkmem.h
include/elk/type.h
include/elk/extensions/unix.h
include/elk/extensions/xlib.h
include/elk/extensions/xt.h
share/elk/lib/ldflags
share/elk/lib/linkscheme
share/elk/lib/makedl
share/elk/lib/module.o
share/elk/lib/standalone.o
share/elk/runtime/obj/bitstring.o
share/elk/runtime/obj/debug.o
share/elk/runtime/obj/elk-eval.o
share/elk/runtime/obj/hack.o
share/elk/runtime/obj/monitor.o
share/elk/runtime/obj/newhandler.o
share/elk/runtime/obj/record.o
share/elk/runtime/obj/regexp.o
share/elk/runtime/obj/struct.o
share/elk/runtime/obj/unix.o
share/elk/runtime/obj/xlib.o
share/elk/runtime/obj/xt.o
share/elk/runtime/obj/xaw/ALIASES
share/elk/runtime/obj/xaw/ascii.o
share/elk/runtime/obj/xaw/box.o
share/elk/runtime/obj/xaw/command.o
share/elk/runtime/obj/xaw/dialog.o
share/elk/runtime/obj/xaw/form.o
share/elk/runtime/obj/xaw/grip.o
share/elk/runtime/obj/xaw/label.o
share/elk/runtime/obj/xaw/list.o
share/elk/runtime/obj/xaw/menubutton.o
share/elk/runtime/obj/xaw/paned.o
share/elk/runtime/obj/xaw/panner.o
share/elk/runtime/obj/xaw/porthole.o
share/elk/runtime/obj/xaw/repeater.o
share/elk/runtime/obj/xaw/scrollbar.o
share/elk/runtime/obj/xaw/shell.o
share/elk/runtime/obj/xaw/simplemenu.o
share/elk/runtime/obj/xaw/sme.o
share/elk/runtime/obj/xaw/smebsb.o
share/elk/runtime/obj/xaw/smeline.o
share/elk/runtime/obj/xaw/stripchart.o
share/elk/runtime/obj/xaw/toggle.o
share/elk/runtime/obj/xaw/tree.o
share/elk/runtime/obj/xaw/viewport.o
share/elk/runtime/scm/apropos.scm
share/elk/runtime/scm/bitstring.scm
share/elk/runtime/scm/cscheme.scm
share/elk/runtime/scm/debug.scm
share/elk/runtime/scm/describe.scm
share/elk/runtime/scm/gdbmtest.scm
share/elk/runtime/scm/initscheme.scm
share/elk/runtime/scm/motif.scm
share/elk/runtime/scm/oops.scm
share/elk/runtime/scm/parse.scm
share/elk/runtime/scm/pp.scm
share/elk/runtime/scm/qsort.scm
share/elk/runtime/scm/record.scm
share/elk/runtime/scm/recordutil.scm
share/elk/runtime/scm/regexp.scm
share/elk/runtime/scm/safe-env.scm
share/elk/runtime/scm/setf.scm
share/elk/runtime/scm/siteinfo.scm
share/elk/runtime/scm/struct.scm
share/elk/runtime/scm/toplevel.scm
share/elk/runtime/scm/trace.scm
share/elk/runtime/scm/unix.scm
share/elk/runtime/scm/xlib.scm
share/elk/runtime/scm/xt.scm
share/elk/runtime/scm/xwidgets.scm
lib/elk/bitstring.la
lib/elk/bitstring.so
lib/elk/debug.la
lib/elk/debug.so
lib/elk/elk-eval.la
lib/elk/elk-eval.so
lib/elk/gdbm.la
lib/elk/gdbm.so
lib/elk/hack.la
lib/elk/hack.so
lib/elk/motif-widgets.la
lib/elk/motif-widgets.so
lib/elk/motif-xt.la
lib/elk/motif-xt.so
lib/elk/newhandler.la
lib/elk/newhandler.so
lib/elk/record.la
lib/elk/record.so
lib/elk/regexp.la
lib/elk/regexp.so
lib/elk/struct.la
lib/elk/struct.so
lib/elk/unix.la
lib/elk/unix.so
lib/elk/xaw-widgets.la
lib/elk/xaw-widgets.so
lib/elk/xaw-xt.la
lib/elk/xaw-xt.so
lib/elk/xlib.la
lib/elk/xlib.so
lib/libelk.a
lib/libelk.la
lib/libelk.so
lib/libelk.so.0
share/elk/apropos.scm
share/elk/bitstring.scm
share/elk/cscheme.scm
share/elk/debug.scm
share/elk/describe.scm
share/elk/gdbmtest.scm
share/elk/initscheme.scm
share/elk/motif.scm
share/elk/oops.scm
share/elk/parse.scm
share/elk/pp.scm
share/elk/qsort.scm
share/elk/record.scm
share/elk/recordutil.scm
share/elk/regexp.scm
share/elk/safe-env.scm
share/elk/setf.scm
share/elk/slib.scm
share/elk/struct.scm
share/elk/toplevel.scm
share/elk/trace.scm
share/elk/unix.scm
share/elk/xaw.scm
share/elk/xlib.scm
share/elk/xwidgets.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/c++/class.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/c++/constructor.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/drawing-area.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/list.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/main-window.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/menu-stuff.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/message-dialog.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/option-menu.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/popup-menu.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/pulldown-menu.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/radio-stuff.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/radio.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/scroll-bar.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/selection-box.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/motif/vcr.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/regexp/match.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/Y.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/acker.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/billiard.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/cc.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/cell.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/co.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/compile.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/cps.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/dynamic.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/fib.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/fix.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/flame.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/hanoi.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/kons.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/meissel.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/mondo.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/perm.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/prim.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/ramanujan.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/rungekutta.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/sqrt.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/unify.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/scheme/work.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/unix/calc.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/unix/copy.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/unix/lock.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/unix/ls.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/unix/pipsiz.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/unix/timeout.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/accel.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/clickcount.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/dialog.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/grip.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/list.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/paned.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/panner.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/popup.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/porthole.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/pulldown.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/scrollbar.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/scrollbox.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/stripchart.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/text.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/tree.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xaw/viewport.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/hello.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/lines.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/map-all.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/picture.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/poly.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/properties.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/track.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/useful.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/xlib/wm-delete.scm
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/xlib
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/xaw
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/unix
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/scheme
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/regexp
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/motif
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/c++
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm share/elk
@dirrm lib/elk
@dirrm include/elk/extensions
@dirrm include/elk
@dirrm share/elk/lib
@dirrm share/elk/runtime/obj/xaw
@dirrm share/elk/runtime/obj
@dirrm share/elk/runtime/scm
@dirrm share/elk/runtime
@dirrm share/elk