net/dhcpcd: Fix build when TOP environment viriable is set

PR:		253270
Reported by:	Volodymyr Kostyrko

(cherry picked from commit 9e078ab7b7)
This commit is contained in:
Dries Michiels 2021-10-31 13:21:37 +09:00 committed by Yasuhiro Kimura
parent 1cd8dc16bf
commit 01223a9c0d
6 changed files with 44 additions and 0 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= dhcpcd
PORTVERSION= 9.4.0
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://roy.marples.name/downloads/dhcpcd/ \
https://cflags.cc/roy/dhcpcd/

View File

@ -0,0 +1,8 @@
--- hooks/Makefile.orig 2020-12-28 12:59:20 UTC
+++ hooks/Makefile
@@ -1,4 +1,4 @@
-TOP?= ../
+TOP= ../
include ${TOP}/iconfig.mk
PROG= dhcpcd-run-hooks

View File

@ -0,0 +1,11 @@
--- src/Makefile.orig 2021-09-10 17:26:01 UTC
+++ src/Makefile
@@ -8,7 +8,7 @@ SRCS+= dhcp-common.c script.c
CFLAGS?= -O2
SUBDIRS+= ${MKDIRS}
-TOP?= ..
+TOP= ..
include ${TOP}/iconfig.mk
CSTD?= c99

View File

@ -0,0 +1,8 @@
--- src/dev/Makefile.orig 2020-12-28 12:59:20 UTC
+++ src/dev/Makefile
@@ -1,4 +1,4 @@
-TOP?= ../../
+TOP= ../../
include ${TOP}/Makefile.inc
include ${TOP}/config.mk

View File

@ -0,0 +1,8 @@
--- tests/crypt/Makefile.orig 2020-12-28 12:59:20 UTC
+++ tests/crypt/Makefile
@@ -1,4 +1,4 @@
-TOP?= ../..
+TOP= ../..
include ${TOP}/iconfig.mk
PROG= run-test

View File

@ -0,0 +1,8 @@
--- tests/eloop-bench/Makefile.orig 2020-12-28 12:59:20 UTC
+++ tests/eloop-bench/Makefile
@@ -1,4 +1,4 @@
-TOP?= ../..
+TOP= ../..
include ${TOP}/iconfig.mk
PROG= eloop-bench