Remove deprecated net-mgmt/nrpe and slave.
This is the old version of net-mgmt/nrpe, which is no longer maintained. Please use net-mgmt/nrpe3 instead, which is the currently maintained version.
This commit is contained in:
parent
cd41a9a54d
commit
01134568b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=457748
2
MOVED
2
MOVED
@ -9832,3 +9832,5 @@ misc/p5-Asterisk|misc/p5-asterisk-perl|2017-12-29|Rename to match upstream namin
|
||||
www/npm2|www/npm|2017-12-31|Has expired: use www/npm or www/npm-node* instead
|
||||
www/npm3|www/npm|2017-12-31|Has expired: use www/npm or www/npm-node* instead
|
||||
net/rubygem-fog-aws0|net/rubygem-fog-aws|2017-12-31|Has expired: use net/rubygem-fog-aws or net/rubygem-fog-aws1 instead
|
||||
net-mgmt/nrpe|net-mgmt/nrpe3|2018-01-01|nrpe 2.0 not maintained, use nrpe 3.0
|
||||
net-mgmt/nrpe-ssl|net-mgmt/nrpe3|2018-01-01|nrpe 2.0 not maintained, use nrpe 3.0
|
||||
|
@ -196,8 +196,6 @@
|
||||
SUBDIR += nfsen
|
||||
SUBDIR += ng_ipacct
|
||||
SUBDIR += nitpicker
|
||||
SUBDIR += nrpe
|
||||
SUBDIR += nrpe-ssl
|
||||
SUBDIR += nrpe3
|
||||
SUBDIR += nsca
|
||||
SUBDIR += nsca-client
|
||||
|
@ -1,80 +0,0 @@
|
||||
# Created by: Paul Dlug<paul@nerdlabs.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nrpe
|
||||
DISTVERSION= 2.15
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= SF/nagios/${PORTNAME}-2.x/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= zeising@FreeBSD.org
|
||||
COMMENT?= Nagios Remote Plugin Executor
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
CONFLICTS?= nrpe-ssl nrpe3
|
||||
|
||||
DEPRECATED= EoL, please use nrpe3 instead
|
||||
EXPIRATION_DATE= 2018-01-01
|
||||
|
||||
USES= perl5
|
||||
USE_PERL5= build
|
||||
USE_RC_SUBR= nrpe2
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
OPTIONS_DEFINE= SSL ARGS
|
||||
OPTIONS_RADIO= PLUGINS
|
||||
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
|
||||
OPTIONS_DEFAULT=ARGS NAGPLUGINS
|
||||
|
||||
SSL_DESC= Enable SSL support (disables plain-text server)
|
||||
ARGS_DESC= Enable command argument processing
|
||||
NAGPLUGINS_DESC=Use net-mgmt/nagios-plugins
|
||||
MONPLUGINS_DESC=Use net-mgmt/monitoring-plugins
|
||||
|
||||
SSL_USES= ssl
|
||||
SSL_CONFIGURE_ON= --enable-ssl --with-ssl=${OPENSSLDIR} \
|
||||
--with-ssl-inc=${OPENSSLINC} \
|
||||
--with-ssl-lib=${OPENSSLLIB}
|
||||
SSL_CONFIGURE_OFF= --disable-ssl
|
||||
SSL_CFLAGS= -I${OPENSSLINC}
|
||||
|
||||
ARGS_CONFIGURE_ON= --enable-command-args
|
||||
ARGS_CONFIGURE_OFF= --disable-command-args
|
||||
|
||||
MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/monitoring-plugins
|
||||
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/nagios-plugins
|
||||
|
||||
NAGIOSUSER?= nagios
|
||||
NAGIOSGROUP?= nagios
|
||||
USERS= ${NAGIOSUSER}
|
||||
GROUPS= ${NAGIOSGROUP}
|
||||
|
||||
NRPE_PIDDIR?= /var/run/nrpe2
|
||||
|
||||
CONFIGURE_ARGS+=--bindir=${PREFIX}/sbin \
|
||||
--libexecdir=${PREFIX}/libexec/nagios \
|
||||
--sysconfdir=${PREFIX}/etc \
|
||||
--with-nrpe-user=${NAGIOSUSER} \
|
||||
--with-nrpe-group=${NAGIOSGROUP}
|
||||
|
||||
PLIST_SUB= NAGIOSUSER=${NAGIOSUSER} \
|
||||
NAGIOSGROUP=${NAGIOSGROUP} \
|
||||
NRPE_PIDDIR=${NRPE_PIDDIR}
|
||||
SUB_LIST+= PIDDIR=${NRPE_PIDDIR}
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/var/run/nrpe.pid|${NRPE_PIDDIR}/nrpe2.pid|g' \
|
||||
-e 's|/usr/lib/nagios/plugins/|${LOCALBASE}/libexec/nagios/|g' \
|
||||
-e 's|/usr/bin/sudo|${LOCALBASE}/bin/sudo|g' \
|
||||
${WRKSRC}/sample-config/nrpe.cfg.in
|
||||
do-install:
|
||||
${INSTALL} -d ${STAGEDIR}${NRPE_PIDDIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/nrpe ${STAGEDIR}${PREFIX}/sbin/nrpe2
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/check_nrpe ${STAGEDIR}${PREFIX}/libexec/nagios/check_nrpe2
|
||||
${INSTALL_DATA} ${WRKSRC}/sample-config/nrpe.cfg ${STAGEDIR}${PREFIX}/etc/nrpe.cfg.sample
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (nrpe-2.15.tar.gz) = 66383b7d367de25ba031d37762d83e2b55de010c573009c6f58270b137131072
|
||||
SIZE (nrpe-2.15.tar.gz) = 419695
|
@ -1,54 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: nrpe2
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable nrpe2:
|
||||
# nrpe2_enable (bool): Set to "NO" by default.
|
||||
# Set it to "YES" to enable nrpe2.
|
||||
# nrpe2_flags (str): Not set by default.
|
||||
# nrpe2_configfile (str): Set to "%%PREFIX%%/etc/nrpe.cfg" by default.
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name=nrpe2
|
||||
rcvar=nrpe2_enable
|
||||
|
||||
load_rc_config "${name}"
|
||||
|
||||
: ${nrpe2_enable:=NO}
|
||||
: ${nrpe2_configfile:=%%PREFIX%%/etc/nrpe.cfg}
|
||||
|
||||
required_files="${nrpe2_configfile}"
|
||||
|
||||
command="%%PREFIX%%/sbin/nrpe2"
|
||||
command_args="-c ${nrpe2_configfile} -d"
|
||||
extra_commands=reload
|
||||
sig_reload=HUP
|
||||
|
||||
start_precmd=nrpe2_prestart
|
||||
stop_precmd=find_pidfile
|
||||
|
||||
find_pidfile()
|
||||
{
|
||||
[ -n "$nrpe2_pidfile" ] &&
|
||||
warn "No longer necessary to set nrpe2_pidfile in rc.conf[.local]"
|
||||
|
||||
if get_pidfile_from_conf pid_file ${nrpe2_configfile}; then
|
||||
pidfile="$_pidfile_from_conf"
|
||||
else
|
||||
pidfile='%%PIDDIR%%/nrpe2.pid'
|
||||
fi
|
||||
}
|
||||
|
||||
nrpe2_prestart()
|
||||
{
|
||||
find_pidfile
|
||||
install -d -o ${nrpe_user:-nagios} ${pidfile%/*}
|
||||
rm -f ${pidfile}
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
@ -1,11 +0,0 @@
|
||||
--- configure.orig 2013-09-06 15:27:13 UTC
|
||||
+++ configure
|
||||
@@ -6745,7 +6745,7 @@ _ACEOF
|
||||
sslbin=$ssldir/bin/openssl
|
||||
fi
|
||||
# awk to strip off meta data at bottom of dhparam output
|
||||
- $sslbin dhparam -C 512 | awk '/^-----/ {exit} {print}' > include/dh.h
|
||||
+ $sslbin dhparam -C 2048 | awk '/^-----/ {exit} {print}' > include/dh.h
|
||||
fi
|
||||
fi
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- sample-config/nrpe.cfg.in.orig 2007-11-24 04:01:23.000000000 +1030
|
||||
+++ sample-config/nrpe.cfg.in 2008-02-20 18:39:58.000000000 +1030
|
||||
@@ -198,7 +198,10 @@
|
||||
|
||||
command[check_users]=@libexecdir@/check_users -w 5 -c 10
|
||||
command[check_load]=@libexecdir@/check_load -w 15,10,5 -c 30,25,20
|
||||
-command[check_hda1]=@libexecdir@/check_disk -w 20% -c 10% -p /dev/hda1
|
||||
+command[check_root]=@libexecdir@/check_disk -w 20% -c 10% -p /
|
||||
+command[check_var]=@libexecdir@/check_disk -w 20% -c 10% -p /var
|
||||
+command[check_tmp]=@libexecdir@/check_disk -w 20% -c 10% -p /tmp
|
||||
+command[check_usr]=@libexecdir@/check_disk -w 20% -c 10% -p /usr
|
||||
command[check_zombie_procs]=@libexecdir@/check_procs -w 5 -c 10 -s Z
|
||||
command[check_total_procs]=@libexecdir@/check_procs -w 150 -c 200
|
||||
|
@ -1,77 +0,0 @@
|
||||
--- src/nrpe.c.orig 2013-09-06 15:27:13 UTC
|
||||
+++ src/nrpe.c
|
||||
@@ -30,6 +30,8 @@
|
||||
#include "utils.h"
|
||||
#include "acl.h"
|
||||
|
||||
+#include <poll.h>
|
||||
+
|
||||
#ifdef HAVE_SSL
|
||||
#include "../include/dh.h"
|
||||
#endif
|
||||
@@ -100,7 +102,9 @@
|
||||
int use_src=FALSE; /* Define parameter for SRC option */
|
||||
|
||||
|
||||
+#ifdef HAVE_SSL
|
||||
void complete_SSL_shutdown( SSL *);
|
||||
+#endif
|
||||
|
||||
|
||||
int main(int argc, char **argv){
|
||||
@@ -266,7 +270,7 @@ int main(int argc, char **argv){
|
||||
|
||||
/* use anonymous DH ciphers */
|
||||
SSL_CTX_set_cipher_list(ctx,"ADH");
|
||||
- dh=get_dh512();
|
||||
+ dh=get_dh2048();
|
||||
SSL_CTX_set_tmp_dh(ctx,dh);
|
||||
DH_free(dh);
|
||||
if(debug==TRUE)
|
||||
@@ -969,8 +973,14 @@
|
||||
continue;
|
||||
|
||||
/* socket is nonblocking and we don't have a connection yet */
|
||||
- if(errno==EAGAIN)
|
||||
+ if(errno==EAGAIN) {
|
||||
+ struct pollfd pfd;
|
||||
+
|
||||
+ pfd.fd = sock;
|
||||
+ pfd.events = POLLIN;
|
||||
+ poll(&pfd,1,-1);
|
||||
continue;
|
||||
+ }
|
||||
|
||||
/* fix for HP-UX 11.0 - just retry */
|
||||
if(errno==ENOBUFS)
|
||||
@@ -1207,9 +1217,13 @@
|
||||
if(result==STATE_OK && use_ssl==TRUE){
|
||||
if((ssl=SSL_new(ctx))!=NULL){
|
||||
SSL_set_fd(ssl,sock);
|
||||
+ int n = 0;
|
||||
|
||||
/* keep attempting the request if needed */
|
||||
- while(((rc=SSL_accept(ssl))!=1) && (SSL_get_error(ssl,rc)==SSL_ERROR_WANT_READ));
|
||||
+ while( ((rc=SSL_accept(ssl))!=1) && (SSL_get_error(ssl,rc)==SSL_ERROR_WANT_READ) && n <= 600){
|
||||
+ usleep(100000);
|
||||
+ n++;
|
||||
+ }
|
||||
|
||||
if(rc!=1){
|
||||
syslog(LOG_ERR,"Error: Could not complete SSL handshake. %d\n",SSL_get_error(ssl,rc));
|
||||
@@ -1796,6 +1810,7 @@
|
||||
return OK;
|
||||
}
|
||||
|
||||
+#ifdef HAVE_SSL
|
||||
void complete_SSL_shutdown( SSL *ssl) {
|
||||
|
||||
/*
|
||||
@@ -1816,6 +1831,7 @@
|
||||
if( SSL_shutdown( ssl)) break;
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
/* bail if daemon is running as root */
|
||||
int check_privileges(void){
|
@ -1,10 +0,0 @@
|
||||
**********************************************************************
|
||||
|
||||
Enable NRPE in /etc/rc.conf with the following line:
|
||||
|
||||
nrpe2_enable="YES"
|
||||
|
||||
A sample configuration is available in %%PREFIX%%/etc/nrpe.cfg.sample.
|
||||
Copy to nrpe.cfg where required and edit to suit your needs.
|
||||
|
||||
**********************************************************************
|
@ -1,9 +0,0 @@
|
||||
nrpe is used to execute Nagios plugins on remote hosts and report the results
|
||||
to the main Nagios server. From the Nagios homepage:
|
||||
|
||||
Allows you to execute "local" plugins (like check_disk, check_procs, etc.) on
|
||||
remote hosts. The check_nrpe plugin is called from Nagios and actually makes
|
||||
the plugin requests to the remote host. Requires that nrpe be running on the
|
||||
remote host (either as a standalone daemon or as a service under inetd).
|
||||
|
||||
WWW: http://www.nagios.org/
|
@ -1,4 +0,0 @@
|
||||
@sample etc/nrpe.cfg.sample
|
||||
libexec/nagios/check_nrpe2
|
||||
sbin/nrpe2
|
||||
@dir(%%NAGIOSUSER%%,%%NAGIOSGROUP%%,755) %%NRPE_PIDDIR%%
|
Loading…
Reference in New Issue
Block a user