- Allow build with clang

- Respect CC
- Support STAGEDIR
- While I'm here:
  - Add LICENSE
  - Use PLIST_DIRS/PLIST_FILES instead of PLIST

PR:		ports/186932
Submitted by:	Hung-Yi Chen <gaod@hychen.org> (maintainer)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2014-02-23 15:20:54 +00:00
parent 14d20fe59a
commit 01005b138e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345731
4 changed files with 36 additions and 4 deletions

View File

@ -10,5 +10,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gaod@hychen.org
COMMENT= NTHU-CS Maple BBS 2.36 BBS-like editor
NO_STAGE= yes
LICENSE= GPLv1 GPLv2 GPLv3
LICENSE_COMB= dual
MAKE_ARGS= CC="${CC}"
PLIST_FILES= bin/ve \
%%DATADIR%%/ve.hlp
PLIST_DIRS= %%DATADIR%%
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/
${INSTALL_PROGRAM} ${WRKSRC}/ve ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/ve.hlp ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- edit.c.orig 2014-02-21 07:38:19.000000000 +0800
+++ edit.c 2014-02-21 07:38:29.000000000 +0800
@@ -988,7 +988,7 @@
redraw_everything = YEA;
}
-match_paren()
+void match_paren()
{
static char parens[] = "()[]{}<>";
int type, mode;

View File

@ -0,0 +1,11 @@
--- screen.c.orig 2014-02-21 07:38:36.000000000 +0800
+++ screen.c 2014-02-21 07:38:47.000000000 +0800
@@ -643,7 +643,7 @@
}
}
-region_scroll_up(int top, int bottom)
+void region_scroll_up(int top, int bottom)
{
int i;

View File

@ -1,3 +0,0 @@
bin/ve
share/ve/ve.hlp
@dirrm share/ve