French version of staroffice (version 5.2).
PR: 21129 Submitted by: Eric Masson <e-masson@kisoft-services.com> originally Modified by: Martin Blapp <mb@imp.ch>
This commit is contained in:
parent
abdde6362d
commit
00ec18e878
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32975
@ -2,5 +2,6 @@
|
||||
#
|
||||
|
||||
SUBDIR += ispell
|
||||
SUBDIR += staroffice52
|
||||
|
||||
.include <bsd.port.subdir.mk>
|
||||
|
128
french/staroffice52/Makefile
Normal file
128
french/staroffice52/Makefile
Normal file
@ -0,0 +1,128 @@
|
||||
# New ports collection makefile for: StarOffice 5.2
|
||||
# Date created: 22 August 2000
|
||||
# Whom: Martin Blapp
|
||||
# Translation: Eric Masson
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= staroffice
|
||||
PORTVERSION= 5.2
|
||||
CATEGORIES= editors linux
|
||||
MASTER_SITES= ftp://ftp.unilim.fr/pub/unix/bureautique/ \
|
||||
ftp://ftp.math.u-bordeaux.fr/pub/StarOffice/Linux-Intel/ \
|
||||
ftp://sunsite.cnlab-switch.ch/mirror/staroffice/francais/ \
|
||||
ftp://ftp.be.embnet.org/pub/tools/StarOffice/Linux/ \
|
||||
ftp://ftp.medasys-digital-systems.fr/pub1/linux/staroffice/
|
||||
DISTNAME= so-5_2-ga-bin-linux-fr.bin
|
||||
DISTFILES= so-5_2-ga-bin-linux-fr.bin
|
||||
.if defined(WITH_ADABAS)
|
||||
DISTFILES+= soa-5_2-ga-bin-linux-fr.bin so-5_2-ga-bin-linux-fr.bin
|
||||
.endif
|
||||
EXTRACT_ONLY=
|
||||
|
||||
MAINTAINER= mb@imp.ch
|
||||
|
||||
DEPENDS= ${PORTSDIR}/emulators/linux_base
|
||||
RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
NO_CDROM= 'Doit etre telecharge depuis le site web de Sun'
|
||||
IS_INTERACTIVE= yes
|
||||
NO_BUILD= yes
|
||||
DIST_SUBDIR= staroffice52
|
||||
WRKSRC= ${WRKDIR}/office52
|
||||
TMPDIR= ${WRKDIR}/tmp
|
||||
LD_PATH= ${TMPDIR}:${WRKSRC}:/compat/linux/lib:/compat/linux/usr/lib
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
pre-fetch:
|
||||
.if ${OSVERSION} < 410000
|
||||
@${ECHO}
|
||||
@${ECHO} OS-VERSION ${OSVERSION}
|
||||
@${ECHO}
|
||||
@${ECHO} Staroffice depend d\'une modification du script
|
||||
@${ECHO} src/sys/i386/linux/linux_sysvec. Celui-ci doit etre
|
||||
@${ECHO} au moins en revision 1.55.2.1.
|
||||
@${ECHO}
|
||||
@${ECHO} Veuillez mettre à jour vers FreeBSD 4.1 SVP
|
||||
@${ECHO}
|
||||
@${FALSE}
|
||||
.endif
|
||||
.if defined(WITH_CDROM)
|
||||
.if !exists(${CD_MOUNTPT}/linux/office52/setup)
|
||||
@${ECHO}
|
||||
@${ECHO} Montez le CDrom de Staroffice 5.2 dans le repertoire
|
||||
@${ECHO} ${CD_MOUNTPT} et relancez l\'installation
|
||||
@${ECHO}
|
||||
@${FALSE}
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CDROM)
|
||||
do-extract:
|
||||
@${MKDIR} ${WRKSRC}/office52
|
||||
@cd ${WRKSRC}/office52 && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
|
||||
.else
|
||||
|
||||
do-extract:
|
||||
.if !defined(DISPLAY) || ${DISPLAY} == ""
|
||||
@ ${ECHO}
|
||||
@ ${ECHO} Impossible d\'ouvrir le display X:
|
||||
@ ${ECHO} Verifiez la variable DISPLAY
|
||||
@ ${ECHO}
|
||||
@ ${FALSE}
|
||||
.else
|
||||
@${MKDIR} ${WRKSRC}
|
||||
@${MKDIR} ${TMPDIR}
|
||||
@${CP} ${_DISTDIR}/${DISTNAME} ${WRKSRC}
|
||||
@${CHMOD} 755 ${WRKSRC}/${DISTNAME}
|
||||
.if defined(WITH_ADABAS)
|
||||
@${CP} ${_DISTDIR}/soa-5_2-ga-bin-linux-fr.bin ${WRKSRC}
|
||||
@${CHMOD} 755 ${WRKSRC}/soa-5_2-ga-bin-linux-fr.bin
|
||||
.endif
|
||||
@cd ${WRKSRC}
|
||||
@SAL_IGNOREXERRORS=1 ${WRKSRC}/${DISTNAME} -extract ${WRKSRC}
|
||||
@cd ../../
|
||||
.endif
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@${PERL} -pi.orig -e 's|DefaultDestPath = "office52";|DefaultDestPath = "${PREFIX}/office52";|' ${WRKSRC}/setup.ins
|
||||
|
||||
do-install:
|
||||
.if !defined(DISPLAY) || ${DISPLAY} == ""
|
||||
@ ${ECHO}
|
||||
@ ${ECHO} Impossible d\'ouvrir le display X:
|
||||
@ ${ECHO} Verifiez la variable DISPLAY
|
||||
@ ${ECHO}
|
||||
@ ${FALSE}
|
||||
.else
|
||||
.if exists(/compat/linux/${PREFIX})
|
||||
@${LN} -fs /compat/linux/${PREFIX}/office52 ${PREFIX}/office52
|
||||
.endif
|
||||
@${CAT} ${PKGDIR}/MESSAGE
|
||||
@-SAL_IGNOREXERRORS=1 TEMP=${TMPDIR} LD_LIBRARY_PATH=${LD_PATH} /compat/linux/bin/sh -c '${WRKSRC}/setup /net'
|
||||
@if [ -f ${PREFIX}/office52/program/setup ]; then \
|
||||
${ECHO} ; \
|
||||
${ECHO} Ignorez le message d\'erreur. StarOffice5.2 a correctement ; \
|
||||
${ECHO} ete installe sur votre système. ; \
|
||||
${ECHO} ; \
|
||||
else \
|
||||
${ECHO} ; \
|
||||
${ECHO} Une erreur est survenue lors de l\'installation de StarOffice5.2. Envoyez un mail à mb@imp.ch ;\
|
||||
${ECHO} avec le debug et quelques informations sur votre environnement FreeBSD SVP. Merci. ; \
|
||||
${ECHO} ; \
|
||||
${FALSE} ; \
|
||||
fi
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${PATCH} -s ${PREFIX}/office52/program/setup ${FILESDIR}/setup.patch
|
||||
@${PATCH} -s ${PREFIX}/office52/program/soffice ${FILESDIR}/soffice.patch
|
||||
|
||||
install-user:
|
||||
${PREFIX}/office52/program/setup
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
french/staroffice52/distinfo
Normal file
2
french/staroffice52/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (staroffice52/so-5_2-ga-bin-linux-fr.bin) = 848e03d4feeef0112e7d2f16407d4431
|
||||
MD5 (staroffice52/soa-5_2-ga-bin-linux-fr.bin) = ab303af54dafbe5b308a06c92bc51133
|
9
french/staroffice52/files/setup.ins.patch
Normal file
9
french/staroffice52/files/setup.ins.patch
Normal file
@ -0,0 +1,9 @@
|
||||
--- setup.ins Tue Aug 22 23:31:42 2000
|
||||
+++ setup.ins Tue Aug 22 23:33:35 2000
|
||||
@@ -1,5 +1,5 @@
|
||||
Installation gid_Installation
|
||||
- DefaultDestPath = "office52";
|
||||
+ DefaultDestPath = "/usr/local/office52";
|
||||
ScriptVersion = 100;
|
||||
Bitmap = "so52.bmp";
|
||||
DefaultLanguage = "33";
|
14
french/staroffice52/files/setup.patch
Normal file
14
french/staroffice52/files/setup.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- setup.orig Mon May 8 08:20:00 2000
|
||||
+++ setup.new Fri Aug 25 15:16:12 2000
|
||||
@@ -1,7 +1,10 @@
|
||||
-#!/bin/sh
|
||||
+#!/compat/linux/bin/sh
|
||||
#
|
||||
# StarOffice patch checking script
|
||||
# (c) 2000, Sun Microsystems Inc.
|
||||
+
|
||||
+# fix coredump on remote DISPLAY (IRIX)
|
||||
+export SAL_IGNOREXERRORS=1
|
||||
|
||||
# resolve installation directory
|
||||
sd_platform=`uname -s`
|
14
french/staroffice52/files/soffice.patch
Normal file
14
french/staroffice52/files/soffice.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- soffice Mon May 8 08:20:00 2000
|
||||
+++ soffice.new Fri Aug 25 15:19:40 2000
|
||||
@@ -1,7 +1,10 @@
|
||||
-#!/bin/sh
|
||||
+#!/compat/linux/bin/sh
|
||||
#
|
||||
# StarOffice startup script
|
||||
# (c) 1999 Sun Microsystems, Inc.
|
||||
+
|
||||
+# fix coredump on remote DISPLAY (IRIX)
|
||||
+export SAL_IGNOREXERRORS=1
|
||||
|
||||
#
|
||||
# STAR_PROFILE_LOCKING_DISABLED=1
|
1
french/staroffice52/pkg-comment
Normal file
1
french/staroffice52/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Suite bureautique integree
|
4
french/staroffice52/pkg-descr
Normal file
4
french/staroffice52/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
StarOffice 5.2 est une suite bureautique contenant un traitement de
|
||||
texte, un tableur, un logiciel de presentation, un editeur d'images
|
||||
etc... StarOffice offre la possibilite de lire et ecrire les fichiers
|
||||
de MS Office (97 et 2000).
|
16
french/staroffice52/pkg-message
Normal file
16
french/staroffice52/pkg-message
Normal file
@ -0,0 +1,16 @@
|
||||
StarOffice 5.2 Personal Installation How-To
|
||||
|
||||
Ecrit par : Darren Wiebe <dkwiebe@hagenhomes.com>
|
||||
and Martin Blapp <mb@imp.ch>
|
||||
|
||||
Traducion: Eric Masson <e-masson@kisoft-services.com>
|
||||
|
||||
Vous allez bientot terminer l'installation réseau de StarOffice 5.2.
|
||||
Une fois cela terminé, sortez de X11 et lancez le à nouveau sous votre profil
|
||||
habituel. Lancez alors "make install-user" et faites une installation "workstation".
|
||||
Changez le répertoire d'installation en $HOME/office52. Ajoutez alors $HOME/office52
|
||||
à votre path
|
||||
|
||||
StarOffice est prêt à l'usage.
|
||||
|
||||
Bonne Chance
|
3030
french/staroffice52/pkg-plist
Normal file
3030
french/staroffice52/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user