update editors/codelite to 10.0

PR:		216529
Submitted by:	Mahdi Mokhtari <mokhi64@gmail.com> (maintainer)
Reviewed by:	feld, lifanov, matthew
Approved by:	matthew (mentor)
Differential Revision:	https://reviews.freebsd.org/D9362
This commit is contained in:
Nikolai Lifanov 2017-01-31 16:02:07 +00:00
parent 07955982e7
commit 00bc048859
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432929
4 changed files with 14 additions and 13 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= codelite
PORTVERSION= 9.2
PORTREVISION= 3
PORTVERSION= 10.0
CATEGORIES= editors devel
MAINTAINER= mokhi64@gmail.com
@ -46,7 +45,7 @@ SFTP_USES= localbase
CLANG_DESC= Clang code-completion
.for v in 34 35 36 37 38
.for v in 34 35 36 37 38 39
OPTIONS_RADIO_CLANG+= CLANG$v
CLANG$v_DESC= Clang ${v:C/(.)(.)/\1.\2.x/}
CLANG$v_BUILD_DEPENDS= clang$v>0:lang/clang$v

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1468513849
SHA256 (eranif-codelite-9.2_GH0.tar.gz) = 2e82e26d55e9884cd5c1061efd3ab4d8bd81dc6e095c5b811d0a3cba395e6118
SIZE (eranif-codelite-9.2_GH0.tar.gz) = 92205408
TIMESTAMP = 1484848953
SHA256 (eranif-codelite-10.0_GH0.tar.gz) = e345b819061a178a0404be2333a68017b7cc288cc673378a08418fe2d130534b
SIZE (eranif-codelite-10.0_GH0.tar.gz) = 91981352

View File

@ -1,11 +1,11 @@
--- SpellChecker/CMakeLists.txt.orig 2016-07-07 05:54:58 UTC
--- SpellChecker/CMakeLists.txt.orig 2017-01-02 08:08:09 UTC
+++ SpellChecker/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 2.6.2)
find_library(LIBHUNSPELL
# Fedora doesn't create a hunspell->hunspell-1.3 symlink, so explicitly look for (the current) full name
- NAMES hunspell hunspell-1.3
+ NAMES hunspell-1.6 hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell
PATH_SUFFIXES lib)
find_path( HUNSPELL_H
- NAMES hunspell hunspell-1.3 hunspell-1.4
+ NAMES hunspell hunspell-1.3 hunspell-1.4 hunspell-1.5 hunspell-1.6
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
HINTS /usr/lib /usr/lib/x86_64-linux-gnu/ /usr/lib64/
endif()

View File

@ -13,6 +13,7 @@ bin/codelite_xterm
%%CLANG37%%lib/codelite/LLDBDebugger.so
%%CLANG38%%bin/codelite-lldb
%%CLANG38%%lib/codelite/LLDBDebugger.so
lib/codelite/AutoSave.so
lib/codelite/CMakePlugin.so
lib/codelite/CallGraph.so
lib/codelite/CodeFormatter.so
@ -20,6 +21,7 @@ lib/codelite/CodeLiteDiff.so
lib/codelite/ContinuousBuild.so
lib/codelite/Copyright.so
lib/codelite/DatabaseExplorer.so
lib/codelite/EditorConfigPlugin.so
lib/codelite/ExternalTools.so
lib/codelite/HelpPlugin.so
lib/codelite/MemCheck.so
@ -29,6 +31,7 @@ lib/codelite/QMakePlugin.so
lib/codelite/SnipWiz.so
lib/codelite/SpellCheck.so
lib/codelite/Subversion.so
lib/codelite/Tail.so
lib/codelite/Tweaks.so
lib/codelite/UnitTestsPP.so
lib/codelite/WebTools.so
@ -82,7 +85,6 @@ share/applications/codelite.desktop
%%DATADIR%%/gdb_printers/qt4.py
%%DATADIR%%/gdb_printers/wx.py
%%DATADIR%%/images/common_tasks.png
%%DATADIR%%/images/cubes.png
%%DATADIR%%/images/help_earth.png
%%DATADIR%%/images/plugin_not_ok.png
%%DATADIR%%/images/plugin_ok.png