Revert patch-Makefile to fix building with DOCS on.

This commit is contained in:
Vanilla I. Shu 2017-03-05 15:03:25 +00:00
parent 1ea18e088f
commit 00b11eeee6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435482
2 changed files with 10 additions and 19 deletions

View File

@ -68,6 +68,7 @@ post-patch:
${WRKSRC}/scripts/utf8-edit
@${REINPLACE_CMD} -e '/make/ d' ${WRKSRC}/IMdkit/lib/Makefile
@${REINPLACE_CMD} -e 's,/usr/X11R6/lib,${LOCALBASE}/lib,' ${WRKSRC}/im-client/Makefile
post-patch-DOCS-off:
@${REINPLACE_CMD} '/install.*DOC_DIR/d' ${WRKSRC}/Makefile

View File

@ -1,5 +1,5 @@
--- Makefile.orig 2014-01-26 06:41:39 UTC
+++ Makefile
--- Makefile.orig 2014-01-26 14:41:39.000000000 +0800
+++ Makefile 2014-04-12 10:55:35.584554559 +0800
@@ -4,8 +4,11 @@ include config.mak
include suffixes-rule
@ -38,13 +38,13 @@
gcin: $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV)
- $(CCLD) $(EXTRA_LDFLAGS) $(gcc_ld_run_path) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L/usr/X11R6/$(LIB)
+ $(CCLD) $(EXTRA_LDFLAGS) $(gcc_ld_run_path) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L/usr/local/$(LIB)
+ $(CCLD) $(EXTRA_LDFLAGS) $(gcc_ld_run_path) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L%%PREFIX%%/$(LIB)
rm -f core.* vgcore.*
ln -sf $@ $@.test
gcin-nocur: $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV)
- $(CCLD) -Wl,-rpath,$(gcinlibdir) $(EXTRA_LDFLAGS) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L/usr/X11R6/$(LIB)
+ $(CCLD) -Wl,-rpath,$(gcinlibdir) $(EXTRA_LDFLAGS) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L/usr/local/$(LIB)
+ $(CCLD) -Wl,-rpath,$(gcinlibdir) $(EXTRA_LDFLAGS) -o $@ $(OBJS) $(IMdkitLIB) $(OBJ_IMSRV) -lXtst $(LDFLAGS) -L%%PREFIX%%/$(LIB)
rm -f core.*
-tslearn: $(OBJS_TSLEARN)
@ -86,7 +86,7 @@
$(CCLD) $(gcc_ld_run_path) -o $@ $(OBJS_gcin_message) -L./im-client -lgcin-im-client $(LDFLAGS)
pin-juyin: $(OBJS_pin_juyin)
@@ -223,22 +231,18 @@ install:
@@ -223,12 +231,12 @@ install:
$(MAKE) -C data install
$(MAKE) -C im-client install
$(MAKE) -C gtk-im install
@ -97,22 +97,12 @@
if [ $(QT4_IM) = 'Y' ]; then $(MAKE) -C qt4-im install; fi
- if [ $(prefix) = /usr/local ]; then \
- install -m 644 gcin.png /usr/share/icons/hicolor/64x64/apps; \
- install -d $(DOC_DIR); \
- install -m 644 README.html Changelog.html $(DOC_DIR); \
+ if [ $(prefix) = /nonstaged ]; then \
+ install -m 644 gcin.png $(prefix)/share/icons/hicolor/64x64/apps; \
install -d $(DOC_DIR); \
install -m 644 README.html Changelog.html $(DOC_DIR); \
install $(PROGS) $(bindir); \
rm -f $(bindir)/trad2sim; ln -sf sim2trad $(bindir)/trad2sim; \
rm -f $(bindir)/ts-contribute; ln -sf ts-edit $(bindir)/ts-contribute; \
rm -f $(bindir)/ts-contribute-en; ln -sf ts-edit $(bindir)/ts-contribute-en; \
rm -f $(bindir)/ts-edit-en; ln -sf ts-edit $(bindir)/ts-edit-en; \
else \
- install -d $(DOC_DIR_i); \
- install -m 644 README.html Changelog.html $(DOC_DIR_i); \
install -s $(PROGS) $(bindir); \
rm -f $(bindir)/trad2sim; ln -sf sim2trad $(bindir)/trad2sim; \
rm -f $(bindir)/ts-contribute; ln -sf ts-edit $(bindir)/ts-contribute; \
@@ -246,6 +250,7 @@ install:
@@ -246,6 +254,7 @@ install:
rm -f $(bindir)/ts-edit-en; ln -sf ts-edit $(bindir)/ts-edit-en; \
fi
$(MAKE) -C scripts install
@ -120,7 +110,7 @@
$(MAKE) -C menu install
if [ $(USE_I18N) = 'Y' ]; then $(MAKE) -C po install; fi
@@ -279,4 +284,4 @@ gcin-fedora.spec: gcin-fedora.spec.in VE
@@ -279,4 +288,4 @@ gcin-fedora.spec: gcin-fedora.spec.in VE
rm -f $@
sed -e "s/__gcin_version__/$(GCIN_VERSION)/" < $< > $@