Fix build on -current by un-clobbering LDFLAGS. Also, don't

mute installation commands.
This commit is contained in:
Adam Weinberger 2014-08-15 16:37:37 +00:00
parent 246575775a
commit 00b0c72489
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364996
2 changed files with 13 additions and 4 deletions

View File

@ -20,10 +20,10 @@ PORTEXAMPLES= adh.nex anolis.nex avian_ovomucoids.nex bglobin.nex \
cynmix.nex kim.nex primates.nex replicase.nex
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mb ${STAGEDIR}${PREFIX}/bin/
${INSTALL_PROGRAM} ${WRKSRC}/mb ${STAGEDIR}${PREFIX}/bin/
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for file in ${PORTEXAMPLES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- Makefile.orig 2005-12-23 01:13:06.000000000 +0900
+++ Makefile 2007-12-11 11:35:36.000000000 +0900
--- Makefile.orig 2005-12-22 11:13:06.000000000 -0500
+++ Makefile 2014-08-15 12:36:02.000000000 -0400
@@ -19,7 +19,7 @@
# set compiler for the non-MPI version (mpicc will be used for the MPI
@ -9,3 +9,12 @@
# set to yes if you want to use the readline library (make sure you have it
# installed on your machine)
@@ -67,7 +67,7 @@
LIBS += -lm
-LDFLAGS = $(CFLAGS)
+LDFLAGS += $(CFLAGS)
LDLIBS = $(LIBS)
OBJECTS = bayes.o command.o mbmath.o mcmc.o model.o plot.o sump.o sumt.o