update to 3.0.1

PR:		17362
Submitted by:	Maxim Sobolev <sobomax@altavista.net>
This commit is contained in:
Michael Haro 2000-03-24 01:23:13 +00:00
parent b5d8bf9cc8
commit 0095d3ed79
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27005
7 changed files with 83 additions and 94 deletions

View File

@ -1,46 +1,26 @@
# New ports collection makefile for: Maelstrom
# Version required: 2.0.6
# Version required: 3.0.1
# Date created: 13 May 1998
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
DISTNAME= Maelstrom-1.4.3-L2.0.6-src
PKGNAME= maelstrom-2.0.6
DISTNAME= Maelstrom-3.0.1
PKGNAME= maelstrom-3.0.1
CATEGORIES= games
MASTER_SITES= ftp://ftp.devolution.com/pub/maelstrom/
MASTER_SITES= http://www.devolution.com/~slouken/projects/Maelstrom/src/
MAINTAINER= andy@icc.surw.chel.su
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
SDL-1.0.2:${PORTSDIR}/devel/sdl
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/Maelstrom
MAKE_ENV= CFLAGS="${CFLAGS} -pedantic" CXXFLAGS="${CXXFLAGS} -pedantic"
do-configure:
@ ${CP} ${FILESDIR}/Makeflags ${WRKSRC}
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/Maelstrom ${PREFIX}/bin
@ ${INSTALL_PROGRAM} ${WRKSRC}/Maelstrom_sound ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/Maelstrom
.for file in Fonts Sounds Sprites
@ ${INSTALL_DATA} ${WRKSRC}/Maelstrom\ ${file} ${PREFIX}/share/Maelstrom
.endfor
@ ${INSTALL_DATA} ${WRKSRC}/Maelstrom-Scores ${PREFIX}/share/Maelstrom
@ ${CHOWN} root:games ${PREFIX}/share/Maelstrom/Maelstrom-Scores
@ ${CHMOD} 666 ${PREFIX}/share/Maelstrom/Maelstrom-Scores
@ ${MKDIR} ${PREFIX}/share/Maelstrom/Images
@ ${INSTALL_DATA} ${WRKSRC}/Images/*n ${PREFIX}/share/Maelstrom/Images
GNU_CONFIGURE= yes
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/Maelstrom
.for file in Ambrosia.URL BUGS Changelog Copyright README README.Options README.network
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/Maelstrom
.endfor
@ ${INSTALL_DATA} ${WRKSRC}/Doc/* ${PREFIX}/share/doc/Maelstrom
INSTALL_TARGET= install install_gamedocs
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (Maelstrom-1.4.3-L2.0.6-src.tar.gz) = 350806a4fa46e7aae76f089dba4b1861
MD5 (Maelstrom-3.0.1.tar.gz) = 88f80726771766285b1397d1b73205b2

View File

@ -1,15 +1,11 @@
--- mixer.cpp Thu Dec 5 13:14:44 1996
+++ /home/andy/tmp/wrk/mixer.cpp Wed May 13 23:06:18 1998
@@ -283,10 +283,12 @@
#endif /* linux */
--- netlogic/netplay.cpp.orig Mon Mar 13 20:51:15 2000
+++ netlogic/netplay.cpp Mon Mar 13 20:52:10 2000
@@ -39,7 +39,7 @@
#define RESET_ERRNO() errno = 0
#endif /* WIN32 */
/* This is necessary so that the sound server stays in sync */
+#ifndef __FreeBSD__
long flags;
flags = fcntl(dsp_fd, F_GETFL, 0);
flags |= O_SYNC;
(void) fcntl(dsp_fd, F_SETFL, flags);
+#endif
-#if !defined(linux) && !defined(__SVR4)
+#if !defined(linux) && !defined(__SVR4) && !defined(__FreeBSD__)
typedef int socklen_t;
#endif
return(0);
}

View File

@ -1,11 +1,12 @@
--- mixer.h Sun May 25 21:18:10 1997
+++ /home/andy/tmp/wrk/mixer.h Thu May 14 00:25:17 1998
@@ -41,7 +41,7 @@
};
#define _PATH_DEV_AUDIO "/dev/audio"
-#ifdef linux
+#if (defined(linux) || defined(__FreeBSD__))
#define _PATH_DEV_DSP "/dev/dsp"
#else
#define _PATH_DEV_DSP _PATH_DEV_AUDIO
--- configure.orig Mon Mar 13 20:58:01 2000
+++ configure Mon Mar 13 20:58:05 2000
@@ -1633,6 +1633,9 @@
ac_default_prefix=/boot/beos
GAME_INSTALLDIR="\$(prefix)/games/$PACKAGE"
;;
+ *-*-freebsd*)
+ GAME_INSTALLDIR="\$(prefix)/share/$PACKAGE"
+ ;;
*)
GAME_INSTALLDIR="\$(prefix)/games/$PACKAGE"
;;

View File

@ -1,9 +1,13 @@
--- netlogic/Makefile.orig Sun May 17 01:28:58 1998
+++ netlogic/Makefile Sun May 17 01:29:05 1998
@@ -1,5 +1,5 @@
--- Makefile.in.orig Mon Mar 13 21:21:22 2000
+++ Makefile.in Mon Mar 13 21:34:53 2000
@@ -446,8 +446,8 @@
chmod 666 $(target)/Maelstrom-Scores
-CFLAGS = $(OPTIMIZE) -I.. $(INCLUDES) -DNETPLAY
+CFLAGS += $(OPTIMIZE) -I.. $(INCLUDES) -DNETPLAY
OBJS = about.o blit.o game.o logic.o make.o netplay.o object.o player.o
install_gamedocs:
- sh mkinstalldirs $(target)/
- cp -rv README* COPYING* Docs* $(target)/
+ sh mkinstalldirs $(prefix)/share/doc/Maelstrom/
+ cp -rv README* COPYING* Docs/* $(prefix)/share/doc/Maelstrom/
netlogic.o: $(OBJS)
# Rule to build tar-gzipped distribution package
$(PACKAGE)-$(VERSION).tar.gz: dist

View File

@ -2,4 +2,4 @@ A port of the high resolution, fast action Asteroids-style
Mac game Maelstrom originally written by Ambrosia Software.
Unique to this port is a kick-butt network play mode.
WWW: http://www.devolution.com/~slouken/Maelstrom
WWW: http://www.devolution.com/~slouken/projects/Maelstrom/

View File

@ -1,9 +1,27 @@
bin/Maelstrom
bin/Maelstrom_sound
share/Maelstrom/Maelstrom Fonts
share/Maelstrom/Maelstrom Sounds
share/Maelstrom/Maelstrom Sprites
share/Maelstrom/Maelstrom-Scores
bin/Maelstrom-netd
bin/macres
bin/playwave
bin/snd2wav
share/doc/Maelstrom/Ambrosia_Software,_Inc._FAQ
share/doc/Maelstrom/COPYING
share/doc/Maelstrom/COPYING.GPL
share/doc/Maelstrom/Maelstrom-Announce
share/doc/Maelstrom/Maelstrom.FAQ
share/doc/Maelstrom/MaelstromGPL_press_release
share/doc/Maelstrom/Makefile
share/doc/Maelstrom/Makefile.in
share/doc/Maelstrom/Networking.Paper
share/doc/Maelstrom/Porting.Paper
share/doc/Maelstrom/Quotes
share/doc/Maelstrom/README
share/doc/Maelstrom/README.joystick
share/doc/Maelstrom/README.network
share/doc/Maelstrom/README.options
share/doc/Maelstrom/RSA.README
share/doc/Maelstrom/Technical_Notes-v1.0
share/doc/Maelstrom/Technical_Notes-v1.1
share/doc/Maelstrom/Technical_Notes-v2.0
share/Maelstrom/Images/Maelstrom_Icon#100.cicn
share/Maelstrom/Images/Maelstrom_Icon#101.cicn
share/Maelstrom/Images/Maelstrom_Icon#102.cicn
@ -20,34 +38,24 @@ share/Maelstrom/Images/Maelstrom_Icon#134.cicn
share/Maelstrom/Images/Maelstrom_Icon#135.cicn
share/Maelstrom/Images/Maelstrom_Icon#136.cicn
share/Maelstrom/Images/Maelstrom_Icon#137.cicn
share/Maelstrom/Images/Maelstrom_Sprites#128.icon
share/Maelstrom/Images/Maelstrom_Titles#100.icon
share/Maelstrom/Images/Maelstrom_Titles#101.icon
share/Maelstrom/Images/Maelstrom_Titles#102.icon
share/Maelstrom/Images/Maelstrom_Titles#128.icon
share/Maelstrom/Images/Maelstrom_Titles#129.icon
share/Maelstrom/Images/Maelstrom_Titles#130.icon
share/Maelstrom/Images/Maelstrom_Titles#133.icon
share/Maelstrom/Images/Maelstrom_Titles#134.icon
share/Maelstrom/Images/Maelstrom_Titles#135.icon
share/Maelstrom/Images/Maelstrom_Titles#999.icon
share/doc/Maelstrom/Ambrosia.FAQ
share/doc/Maelstrom/Ambrosia.URL
share/doc/Maelstrom/BUGS
share/doc/Maelstrom/Changelog
share/doc/Maelstrom/Copyright
share/doc/Maelstrom/Maelstrom-Announce
share/doc/Maelstrom/Maelstrom.FAQ
share/doc/Maelstrom/Networking.Paper
share/doc/Maelstrom/Porting.Paper
share/doc/Maelstrom/Quotes
share/doc/Maelstrom/README
share/doc/Maelstrom/README.Options
share/doc/Maelstrom/README.network
share/doc/Maelstrom/RSA.README
share/doc/Maelstrom/Technical_Notes-v1.0
share/doc/Maelstrom/Technical_Notes-v1.1
share/doc/Maelstrom/Technical_Notes-v2.0
share/Maelstrom/Images/Maelstrom_Titles#100.bmp
share/Maelstrom/Images/Maelstrom_Titles#101.bmp
share/Maelstrom/Images/Maelstrom_Titles#102.bmp
share/Maelstrom/Images/Maelstrom_Titles#128.bmp
share/Maelstrom/Images/Maelstrom_Titles#129.bmp
share/Maelstrom/Images/Maelstrom_Titles#130.bmp
share/Maelstrom/Images/Maelstrom_Titles#133.bmp
share/Maelstrom/Images/Maelstrom_Titles#134.bmp
share/Maelstrom/Images/Maelstrom_Titles#135.bmp
share/Maelstrom/Images/Maelstrom_Titles#999.bmp
share/Maelstrom/Images/Makefile
share/Maelstrom/Images/Makefile.in
share/Maelstrom/Maelstrom-Scores
share/Maelstrom/Maelstrom_Fonts
share/Maelstrom/Maelstrom_Sounds
share/Maelstrom/Maelstrom_Sprites
share/Maelstrom/icon.bmp
share/Maelstrom/icon.xpm
@dirrm share/Maelstrom/Images
@dirrm share/Maelstrom
@dirrm share/doc/Maelstrom