Remove expired port:

2017-07-02 deskutils/california: Orphaned upstream, replaced by gnome-calendar
This commit is contained in:
Rene Ladan 2017-07-02 13:35:11 +00:00
parent 54046f4915
commit 008357f249
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=444883
7 changed files with 1 additions and 161 deletions

1
MOVED
View File

@ -9458,3 +9458,4 @@ net/freeradius2|net/freeradius3|2017-07-01|Has expired: EoL, use net/freeradius3
net/abills||2017-07-01|Removed, unmaintained and depends on expired net/freeradius2
net-mgmt/ezradius||2017-07-01|Removed, unmaintained and depends on expired net/freeradius2
x11-toolkits/qt5-declarative||2017-07-01|Has expired: Has not been released since Qt 5.5 -- installation can lead to runtime conflicts with qt5-quick
deskutils/california|deskutils/gnome-calendar|2017-07-02|Has expired: Orphaned upstream, replaced by gnome-calendar

View File

@ -20,7 +20,6 @@
SUBDIR += cal
SUBDIR += calcurse
SUBDIR += calibre
SUBDIR += california
SUBDIR += cartotheque
SUBDIR += cdcat
SUBDIR += charmap

View File

@ -1,47 +0,0 @@
# Created by: Gustau Perez <gustau.perez@gmail.com>
# $FreeBSD$
PORTNAME= california
PORTVERSION= 0.4.0
PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Calendar client for GNOME 3
DEPRECATED= Orphaned upstream, replaced by gnome-calendar
EXPIRATION_DATE=2017-07-02
BUILD_DEPENDS= itstool:textproc/itstool \
xdg-open:devel/xdg-utils
LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3 \
libicui18n.so:devel/icu \
libsoup-2.4.so:devel/libsoup \
libgee-0.8.so:devel/libgee \
libgdata.so:devel/libgdata \
libical.so:devel/libical \
libsecret-1.so:security/libsecret \
libjson-glib-1.0.so:devel/json-glib \
libgoa-1.0.so:net/gnome-online-accounts
RUN_DEPENDS= xdg-open:devel/xdg-utils
USES= desktop-file-utils gettext gmake libtool pathfix \
pkgconfig tar:xz
USE_GNOME= cairo evolutiondataserver3 glib20 gnomedocutils gnomeprefix \
gtk30 intlhack introspection
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --disable-unity --disable-fatal
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.yorba.california.gschema.xml
post-patch:
@${REINPLACE_CMD} -e 's|californiadocdir = $${prefix}|californiadocdir = $${prefix}/share|g' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (gnome3/california-0.4.0.tar.xz) = b25f356363a9f8f8f93c7ab78af02de39f9c3b71964663129ac9904de9147eb6
SIZE (gnome3/california-0.4.0.tar.xz) = 1006180

View File

@ -1,43 +0,0 @@
From 4b61966a93e7be65ed35e8a509e2b7538b136c3c Mon Sep 17 00:00:00 2001
From: Adam Dingle <adam@medovina.org>
Date: Thu, 24 Mar 2016 12:35:04 -0400
Subject: Fix build with newer evolution-data-server: bug 743961
Thanks to Milan Crha <mcrha@redhat.com> for this fix.
https://bugzilla.gnome.org/show_bug.cgi?id=743961
---
configure.ac | 2 +-
src/backing/eds/backing-eds-calendar-source.vala | 2 +-
vapi/libecal-1.2.vapi | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/backing/eds/backing-eds-calendar-source.vala b/src/backing/eds/backing-eds-calendar-source.vala
index 7e30e08..da88db4 100644
--- src/backing/eds/backing-eds-calendar-source.vala
+++ src/backing/eds/backing-eds-calendar-source.vala
@@ -256,7 +256,7 @@ internal class EdsCalendarSource : CalendarSource {
// Invoked by EdsStore prior to making it available outside of unit
internal async void open_async(Cancellable? cancellable) throws Error {
- client = (E.CalClient) yield E.CalClient.connect(eds_source, E.CalClientSourceType.EVENTS,
+ client = (E.CalClient) yield E.CalClient.connect(eds_source, E.CalClientSourceType.EVENTS, 1,
cancellable);
client.bind_property("readonly", this, PROP_READONLY, BindingFlags.SYNC_CREATE);
diff --git a/vapi/libecal-1.2.vapi b/vapi/libecal-1.2.vapi
index 6ead3ec..46fd711 100644
--- vapi/libecal-1.2.vapi
+++ vapi/libecal-1.2.vapi
@@ -23,7 +23,7 @@ namespace E {
public bool check_save_schedules ();
public static bool check_timezones (iCal.icalcomponent comp, GLib.List comps, GLib.Callback tzlookup, void* ecalclient, GLib.Cancellable cancellable) throws GLib.Error;
[CCode (finish_name = "e_cal_client_connect_finish")]
- public static async unowned E.Client connect (E.Source source, E.CalClientSourceType source_type, GLib.Cancellable cancellable) throws GLib.Error;
+ public static async unowned E.Client connect (E.Source source, E.CalClientSourceType source_type, uint32 wait_for_connected_seconds, GLib.Cancellable cancellable) throws GLib.Error;
public static unowned E.Client connect_sync (E.Source source, E.CalClientSourceType source_type, GLib.Cancellable cancellable) throws GLib.Error;
[CCode (finish_name = "e_cal_client_create_object_finish")]
public async void create_object (iCal.icalcomponent icalcomp, GLib.Cancellable? cancellable, out string out_uid) throws GLib.Error;
--
cgit v0.12

View File

@ -1,3 +0,0 @@
California is a calendar client for GNOME 3
WWW: https://wiki.gnome.org/Apps/California

View File

@ -1,65 +0,0 @@
bin/california
share/appdata/california.appdata.xml
share/applications/california.desktop
share/california/icons/Adwaita/scalable/actions/edit-symbolic.svg
share/doc/california/AUTHORS
share/doc/california/COPYING
share/doc/california/ChangeLog
share/doc/california/INSTALL
share/doc/california/NEWS
share/doc/california/README
share/help/C/california/cal-add-calendar.page
share/help/C/california/cal-change-view.page
share/help/C/california/cal-event-edit.page
share/help/C/california/cal-event-quick-add.page
share/help/C/california/cal-event-remove.page
share/help/C/california/cal-hide-a-calendar.page
share/help/C/california/cal-open-calendar-list.xml
share/help/C/california/cal-quickstart.page
share/help/C/california/cal-remove-calendar.page.stub
share/help/C/california/cal-rename-calendar.page
share/help/C/california/cal-shortcut-keys.page
share/help/C/california/gnome-help.sct
share/help/C/california/index.page
share/help/C/california/legal.xml
share/help/C/california/media/california-screenshot.png
share/help/C/california/media/x-office-calendar.png
share/help/ca/california/cal-add-calendar.page
share/help/ca/california/cal-change-view.page
share/help/ca/california/cal-event-edit.page
share/help/ca/california/cal-event-quick-add.page
share/help/ca/california/cal-event-remove.page
share/help/ca/california/cal-hide-a-calendar.page
share/help/ca/california/cal-open-calendar-list.xml
share/help/ca/california/cal-quickstart.page
share/help/ca/california/cal-remove-calendar.page.stub
share/help/ca/california/cal-rename-calendar.page
share/help/ca/california/cal-shortcut-keys.page
share/help/ca/california/gnome-help.sct
share/help/ca/california/index.page
share/help/ca/california/legal.xml
share/help/ca/california/media/california-screenshot.png
share/help/ca/california/media/x-office-calendar.png
share/locale/bs/LC_MESSAGES/california.mo
share/locale/ca/LC_MESSAGES/california.mo
share/locale/cs/LC_MESSAGES/california.mo
share/locale/de/LC_MESSAGES/california.mo
share/locale/el/LC_MESSAGES/california.mo
share/locale/es/LC_MESSAGES/california.mo
share/locale/fi/LC_MESSAGES/california.mo
share/locale/gl/LC_MESSAGES/california.mo
share/locale/he/LC_MESSAGES/california.mo
share/locale/hu/LC_MESSAGES/california.mo
share/locale/id/LC_MESSAGES/california.mo
share/locale/kk/LC_MESSAGES/california.mo
share/locale/pl/LC_MESSAGES/california.mo
share/locale/pt/LC_MESSAGES/california.mo
share/locale/pt_BR/LC_MESSAGES/california.mo
share/locale/ru/LC_MESSAGES/california.mo
share/locale/sl/LC_MESSAGES/california.mo
share/locale/sr/LC_MESSAGES/california.mo
share/locale/sr@latin/LC_MESSAGES/california.mo
share/locale/sv/LC_MESSAGES/california.mo
share/locale/tr/LC_MESSAGES/california.mo
share/locale/uk/LC_MESSAGES/california.mo
share/locale/zh_TW/LC_MESSAGES/california.mo