Initial version. Gnumeric is a spreadsheet for GNOME.

This is a slightly modified version of japanese/gnumeric.  It can
exchange simple spreadsheets with MS Excel.

TODO:		Test CLE's patch, to see if a static gnomeole2 is needed to
		avoid frequent crash when opening complicated .xls.
This commit is contained in:
Jing-Tang Keith Jang 2001-03-06 07:19:39 +00:00
parent 57b7f1a472
commit 007c839ed1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39115
5 changed files with 56 additions and 0 deletions

View File

@ -27,6 +27,7 @@
SUBDIR += gb2ps
SUBDIR += gbscript
SUBDIR += ghostscript6
SUBDIR += gnumeric
SUBDIR += hc
SUBDIR += hztty
SUBDIR += joe

16
chinese/gnumeric/Makefile Normal file
View File

@ -0,0 +1,16 @@
# New ports collection makefile for: zh-gnumeric
# Date created: 6 March 2001
# Whom: Jing-Tang Keith Jang <keith@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= chinese math gnome
MAINTAINER= keith@FreeBSD.org
MASTERDIR= ${.CURDIR}/../../math/gnumeric
EXTRA_PATCHES= ${.CURDIR}/files/patch-*
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,11 @@
--- src/dialogs/dialog-stf-preview.c.orig Mon Oct 30 17:44:01 2000
+++ src/dialogs/dialog-stf-preview.c Mon Oct 30 17:44:31 2000
@@ -711,7 +711,7 @@
renderdata->gridgroup = NULL;
renderdata->hashtable = g_hash_table_new (g_int_hash, g_int_equal);
- renderdata->font = gdk_font_load ("fixed");
+ renderdata->font = gdk_fontset_load ("-*-medium-r-normal--14-*-*-*-*-*-big5-0");
renderdata->charwidth = gdk_string_width (renderdata->font, "W");
renderdata->charheight = gdk_string_height (renderdata->font, "W");

View File

@ -0,0 +1,14 @@
--- src/style.c.orig Tue Sep 19 09:41:02 2000
+++ src/style.c Mon Oct 30 23:11:36 2000
@@ -70,9 +70,9 @@
}
/* Worst case scenario */
- font->gdk_font = gnome_display_font_get_gdk_font (font->dfont);
+ font->gdk_font = gdk_fontset_load ("-*-medium-r-normal--14-*-*-*-*-*-big5-0");
if (font->gdk_font == NULL)
- font->gdk_font = gdk_font_load ("fixed");
+ font->gdk_font = gdk_fontset_load ("-*-medium-r-normal--14-*-*-*-*-*-big5-0");
else
gdk_font_ref (font->gdk_font);

View File

@ -0,0 +1,14 @@
--- src/item-edit.c.orig Mon Oct 30 23:06:00 2000
+++ src/item-edit.c Mon Oct 30 23:08:03 2000
@@ -223,6 +223,11 @@
return;
top_pos += item_edit->font->ascent;
+ /* Handle multibyte */
+ if( cursor_pos != -1 )
+ cursor_pos = strlen(gtk_editable_get_chars(GTK_EDITABLE(item_edit->entry),
+ 0, cursor_pos));
+
/* Draw the background (recall that gdk_draw_rectangle excludes far coords) */
gdk_draw_rectangle (
drawable, canvas->style->white_gc, TRUE,