x11/xkb-switch: Update 1.5.0 -> 1.6.0

Also pet portlint.

PR:		239448
Submitted by:	Dmitri Goutnik <dg@syrec.org> (maintainer)
This commit is contained in:
Yuri Victorovich 2019-08-03 23:07:43 +00:00
parent 1bc4ae62e6
commit 006aaaa8ae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=508035
3 changed files with 17 additions and 21 deletions

View File

@ -2,25 +2,33 @@
# $FreeBSD$
PORTNAME= xkb-switch
PORTVERSION= 1.5.0
PORTVERSION= 1.6.0
CATEGORIES= x11
# https://github.com/ierton/xkb-switch/pull/41
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES= 2075a8cdd5456c906fcd49278c1003dcb6b9f880.patch:-p1
MAINTAINER= dg@syrec.org
COMMENT= Switch your X keyboard layouts from the command line
LICENSE= GPLv3
USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= ierton
USES= cmake
USE_XORG= x11 xkbfile
USE_LDCONFIG= yes
CMAKE_ARGS= -DMAN_COMPRESSION="gz" -DMANDIR="${MANPREFIX}/man"
OPTIONS_DEFINE= DOCS
PLIST_FILES= bin/xkb-switch \
lib/libxkbswitch.so
lib/libxkbswitch.so \
lib/libxkbswitch.so.1 \
lib/libxkbswitch.so.1.6.0 \
man/man1/xkb-switch.1.gz
PORTDOCS= README.md

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1489685611
SHA256 (ierton-xkb-switch-1.5.0_GH0.tar.gz) = 3e100ac15670eda2109fb0d3159ad08e85e3b33de4cb1b3369dce5da7d83e954
SIZE (ierton-xkb-switch-1.5.0_GH0.tar.gz) = 18899
TIMESTAMP = 1564084605
SHA256 (ierton-xkb-switch-1.6.0_GH0.tar.gz) = 17ddd00a09945f634654ddf98d55023b0727755f828706747fd5227e2651633d
SIZE (ierton-xkb-switch-1.6.0_GH0.tar.gz) = 20458
SHA256 (2075a8cdd5456c906fcd49278c1003dcb6b9f880.patch) = 8dce584225bea7340a3674d9ab4ed66912ee4354f7e40f941625c90b8b66d5e1
SIZE (2075a8cdd5456c906fcd49278c1003dcb6b9f880.patch) = 1845

View File

@ -1,14 +0,0 @@
--- CMakeLists.txt.orig 2016-04-17 08:55:32 UTC
+++ CMakeLists.txt
@@ -4,6 +4,11 @@ PROJECT( XKB-SWITCH )
FIND_PROGRAM(CTAGS ctags)
+FIND_PACKAGE(X11 REQUIRED)
+
+INCLUDE_DIRECTORIES(${X11_INCLUDE_DIR})
+LINK_DIRECTORIES(${X11_LIBRARY_DIR})
+
ADD_EXECUTABLE(xkb-switch XKbSwitch.cpp XKeyboard.cpp)
TARGET_LINK_LIBRARIES(xkb-switch X11 xkbfile)