- Update to 0.10.2. [1]

- Support kqueue polling. [2]

PR:		ports/103508 [1]
Submitted by:	Toni Viemero <toni.viemero@iki.fi> [1]
		Dennis Schneider <dans-at-1158888366@berlin.ccc.de> [2]
This commit is contained in:
Florent Thoumie 2006-09-25 22:39:28 +00:00
parent 2bca2ec886
commit 003bd9349a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=173836
4 changed files with 12 additions and 16 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= libtorrent-devel
PORTVERSION= 0.10.0
PORTVERSION= 0.10.2
PORTREVISION= 0
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
@ -22,4 +22,8 @@ CONFLICTS= libtorrent-[0-9]*
EXTRA_PATCHES= ${.CURDIR}/files/devel-*
.if defined(WITH_KQUEUE)
CONFIGURE_ARGS=--with-kqueue
.endif
.include "${MASTERDIR}/Makefile"

View File

@ -1,3 +1,3 @@
MD5 (libtorrent-0.10.0.tar.gz) = 240e90818c4c9c34474b2e1873d09910
SHA256 (libtorrent-0.10.0.tar.gz) = 47645632fee222609c139bddf50872949bd3359214976a25a92bbc1d277c70de
SIZE (libtorrent-0.10.0.tar.gz) = 447795
MD5 (libtorrent-0.10.2.tar.gz) = 99f1daa0f6ce0aa8d53745c494df9b36
SHA256 (libtorrent-0.10.2.tar.gz) = b3bd1dcc0de3dfdec4a2d6f7012d126875e166330ff9d399927b468fde7ae5d1
SIZE (libtorrent-0.10.2.tar.gz) = 453071

View File

@ -1,11 +0,0 @@
--- src/utils/sha1.h.orig Wed Jul 12 11:35:43 2006
+++ src/utils/sha1.h Wed Jul 12 11:36:04 2006
@@ -87,7 +87,7 @@
Sha1::final_c(char* buffer) {
unsigned int len;
- SHA1_End(&m_ctx, buffer, &len, 20);
+ SHA1_End(&m_ctx, (unsigned char*)buffer, &len, 20);
}
#elif defined USE_OPENSSL_SHA

View File

@ -2,6 +2,7 @@ include/torrent/bitfield.h
include/torrent/block.h
include/torrent/block_list.h
include/torrent/block_transfer.h
include/torrent/chunk_manager.h
include/torrent/common.h
include/torrent/connection_manager.h
include/torrent/download.h
@ -14,6 +15,8 @@ include/torrent/object.h
include/torrent/object_stream.h
include/torrent/path.h
include/torrent/peer.h
include/torrent/peer_info.h
include/torrent/peer_list.h
include/torrent/piece.h
include/torrent/poll.h
include/torrent/poll_epoll.h
@ -26,6 +29,6 @@ include/torrent/tracker.h
include/torrent/tracker_list.h
include/torrent/transfer_list.h
lib/libtorrent.so
lib/libtorrent.so.8
lib/libtorrent.so.9
libdata/pkgconfig/libtorrent.pc
@dirrm include/torrent