Update to 0.2.0 to fix fetch

Pointed out by:	pointyhat via kris
Approved by:	marcus (co mentor)
This commit is contained in:
Michael Johnson 2004-11-10 04:21:03 +00:00
parent c9a1b1ee04
commit 0031918568
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121282
4 changed files with 63 additions and 7 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= cairo
PORTVERSION= 0.1.23
PORTVERSION= 0.2.0
CATEGORIES= graphics
MASTER_SITES= http://www.cairographics.org/snapshots/
@ -25,9 +25,6 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CLFAGS}" \
LDFLAGS="${PTHREAD_LDFLAGS}"
# glitz is out of sync with cairo
CONFIGURE_ARGS= --disable-gl
PLIST_FILES= include/cairo-features.h \
include/cairo.h \
lib/libcairo.a \
@ -35,4 +32,13 @@ PLIST_FILES= include/cairo-features.h \
lib/libcairo.so.1 \
libdata/pkgconfig/cairo.pc
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
post-patch:
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
${WRKSRC}/src/*.*
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (cairo-0.1.23.tar.gz) = c36bcb2c5fe2b716620e68626a0da3a1
SIZE (cairo-0.1.23.tar.gz) = 393051
MD5 (cairo-0.2.0.tar.gz) = 2ff2b3b52b862971d2baa3fede3a3d6e
SIZE (cairo-0.2.0.tar.gz) = 462216

View File

@ -0,0 +1,27 @@
--- src/cairo_font.c.orig Tue Nov 9 21:51:24 2004
+++ src/cairo_font.c Tue Nov 9 21:53:06 2004
@@ -54,9 +54,9 @@
static unsigned long
_font_cache_hash (void *cache, void *key)
{
+ unsigned long hash;
cairo_font_cache_key_t *in;
in = (cairo_font_cache_key_t *) key;
- unsigned long hash;
/* 1607 and 1451 are just a couple random primes. */
hash = _cairo_hash_string (in->family);
@@ -86,11 +86,12 @@
void *key,
void **return_value)
{
+ const struct cairo_font_backend *backend;
cairo_font_cache_key_t *k;
cairo_font_cache_entry_t *entry;
k = (cairo_font_cache_key_t *) key;
- const struct cairo_font_backend *backend = CAIRO_FONT_BACKEND_DEFAULT;
+ backend = CAIRO_FONT_BACKEND_DEFAULT;
/* XXX: The current freetype backend may return NULL, (for example
* if no fonts are installed), but I would like to guarantee that

View File

@ -0,0 +1,23 @@
--- src/cairo_ft_font.c.orig Tue Nov 9 21:53:24 2004
+++ src/cairo_ft_font.c Tue Nov 9 21:58:25 2004
@@ -481,6 +481,9 @@
cairo_glyph_t **glyphs,
int *nglyphs)
{
+ double x, y;
+ FT_ULong *ucs4 = NULL;
+ size_t i;
cairo_ft_font_t *font = abstract_font;
FT_Face face = font->val->face;
cairo_glyph_cache_key_t key;
@@ -490,9 +493,7 @@
key.unscaled = &font->base;
key.scale = *sc;
- double x = 0., y = 0.;
- size_t i;
- FT_ULong *ucs4 = NULL;
+ x = 0., y = 0.;
_utf8_to_ucs4 (utf8, &ucs4, nglyphs);