a small tool to convert VDA format (produced by many CAD

packages to fbd, used by the CalculiX port.

PR:		52306
Submitted by:	Pedro F. Giffuni <giffunip@yahoo.com>
This commit is contained in:
Maho Nakata 2003-07-19 05:34:45 +00:00
parent 867a7eec5a
commit 001d1e7f24
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=85176
8 changed files with 152 additions and 0 deletions

View File

@ -63,6 +63,7 @@
SUBDIR += uudeview
SUBDIR += uudx
SUBDIR += uulib
SUBDIR += vda2fbd
SUBDIR += xdeview
SUBDIR += xunicode

View File

@ -0,0 +1,26 @@
# New ports collection makefile for: vda2fbd
# Date created: 19 April 2003
# Whom: Pedro Giffuni <giffunip@asme.org>
#
# $FreeBSD$
#
PORTNAME= vda2fbd
PORTVERSION= 0.9
CATEGORIES= converters cad
MASTER_SITES= http://www.dhondt.de/
MAINTAINER= ports@FreeBSD.org
COMMENT= An add-on converter for CalculiX
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/*.ps \
${DOCSDIR}
${GZIP_CMD} ${DOCSDIR}/*.ps
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,26 @@
# New ports collection makefile for: vda2fbd
# Date created: 19 April 2003
# Whom: Pedro Giffuni <giffunip@asme.org>
#
# $FreeBSD: /tmp/pcvs/ports/converters/vda2fbd/Attic/Makefile~,v 1.1 2003-07-19 05:34:45 maho Exp $
#
PORTNAME= vda2fbd
PORTVERSION= 0.9
CATEGORIES= converters cad
MASTER_SITES= http://www.dhondt.de/
MAINTAINER= ports@FreeBSD.org
COMMENT= An add-on converter for CalculiX
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/*.ps \
${DOCSDIR}
${GZIP_CMD} ${DOCSDIR}/*.ps
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (vda2fbd-0.9.tar.gz) = 617d026c00b251a9c5576ccf79f2c798

View File

@ -0,0 +1,23 @@
--- Makefile.orig Thu Sep 5 09:14:22 2002
+++ Makefile Thu May 15 16:38:06 2003
@@ -1,15 +1,15 @@
-INST=/usr/local
+INST=$(PREFIX)
TARGET=vda2fbd
-CC = gcc
-YACC = bison -b y
-#YACC = yacc
+CC ?= gcc
+#YACC = bison -b y
+YACC = yacc
LEX = flex
YFLAGS = -d
-CFLAGS = -g -O2 # -ansi -Wall
+CFLAGS += -g -O2 # -ansi -Wall
LDFLAGS = -lm
LEX_OBJS = y.tab.o lex.yy.o

View File

@ -0,0 +1,68 @@
This patch was submitted to the CalculiX mailing list so hopefully we will
not have to include it in future versions of the software. -- pfg 2003
--- enqu_fbd.c.orig Mon May 5 20:21:49 2003
+++ enqu_fbd.c Mon May 5 20:22:08 2003
@@ -17,7 +17,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <malloc.h>
+#include <stdlib.h>
#include <stdio.h>
#include "fbd.h"
--- enqu_vda.c.orig Mon May 5 20:18:15 2003
+++ enqu_vda.c Mon May 5 20:19:05 2003
@@ -17,7 +17,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <malloc.h>
+#include <stdlib.h>
#include <stdio.h>
#include "vda.h"
--- fbd_main.c.orig Mon May 5 20:19:35 2003
+++ fbd_main.c Mon May 5 20:20:00 2003
@@ -17,7 +17,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <malloc.h>
+#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include "vda.h"
--- init_vda.c.orig Mon May 5 20:17:32 2003
+++ init_vda.c Mon May 5 20:17:50 2003
@@ -19,7 +19,7 @@
#include <stdio.h>
#include <string.h>
-#include <malloc.h>
+#include <stdlib.h>
#include "vda.h"
extern int max_u_order, max_v_order;
--- vda.y.orig Mon May 5 20:13:57 2003
+++ vda.y Mon May 5 20:14:20 2003
@@ -20,7 +20,7 @@
%{
#include <stdio.h>
#include <string.h>
-#include <malloc.h>
+#include <stdlib.h>
#include "vda.h"
#include "vda_util.h"
--- vda2fbd.c.orig Mon May 5 20:20:34 2003
+++ vda2fbd.c Mon May 5 20:20:57 2003
@@ -17,7 +17,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <malloc.h>
+#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <math.h>

View File

@ -0,0 +1,5 @@
This is a converter from VDA/FS format to fbd format.
Usage:
vda2fbd vdainputfile > fbdoutputfile

View File

@ -0,0 +1,2 @@
bin/vda2fbd
%%PORTDOCS%%%%DOCSDIR%%/model.ps.gz