1
0
Fork 0
Commit Graph

104 Commits

Author SHA1 Message Date
Samuel Clay eda8aff38b Fix misleading description on configure options 2021-11-04 08:31:54 -06:00
Samuel Clay 2ff409d3af
Update configure.ac
Fix misleading description on configure options
2021-11-03 21:29:45 -06:00
Witold Filipczyk 47e199ade9 [configure.ac] mozjs up to 78 2021-09-10 19:18:05 +02:00
Witold Filipczyk 7f6156f2c5 [gettext] autotools part 2021-08-08 22:04:52 +02:00
Witold Filipczyk 0951190949 [configure.ac] Fix build without spidermonkey 2021-07-21 21:29:58 +02:00
Witold Filipczyk d4f280d325 [configure.ac] Compile with libxml++-5.0
Note, disable CSS if do not want segfaults
2021-07-09 17:52:15 +02:00
Witold Filipczyk 0d76fc0f2a [gemini] optional, not enabled by default 2021-07-02 21:28:48 +02:00
Witold Filipczyk 9328fa261e [libdom] libdom also retired 2021-06-12 17:37:11 +02:00
Witold Filipczyk 908fa22878 [htmlcxx] htmlcxx retired 2021-06-12 13:29:05 +02:00
Witold Filipczyk c45c98438f [configure.ac] Added htmlcxx 2021-04-20 21:19:23 +02:00
nobody@earth.com a19b95f20c [smjs local storage] spider monkey local storage 2021-02-22 23:27:19 +01:00
Witold Filipczyk f13022b36d [configure.ac] Show error message about libgcrypt-config. Refs #86 2021-01-16 16:52:12 +01:00
Witold Filipczyk df2540be55 [configure.ac] Disable spidermonkey by default. Refs #85
If you want to build Spidermonkey support with autotools, you
must explicitly add --with-spidermonkey to ./configure invocation
and use C++ compiler as CC.
2021-01-16 11:10:50 +01:00
Witold Filipczyk b8db1173c1 [configure.ac] Compilation fix for autoconf2.70 and compilation with g++ 2021-01-16 10:58:18 +01:00
Witold Filipczyk bdc6e05410 [headers] check stdalign.h 2021-01-13 22:02:30 +01:00
Witold Filipczyk 0fea79cc8f [cflags] Removed -Wno-pointer-sign
Likely some new bugs were introduced by this change.
The long term goal is clean compilation by g++.
2021-01-02 16:20:27 +01:00
Witold Filipczyk d05f781792 [version] 0.15.GIT 2020-12-27 19:39:52 +01:00
Witold Filipczyk d976790a10 [NEWS] Info about 0.14.0 2020-12-27 14:59:40 +01:00
Witold Filipczyk 8f6ff41a62 [NEWS] Info about elinks-0.14.0rc2 2020-12-13 18:11:45 +01:00
Witold Filipczyk 672c5fce52 [NEWS] Info about 0.14.0rc1 2020-12-06 15:46:28 +01:00
Witold Filipczyk a24cea2d87 [configure.ac] PKG_CONFIG_STATIC -> pkg_config_static 2020-11-24 19:36:29 +01:00
Witold Filipczyk a92df85c11 [spidermonkey] Changes in setTimeout.
Spidermonkey is "hardcoded" in ecmascript, but ecmascript script engine
is rarely being changed.
2020-11-22 16:42:23 +01:00
Witold Filipczyk 6171e286bd [static] Added --with-static option 2020-11-09 22:04:48 +01:00
Witold Filipczyk 000b391c2d [brotli] used pkg-config for libbrotlidec
This will let build static binary with brotli.
2020-11-09 21:16:43 +01:00
Witold Filipczyk aeeb5c69a2 [configure.ac] Added -fpermissive for SpiderMonkey
If you want to build with SpiderMonkey, you must compile by g++.
Current state is it segfaults often.
2020-10-27 15:05:31 +01:00
Witold Filipczyk d1ecd45828 [mozjs52] It compiles, but often segfaults. No idea yet how to fix it. 2020-10-27 14:53:24 +01:00
Witold Filipczyk a5b68a25a1 [mozjs45] Code is unstable, but at least compiles. 2020-10-23 22:34:58 +02:00
Witold Filipczyk 01c511f52d [mozjs38] ELinks is compilable, was not heavily tested. 2020-10-16 19:54:02 +02:00
Witold Filipczyk dd704b900a [mozjs31] SpiderMonkey updated to mozjs31. TODO: smjs scripting. 2020-10-11 15:42:59 +02:00
Witold Filipczyk 1f57e72212 [mozjs24] Allow build elinks with g++
SpiderMonkey was updated to mozjs24. If you want to build elinks
with ecmascript support, you must compile using g++ with -fpermissive .
There is a lot of warnings.
There are some memleaks in ecmascript code, especially related to JSAutoCompartment.
I don't know yet, where and how to free it.

Debian does not support mozjs24, so I'm going to gradually update SpiderMonkey version.
2020-10-05 20:14:55 +02:00
Witold Filipczyk 2a16aa91fe [meson] Generate elinks.spec and changes in contrib 2020-09-07 17:48:37 +02:00
Felix Janda 9e08ea995a docs: generate pdfs using dblatex 2020-09-03 12:44:43 -04:00
Witold Filipczyk e4b10df949 [configure.ac] --with-luapkg=name let user choose Lua version
For example:
--with-luapkg=luajit
or
--with-luapkg=lua5.2
etc.
If you do not want lua, omit this configure option or pass --with-luapkg=

Old --without-lua was removed.
2020-05-31 16:24:24 +02:00
Witold Filipczyk 058c3f6d0a [configure.ac] Let build with lua52 or lua53 also. Refs #46
Preferred is lua51, but next are checked 53, and finally 52
2020-05-22 21:01:15 +02:00
Witold Filipczyk 83706c49ba [configure.ac] Do not show warnings related to gettext for gcc-10
It is not a good idea, but warnings also look ugly.
2020-05-18 21:49:58 +02:00
Witold Filipczyk 6a581dd044 [cofigure.ac] gcc-9 on Raspbian 2020-05-17 18:53:57 +02:00
Witold Filipczyk 5967eb93b4 [python3] python3 for asciidoc 2020-01-04 20:12:34 +01:00
Witold Filipczyk a27e9b168c [python3] adjust code to Python3 in test scripts. Refs #38
I don't know how to fix big_file.cgi
If you know how to get equivalent of this script in Python3, tell me.
2020-01-01 16:07:14 +01:00
Witold Filipczyk df905c7481 Changed version. 2019-12-27 17:33:27 +01:00
Witold Filipczyk e8cb012ada [ssl] Allow older versions of openssl. Refs #37 2019-12-06 18:50:31 +01:00
Witold Filipczyk 5c71cc384e [configure] gcc -dumpversion returns 8 on Debian Buster 2019-11-14 15:21:44 +01:00
Witold Filipczyk b3e01b3298 [scripting] python scripting with Python3.
Only utf-8 encoding is supported.
2019-11-11 13:33:37 +01:00
Witold Filipczyk 41164c9d73 [configure.ac] gcc9 2019-08-24 12:42:49 +02:00
Witold Filipczyk 90086599da [encoding] Experimental zstd encoding 2019-07-14 18:54:39 +02:00
Witold Filipczyk 3d96b0d7d7 Revert "Compile with C++."
This reverts commit 4f4df33638.
2019-04-21 12:27:40 +02:00
Witold Filipczyk 4f4df33638 Compile with C++.
Weak points:
- alignof
- js problems

Todo:
- make js work with C++ and mozjs-17
- then mozjs-24
- then mozjs-52
- then mozjs-60
- decrease number of warnings
2019-02-17 20:46:16 +01:00
Witold Filipczyk 25dd2ecae9 Changed ecmascript engine to mozjs-17.0.
Was not tested, especially smjs is likely buggy.
2019-02-10 21:00:37 +01:00
Witold Filipczyk 6ec3fc3f33 More user friendly method to set expires in cookie dialog. 2018-08-25 22:44:11 +02:00
rkd77 26d1759d35
Merge pull request #15 from doughdemon/musl
Musl compatibility
2017-11-24 15:19:55 +01:00
Felix Janda 9555619c50 Remove __va_copy configure test
__va_copy is a macro and can be detected via #ifdef.
2017-11-23 19:15:35 -05:00
KURASAWA Nozomu e1ac2896c6 Add Japanese translations. 2017-11-23 18:42:31 -05:00
Felix Janda bfb4733f39 Don't use <sys/signal.h>
This legacy header appears to be unused. Removing its includes
avoids numerous warnings when compiling with musl libc:

/usr/include/sys/signal.h:1:2: warning: #warning redirecting incorrect #include <sys/signal.h> to <signal.h> [-Wcpp]
2017-11-23 17:51:41 -05:00
Felix Janda c5a6c6bd1b configure: Use AC_USE_SYSTEM_EXTENSIONS
Fixes

warning: AC_COMPILE_IFELSE was called before AC_USE_SYSTEM_EXTENSIONS
2017-11-22 17:02:00 -05:00
Felix Janda 06832623ad Rename configure.in to configure.ac
Avoids aclocal warning
2017-11-22 17:01:48 -05:00