1
0
Fork 0

Clarify the GPL upgrades policy a bit, and propose an addition

The proposed addition is that if the current ELinks maintainer likes
GPLv3, he might have the right to relicence all the default GPLv2-only
contributions to GPLv3. Please state your opinions etc.
This commit is contained in:
Petr Baudis 2005-09-17 03:33:36 +02:00 committed by Petr Baudis
parent eb22654911
commit 9325c52067
1 changed files with 10 additions and 1 deletions

11
COPYING
View File

@ -1,6 +1,15 @@
Note that the only valid version of the GPL as far as ELinks is
concerned is _this_ particular version of the license (ie v2, not v2.2
or v3.x or whatever), unless explicitly otherwise stated.
or v3.x or whatever), unless explicitly stated otherwise. That is at
least the policy for all pasky's contributions and the default - if you
want different policy for your patches, the best way to state it is by
a patch for your AUTHORS entry.
If pasky likes GPLv3, he might relicence his contributions for GPLv3
as well. The default policy should probably be that you trust pasky,
Jonas, or the current maintainer of the day to do the right thing (much
like it is in the Linux kernel). But this needs to be yet worked out
and agreed upon.
-----------------------------------------------------------------------