1
0
Fork 0

Document that GNU Make >= 3.78 is needed, and check it.

This commit is contained in:
Kalle Olavi Niemitalo 2007-12-06 23:46:19 +02:00 committed by Kalle Olavi Niemitalo
parent a2bc397350
commit 4ffbf1faed
2 changed files with 16 additions and 3 deletions

View File

@ -4,6 +4,7 @@ top_builddir=.
SUBDIRS = doc src
SUBDIRS-$(CONFIG_NLS) += po
CLEAN = features.log
calltest = $1-$1
all-recursive: config.h
@ -49,6 +50,16 @@ $(top_srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4)
@echo timestamp > $(top_srcdir)/stamp-h.in 2> /dev/null
# Makefile.lib heavily uses $(call ...), which was added in GNU Make 3.78.
# An elinks-users post on 2007-12-04 reported trouble with GNU Make 3.68.
# Detect this situation and give an error message. $(MAKECMDGOALS) is
# only defined by 3.76 and later, so specify the "all" target as well.
# This check has been tested with GNU Make 3.68, 3.77, 3.78.1, and 3.81.
ifneq ($(call calltest,ok),ok-ok)
$(MAKECMDGOALS) default all:
@echo >&2 "You need GNU Make 3.78 or later"
@false
else
ifeq ($(wildcard Makefile.config),)
# Catch all
$(MAKECMDGOALS) default:
@ -56,3 +67,4 @@ $(MAKECMDGOALS) default:
else
include $(top_srcdir)/Makefile.lib
endif
endif

View File

@ -19,9 +19,10 @@ required or recommended that you install.
Requirements
~~~~~~~~~~~~
To successfully install ELinks all that is required is GNU make and a C
compiler. If you want to install directly from GIT it is also required that
automake and autoconf is installed on your system.
To successfully install ELinks all that is required is GNU make
(version 3.78 or later) and a C compiler. If you want to install
directly from GIT it is also required that automake and autoconf
is installed on your system.
Recommended Libraries and Programs
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~