|
||
---|---|---|
config | ||
hosts | ||
patches | ||
README.md | ||
flake.lock | ||
flake.nix |
README.md
iiogama's Personal NixOS/Home-Manager Configuration
How to build existing system with flake
cd <build repo>
sudo nixos-rebuild switch --flake ".#<hostname>"
How to install new system with flake
- Boot into live NixOS disk and run the following commands:
sudo su
nix-env -iA nixos.git
git clone <repo url> /mnt/etc/nixos
nixos-install --flake ".#<host>"
- Reboot machine, log in, and run the following commands:
sudo rm -r /etc/nixos/configuration.nix
- Move build to desired location.
Nix commands to remember
nix flake update
nix run nixpkgs#<package>
Resources
- Zero To Nix
- The Cute World's NixOS Guide
- NixOS Wiki
- The Nix Hour YouTube Playlist
- Nixology YouTube Playlist
- Nixcloud
Todo
- Create additional host configurations
- Implement the Impermanence module
- Create specific software installations (i.e. gui, gaming, kali-collection, etc)
- Implement Agenix or Sopsnix
- Implement Stylix
- Implement MicroVM.nix