diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a282b1a3d0..4bb9c35d4c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8121,6 +8121,31 @@ experiments.")
 and visualizaton of alternative splicing events generated by rMATS.")
     (license license:expat)))
 
+(define-public r-mdqc
+  (package
+    (name "r-mdqc")
+    (version "1.62.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "mdqc" version))
+       (sha256
+        (base32 "0y35z9sw3h77a5g4ah0fxrk5xh7irdw9z0y2jhh6dp0xxcqh6i0k"))))
+    (properties `((upstream-name . "mdqc")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-cluster
+           r-mass))
+    (home-page "https://bioconductor.org/packages/mdqc")
+    (synopsis "Mahalanobis distance quality control for microarrays")
+    (description
+     "MDQC is a multivariate quality assessment method for microarrays based
+on quality control (QC) reports.  The Mahalanobis distance of an array's
+quality attributes is used to measure the similarity of the quality of that
+array against the quality of the other arrays.  Then, arrays with unusually
+high distances can be flagged as potentially low-quality.")
+    (license license:lgpl2.0+)))
+
 (define-public r-metagenomeseq
   (package
     (name "r-metagenomeseq")