From 832f2bcb926cb4371e65276d09c8d60ab7d6d0a1 Mon Sep 17 00:00:00 2001
From: Luca Cirrottola <luca.cirrottola@inria.fr>
Date: Mon, 29 Jul 2024 19:36:03 +0200
Subject: [PATCH] gnu: hdf5@1.14: Update to 1.14.3.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/maths.scm (hdf5-1.14): Update to 1.14.3.
[arguments]: New field.

Co-authored-by: Ludovic Courtès <ludovic.courtes@inria.fr>
Change-Id: If413ec4d00de0de86020d8f56f2e3f9ec52ed0a9
---
 gnu/packages/maths.scm | 17 ++++++++++++++---
 1 file changed, 14 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e3bb14a3c2..f0f97619f2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1814,7 +1814,7 @@ extremely large and complex data collections.")
 (define-public hdf5-1.14
   (package
     (inherit hdf5-1.8)
-    (version "1.14.0")
+    (version "1.14.3")
     (source
      (origin
        (method url-fetch)
@@ -1828,8 +1828,19 @@ extremely large and complex data collections.")
                                         (take (string-split version #\.) 2))
                                  "/src/hdf5-" version ".tar.bz2")))
        (sha256
-        (base32 "181bdh8hp7v9xqwcby3lknr92lxlicc2hqscba3f5nhf8lrr9rz4"))
-       (patches (search-patches "hdf5-config-date.patch"))))))
+        (base32 "05zr11y3bivfwrbvzbky1q2gjf6r7n92cvvdnh5jilbmxljg49cl"))
+       (patches (search-patches "hdf5-config-date.patch"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments hdf5-1.8)
+       ((#:phases phases #~%standard-phases)
+        #~(modify-phases #$phases
+            (add-after 'configure 'skip-version-test
+              (lambda _
+                ;; Skip test_check_version since the 'patch-settings' phase
+                ;; modifies the test reference.
+                (substitute* "test/test_check_version.sh.in"
+                  (("TESTING\\(\\).*" all)
+                   (string-append all "\nSKIP; exit 0\n")))))))))))
 
 (define-public hdf5
   ;; Default version of HDF5.