From 1cfaa79e6d90eb3eaa476a15abc2c4ca8ee78e03 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 14 Apr 2024 11:27:36 +0100
Subject: [PATCH] gnu: go-github-com-golang-groupcache-lru: Import all go
 modules.

Rename go-github-com-golang-groupcache-lru to
go-github-com-golang-groupcache to reflect go.mod import path as seen in
<https://pkg.go.dev/github.com/golang/groupcache>. It will provide other
available submodules together with main module groupcache: lru,
singleflight, groupcachepb and consistenthash.

* gnu/packages/syncthing.scm (go-github-com-golang-groupcache):
[arguments]: Remove <#:unpack-path>, update <#:import-path> to make
other modules available.
[propagated-inputs]: Add go-github-com-golang-protobuf-proto.

* gnu/packages/ipfs.scm (kubo): [inputs]: Remove
go-github-com-golang-groupcache-lru, add
go-github-com-golang-groupcache.

Change-Id: I455eecd2ebeff5f456f83621aa85b4de7d60304e
---
 gnu/packages/ipfs.scm      | 2 +-
 gnu/packages/syncthing.scm | 9 +++++----
 2 files changed, 6 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 460ee085ec..02678a6b96 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -353,7 +353,7 @@ written in Go.")
                   go-github-com-francoispqt-gojay
                   go-github-com-fsnotify-fsnotify
                   go-github-com-gogo-protobuf
-                  go-github-com-golang-groupcache-lru
+                  go-github-com-golang-groupcache
                   go-github-com-golang-snappy
                   go-github-com-google-uuid
                   go-github-com-gorilla-mux
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 3f8cb808ce..0914d618f5 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -353,11 +353,11 @@ structs in the Go programming language.")
     (home-page "https://github.com/d4l3k/messagediff")
     (license expat)))
 
-(define-public go-github-com-golang-groupcache-lru
+(define-public go-github-com-golang-groupcache
   (let ((commit "869f871628b6baa9cfbc11732cdf6546b17c1298")
         (revision "2"))
     (package
-      (name "go-github-com-golang-groupcache-lru")
+      (name "go-github-com-golang-groupcache")
       (version (git-version "0.0.0" revision commit))
       (source (origin
                 (method git-fetch)
@@ -370,8 +370,9 @@ structs in the Go programming language.")
                   "0r4nk8129bvx50qb4xzjaay39b2h6k7cbdqqzdlanmc82ygczsbw"))))
       (build-system go-build-system)
       (arguments
-       `(#:import-path "github.com/golang/groupcache/lru"
-         #:unpack-path "github.com/golang/groupcache"))
+       `(#:import-path "github.com/golang/groupcache"))
+      (propagated-inputs
+       (list go-github-com-golang-protobuf-proto))
       (synopsis "Groupcache is a caching and cache-filling library")
       (description "Groupcache is a caching and cache-filling library, intended
 as a replacement for memcached in many cases.  It provides a data loading