As advertised, remove net-p2p/qbittorrent.

This commit is contained in:
Doug Barton 2010-05-01 22:44:17 +00:00
parent 02fcbc9134
commit fde5221f27
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253519
9 changed files with 1 additions and 165 deletions

1
MOVED
View File

@ -4368,3 +4368,4 @@ math/libgmp4|math/gmp|2010-04-19|Switch to newer performance release
irc/dircproxy-devel||2010-04-19|Removed
security/krb5-17||2010-04-25|deleted: no longer builds with new OpenSSL 1.0. secuirity/krb5 now contains 1.8.1.
www/blogd|www/ephemera|2010-04-26|Port renamed
net-p2p/qbittorrent|net-p2p/qbittorrent-22|2010-05-01|Old version no longer updated

View File

@ -103,7 +103,6 @@
SUBDIR += py-py2play
SUBDIR += py-vertex
SUBDIR += pyslsk
SUBDIR += qbittorrent
SUBDIR += qbittorrent-22
SUBDIR += qtella
SUBDIR += qtorrent

View File

@ -1,65 +0,0 @@
# New ports collection makefile for: qbittorrent
# Date created: 2007-04-01
# Whom: alepulver
#
# $FreeBSD$
#
PORTNAME= qbittorrent
PORTVERSION= 2.1.6
PORTREVISION= 1
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= dougb@FreeBSD.org
COMMENT= Bittorrent client using Qt4 and libtorrent-rasterbar
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
GeoIP.5:${PORTSDIR}/net/GeoIP
NO_LATEST_LINK= yes
DEPRECATED= The most recent release version is in net-p2p/qbittorrent-22
EXPIRATION_DATE= 2010-05-01
MAKE_JOBS_SAFE= yes
CONFLICTS= qbittorrent*-2.2.*
OPTIONS= NOTIFY "Enable libnotify support" on \
LT_15 "Use 0.15 (devel) version of libtorrent-rasterbar" off
USE_QT_VER= 4
QT_COMPONENTS= corelib gui network xml \
moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-libboost-inc="${LOCALBASE}/include"
INSTALLS_ICONS= yes
MAN1= qbittorrent.1
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NOTIFY)
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+= --disable-libnotify
.endif
.if defined(WITH_LT_15)
LIB_DEPENDS+= torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
.else
LIB_DEPENDS+= torrent-rasterbar.5:${PORTSDIR}/net-p2p/libtorrent-rasterbar-14
.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
${WRKSRC}/src/src.pro
@${ECHO_CMD} "LIBS+= -lexecinfo" >> ${WRKSRC}/src/src.pro
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (qbittorrent-2.1.6.tar.gz) = 01c28bbb0ffc126f9e56f36e3a6d69f8
SHA256 (qbittorrent-2.1.6.tar.gz) = a4746db8d317476f77d7fe13d3fe2df7794d083fbc35bfdc28ca102a320744a2
SIZE (qbittorrent-2.1.6.tar.gz) = 2416012

View File

@ -1,14 +0,0 @@
--- src/createtorrent_imp.cpp.orig 2009-09-21 10:02:50.000000000 +0000
+++ src/createtorrent_imp.cpp 2009-09-21 10:05:18.000000000 +0000
@@ -257,7 +257,11 @@
}
if(abort) return;
// calculate the hash for all pieces
+#if defined(__GNUC__) && __GNUC__ <= 3
+ set_piece_hashes(t, full_path.branch_path(), boost::bind(&sendProgressUpdateSignal, _1, t.num_pieces(), this));
+#else
set_piece_hashes(t, full_path.branch_path(), boost::bind<void>(&sendProgressUpdateSignal, _1, t.num_pieces(), this));
+#endif
// Set qBittorrent as creator and add user comment to
// torrent_info structure
t.set_creator(creator_str);

View File

@ -1,11 +0,0 @@
--- src/filesystemwatcher.h.orig 2009-12-11 04:39:09.000000000 +0900
+++ src/filesystemwatcher.h 2009-12-17 00:41:29.000000000 +0900
@@ -11,7 +11,7 @@
#include <QSet>
#include <iostream>
#include <errno.h>
-#ifdef Q_WS_MAC
+#if defined(Q_WS_MAC) || defined(__FreeBSD__)
#include <sys/param.h>
#include <sys/mount.h>
#else

View File

@ -1,11 +0,0 @@
--- src/misc.h.orig 2009-12-13 19:15:50.000000000 +0900
+++ src/misc.h 2009-12-17 00:34:12.000000000 +0900
@@ -47,7 +47,7 @@
#include <boost/date_time/posix_time/conversion.hpp>
#ifndef Q_WS_WIN
-#ifdef Q_WS_MAC
+#if defined(Q_WS_MAC) || defined(__FreeBSD__)
#include <sys/param.h>
#include <sys/mount.h>
#else

View File

@ -1,22 +0,0 @@
qBittorrent v2 is the closest open source (GNU GPL v2 license) equivalent
to utorrent. It is based on the Qt4 toolkit and libtorrent-rasterbar.
Features:
Well-integrated and extensible Search Engine
Simultaneous search in most famous BitTorrent search sites
Per-category-specific search requests (e.g. Books, Music, Movies)
All Bittorrent extensions
* DHT, Peer Exchange, Full encryption, Magnet URI
Remote control through a Web user interface
* Nearly identical to the regular UI, all in Ajax
Advanced control over trackers, peers and torrents
* Torrents queueing and prioritizing
* Torrent content selection and prioritizing
UPnP / NAT-PMP port forwarding support
Available in ~25 languages (Unicode support)
uTorrent spoofing to bypass private trackers whitelisting
Advanced RSS support with download filters (inc. regex)
IP Filtering (eMule and PeerGuardian compatible)
WWW: http://www.qbittorrent.org/

View File

@ -1,38 +0,0 @@
bin/qbittorrent
share/applications/qBittorrent.desktop
share/icons/hicolor/128x128/apps/qbittorrent.png
share/icons/hicolor/16x16/apps/qbittorrent.png
share/icons/hicolor/192x192/apps/qbittorrent.png
share/icons/hicolor/22x22/apps/qbittorrent.png
share/icons/hicolor/24x24/apps/qbittorrent.png
share/icons/hicolor/32x32/apps/qbittorrent.png
share/icons/hicolor/36x36/apps/qbittorrent.png
share/icons/hicolor/48x48/apps/qbittorrent.png
share/icons/hicolor/64x64/apps/qbittorrent.png
share/icons/hicolor/72x72/apps/qbittorrent.png
share/icons/hicolor/96x96/apps/qbittorrent.png
@dirrmtry share/icons/hicolor/96x96/apps
@dirrmtry share/icons/hicolor/96x96
@dirrmtry share/icons/hicolor/72x72/apps
@dirrmtry share/icons/hicolor/72x72
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor/36x36/apps
@dirrmtry share/icons/hicolor/36x36
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/24x24/apps
@dirrmtry share/icons/hicolor/24x24
@dirrmtry share/icons/hicolor/22x22/apps
@dirrmtry share/icons/hicolor/22x22
@dirrmtry share/icons/hicolor/192x192/apps
@dirrmtry share/icons/hicolor/192x192
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor/128x128/apps
@dirrmtry share/icons/hicolor/128x128
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/applications