- Update to version 0.99.7

Remove file:
files/patch-misc__desktops__Makefile.in

PR:		ports/169007
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Sylvio Cesar Teixeira 2012-06-17 20:21:17 +00:00
parent cdaf90bcfd
commit f33f276c4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299504
4 changed files with 84 additions and 85 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= xine
PORTVERSION= 0.99.6
PORTREVISION= 7
PORTVERSION= 0.99.7
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-ui/${PORTVERSION}
DISTNAME= ${PORTNAME}-ui-${PORTVERSION}
@ -15,24 +14,33 @@ DISTNAME= ${PORTNAME}-ui-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An X11 multimedia player
LICENSE= GPLv2
BUILD_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
# Please update libxine PLUGINSDIR as well (see below)
LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine \
png15:${PORTSDIR}/graphics/png
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
xine:${PORTSDIR}/multimedia/libxine
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
OPTIONS_DEFINE= CACA AALIB LIRC CURL WIN32_CODECS NLS XFT DOCS
OPTIONS_DEFAULT=CURL WIN32_CODECS XFT
WIN32_CODECS_DESC= Enable win32 codecs (for i386 only)
USE_XZ= yes
USE_XORG= x11 xt xtst xv xinerama xxf86vm
USE_XORG= x11 xext xinerama xscrnsaver xt xtst xv xxf86vm
USE_GETTEXT= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-vdr-keys
CONFIGURE_ENV= THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
THREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-vdr-keys \
--disable-nvtvsimple
MAKE_ENV= V=1
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
MANLANG= "" de es fr pl
MAN1_EN= aaxine.1 xine-bugreport.1 xine-check.1 xine-remote.1 xine.1
@ -41,21 +49,13 @@ MAN1_ES= ${MAN1_EN}
MAN1_FR= xine.1
MAN1_PL= aaxine.1 xine-remote.1 xine.1
OPTIONS= CACA "Enable libcaca output" off \
AALIB "Enable aalib output" off \
LIRC "Enable lirc support" off \
CURL "Enable curl support" on \
WIN32_CODECS "Enable win32 codecs (for i386 only)" on \
NLS "Enable Native Language Support" on \
XFT "Enable Xft support" on
DOCSDIR= ${PREFIX}/share/doc/xine-ui
XINE_PLUGINSDIR= lib/xine/plugins/2.1
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
.if !defined(WITHOUT_WIN32_CODECS)
.if ${PORT_OPTIONS:MWIN32_CODECS}
RUN_DEPENDS+= ${CODEC_DETECTION_FILE}:${CODEC_PORT}
CODEC_PORT= ${PORTSDIR}/multimedia/win32-codecs
@ -63,63 +63,74 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.if !defined(WITHOUT_XFT)
.if ${PORT_OPTIONS:MXFT}
USE_XORG+= xft
.else
CONFIGURE_ARGS+= --disable-xft
.endif
.if !defined(WITHOUT_CURL)
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --without-curl
.endif
.if defined(WITH_LIRC)
LIB_DEPENDS+= lirc_client.2:${PORTSDIR}/comms/lirc
CONFIGURE_ARGS+= --enable-lirc
.if ${PORT_OPTIONS:MLIRC}
LIB_DEPENDS+= lirc_client:${PORTSDIR}/comms/lirc
CONFIGURE_ENV+= LIRC_CFLAGS="-I${LOCALBASE}/include" \
LIRC_LIBS="-L${LOCALBASE}/libs -llirc_client"
CONFIGURE_ARGS+= --enable-lirc
.else
CONFIGURE_ARGS+= --disable-lirc
.endif
.if defined(WITH_CACA)
.if ${PORT_OPTIONS:MCACA}
.if !exists(${LOCALBASE}/${XINE_PLUGINSDIR}/xineplug_vo_out_caca.so)
IGNORE= libxine should be compiled with caca support
.endif
LIB_DEPENDS+= caca.0:${PORTSDIR}/graphics/libcaca
PLIST_SUB+= WITH_CACA=""
LIB_DEPENDS+= caca:${PORTSDIR}/graphics/libcaca
PLIST_SUB+= CACA=""
.else
PLIST_SUB+= WITH_CACA="@comment "
CONFIGURE_ARGS+= --without-caca
PLIST_SUB+= CACA="@comment "
.endif
.if defined(WITH_AALIB)
LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
PLIST_SUB+= WITH_AALIB=""
.if ${PORT_OPTIONS:MAALIB}
LIB_DEPENDS+= aa:${PORTSDIR}/graphics/aalib
CONFIGURE_ARGS+= --with-aalib
PLIST_SUB+= AALIB=""
.else
PLIST_SUB+= WITH_AALIB="@comment "
CONFIGURE_ARGS+= --without-aalib --disable-aalibtest
PLIST_SUB+= AALIB="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e \
's|THREAD_LIBS=.*$$|THREAD_LIBS="\$$THREAD_LIBS"|g ; \
s|THREAD_CFLAGS=.*$$|THREAD_CFLAGS="\$$THREAD_CFLAGS"|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/xitk/download.c
'/THREAD_LIBS/s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|<string.h>|<strings.h>|' ${WRKSRC}/src/aaui/main.c
.for file in doc/Makefile.in src/xitk/xine-toolkit/Makefile.in
@${REINPLACE_CMD} -e \
's|: install-docsDATA|:|' ${WRKSRC}/${file}
.endfor
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc \
&& ${INSTALL_DATA} README* ${DOCSDIR}
@${MKDIR} ${PREFIX}/share/doc/xitk
cd ${WRKSRC}/src/xitk/xine-toolkit \
&& ${INSTALL_DATA} README ${PREFIX}/share/doc/xitk
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (xine-ui-0.99.6.tar.xz) = 4eb1e3eb6c2ebba70f2e215a15d8b99bb3e2b0449c94105dc16e963a99a59ef3
SIZE (xine-ui-0.99.6.tar.xz) = 1797144
SHA256 (xine-ui-0.99.7.tar.xz) = 9d8cdfd1c5c84251d6978765b059adf57099ff6c447f3e4b59066c8563f66bc4
SIZE (xine-ui-0.99.7.tar.xz) = 1752328

View File

@ -1,11 +0,0 @@
--- ./misc/desktops/Makefile.in.orig 2010-03-06 04:34:49.000000000 +0300
+++ ./misc/desktops/Makefile.in 2010-12-23 00:13:47.494601700 +0300
@@ -269,7 +269,7 @@
icon32_DATA = icons/32/xine.png
icon48_DATA = icons/48/xine.png
pixmap_DATA = xine.xpm
-desktopdir = $(datadir)/xine/desktop
+desktopdir = $(datadir)/applications
desktop_DATA = xine.desktop
all: all-am

View File

@ -1,35 +1,35 @@
%%WITH_AALIB%%bin/aaxine
%%WITH_CACA%%bin/cacaxine
%%AALIB%%bin/aaxine
%%CACA%%bin/cacaxine
bin/fbxine
bin/xine
bin/xine-bugreport
bin/xine-check
bin/xine-remote
share/applications/xine.desktop
%%DOCSDIR%%/README.config_en
%%DOCSDIR%%/README.cs.0.Introduction
%%DOCSDIR%%/README.cs.10.Remote_control
%%DOCSDIR%%/README.cs.15.MRLs
%%DOCSDIR%%/README.cs.5.xine-ui
%%DOCSDIR%%/README.en.0.Introduction
%%DOCSDIR%%/README.en.10.Remote_control
%%DOCSDIR%%/README.en.15.MRLs
%%DOCSDIR%%/README.en.20.DVD
%%DOCSDIR%%/README.en.25.VideoCD
%%DOCSDIR%%/README.en.30.Advanced
%%DOCSDIR%%/README.en.32.Window_managers
%%DOCSDIR%%/README.en.35.Legal_issues
%%DOCSDIR%%/README.en.5.xine-ui
%%DOCSDIR%%/README_cs
%%DOCSDIR%%/README_de
%%DOCSDIR%%/README_en
%%DOCSDIR%%/README_es
%%DOCSDIR%%/README_fi
%%DOCSDIR%%/README_fr
%%DOCSDIR%%/README_it
%%DOCSDIR%%/README_pl
%%DOCSDIR%%/README_uk
share/doc/xitk/README
%%PORTDOCS%%%%DOCSDIR%%/README.config_en
%%PORTDOCS%%%%DOCSDIR%%/README.cs.0.Introduction
%%PORTDOCS%%%%DOCSDIR%%/README.cs.10.Remote_control
%%PORTDOCS%%%%DOCSDIR%%/README.cs.15.MRLs
%%PORTDOCS%%%%DOCSDIR%%/README.cs.5.xine-ui
%%PORTDOCS%%%%DOCSDIR%%/README.en.0.Introduction
%%PORTDOCS%%%%DOCSDIR%%/README.en.10.Remote_control
%%PORTDOCS%%%%DOCSDIR%%/README.en.15.MRLs
%%PORTDOCS%%%%DOCSDIR%%/README.en.20.DVD
%%PORTDOCS%%%%DOCSDIR%%/README.en.25.VideoCD
%%PORTDOCS%%%%DOCSDIR%%/README.en.30.Advanced
%%PORTDOCS%%%%DOCSDIR%%/README.en.32.Window_managers
%%PORTDOCS%%%%DOCSDIR%%/README.en.35.Legal_issues
%%PORTDOCS%%%%DOCSDIR%%/README.en.5.xine-ui
%%PORTDOCS%%%%DOCSDIR%%/README_cs
%%PORTDOCS%%%%DOCSDIR%%/README_de
%%PORTDOCS%%%%DOCSDIR%%/README_en
%%PORTDOCS%%%%DOCSDIR%%/README_es
%%PORTDOCS%%%%DOCSDIR%%/README_fi
%%PORTDOCS%%%%DOCSDIR%%/README_fr
%%PORTDOCS%%%%DOCSDIR%%/README_it
%%PORTDOCS%%%%DOCSDIR%%/README_pl
%%PORTDOCS%%%%DOCSDIR%%/README_uk
%%PORTDOCS%%share/doc/xitk/README
share/icons/hicolor/16x16/apps/xine.png
share/icons/hicolor/22x22/apps/xine.png
share/icons/hicolor/32x32/apps/xine.png
@ -62,11 +62,10 @@ share/icons/hicolor/48x48/apps/xine.png
%%NLS%%share/locale/uk/LC_MESSAGES/xine-ui.mo
%%NLS%%share/locale/uk/LC_MESSAGES/xitk.mo
share/mime/packages/xine-ui.xml
share/mime/text/x-xine.xml
share/pixmaps/xine.xpm
%%DATADIR%%/oxine/mainmenu
%%DATADIR%%/oxine/mediamarks
%%DATADIR%%/skins/xine-ui_logo.mpv
%%DATADIR%%/skins/xine-ui_logo.png
%%DATADIR%%/skins/xine_splash.png
%%DATADIR%%/skins/xinetic/BigArrowDown.png
%%DATADIR%%/skins/xinetic/BigArrowLeft.png
@ -130,7 +129,7 @@ share/pixmaps/xine.xpm
%%DATADIR%%/skins/xinetic/SmallArrowDown.png
%%DATADIR%%/skins/xinetic/SmallArrowUp.png
%%DATADIR%%/skins/xinetic/skinconfig
%%DATADIR%%/visuals/default.avi
%%DATADIR%%/visuals/default.mpv
@dirrm %%DATADIR%%/visuals
@dirrm %%DATADIR%%/skins/xinetic
@dirrm %%DATADIR%%/skins
@ -146,8 +145,8 @@ share/pixmaps/xine.xpm
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/doc/xitk
@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrmtry share/doc/xitk
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications
@dirrmtry man/pl/man1
@dirrmtry man/pl