add xtheater 1.0.0p1

MPEG-1 player in GTK+ capable of playing MPEG-1 format streams
This commit is contained in:
Ying-Chieh Liao 2002-06-08 14:31:36 +00:00
parent 4832003577
commit bfc87f8f4f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60859
13 changed files with 131 additions and 0 deletions

View File

@ -400,6 +400,7 @@
SUBDIR += xpm
SUBDIR += xpx
SUBDIR += xsane
SUBDIR += xtheater
SUBDIR += xv
SUBDIR += xv-m17n
SUBDIR += xvid

View File

@ -0,0 +1,33 @@
# ex:ts=8
# Ports collection makefile for: xtheater
# Date created: Jun 7, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= xtheater
PORTVERSION= 1.0.0p1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= Xtheater-${PORTVERSION:S/p/-pre/}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12 \
smpeg:${PORTSDIR}/graphics/smpeg \
aviplay:${PORTSDIR}/graphics/avifile
USE_BZIP2= yes
USE_XLIB= yes
USE_GTK= yes
USE_MESA= yes
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE} ${PTHREAD_LIBS}"
USE_GMAKE= yes
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Xtheater-1.0.0-pre1.tar.bz2) = b44c7eb4d33d9672296cf8ce3fa1275a

View File

@ -0,0 +1,11 @@
--- plugins/player/smpeg/Makefile.in.orig Sat Jun 8 02:47:41 2002
+++ plugins/player/smpeg/Makefile.in Sat Jun 8 02:47:57 2002
@@ -94,7 +94,7 @@
@USE_GL_TRUE@GL_LIBS = -lGL -lGLU
@USE_GL_FALSE@GL_LIBS =
LIBS = $(SMPEG_LIBS) $(GL_LIBS)
-INCLUDES = -I.. $(SMPEG_CFLAGS) $(GLIB_CFLAGS)
+INCLUDES = -I.. $(SMPEG_CFLAGS) $(GLIB_CFLAGS) -I${X11BASE}/include
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../../config.h
CONFIG_CLEAN_FILES =

View File

@ -0,0 +1 @@
MPEG-1 player in GTK+ capable of playing MPEG-1 format streams

View File

@ -0,0 +1,6 @@
Xtheater is a Media Player for linux capable of playing MPEG video and audio
files, network streams, and VCDs, as well as AVI and ASF files. It tries to
keep things simple and straightforward to provide the simplest, most stable
behavior as possilbe, while at the same time offering a nice featureset.
WWW: http://xtheater.sourceforge.net/

View File

@ -0,0 +1,13 @@
bin/xtheater
Xtheater/player/libsmpeg-1.0.0-pre1.so
Xtheater/player/libsmpeg.a
Xtheater/player/libsmpeg.la
Xtheater/player/libsmpeg.so
Xtheater/ui/libgtkui-1.0.0-pre1.so
Xtheater/ui/libgtkui.a
Xtheater/ui/libgtkui.la
Xtheater/ui/libgtkui.so
Xtheater/config
@dirrm Xtheater/player
@dirrm Xtheater/ui
@dirrm Xtheater

View File

@ -0,0 +1,33 @@
# ex:ts=8
# Ports collection makefile for: xtheater
# Date created: Jun 7, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= xtheater
PORTVERSION= 1.0.0p1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= Xtheater-${PORTVERSION:S/p/-pre/}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12 \
smpeg:${PORTSDIR}/graphics/smpeg \
aviplay:${PORTSDIR}/graphics/avifile
USE_BZIP2= yes
USE_XLIB= yes
USE_GTK= yes
USE_MESA= yes
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE} ${PTHREAD_LIBS}"
USE_GMAKE= yes
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Xtheater-1.0.0-pre1.tar.bz2) = b44c7eb4d33d9672296cf8ce3fa1275a

View File

@ -0,0 +1,11 @@
--- plugins/player/smpeg/Makefile.in.orig Sat Jun 8 02:47:41 2002
+++ plugins/player/smpeg/Makefile.in Sat Jun 8 02:47:57 2002
@@ -94,7 +94,7 @@
@USE_GL_TRUE@GL_LIBS = -lGL -lGLU
@USE_GL_FALSE@GL_LIBS =
LIBS = $(SMPEG_LIBS) $(GL_LIBS)
-INCLUDES = -I.. $(SMPEG_CFLAGS) $(GLIB_CFLAGS)
+INCLUDES = -I.. $(SMPEG_CFLAGS) $(GLIB_CFLAGS) -I${X11BASE}/include
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../../config.h
CONFIG_CLEAN_FILES =

View File

@ -0,0 +1 @@
MPEG-1 player in GTK+ capable of playing MPEG-1 format streams

View File

@ -0,0 +1,6 @@
Xtheater is a Media Player for linux capable of playing MPEG video and audio
files, network streams, and VCDs, as well as AVI and ASF files. It tries to
keep things simple and straightforward to provide the simplest, most stable
behavior as possilbe, while at the same time offering a nice featureset.
WWW: http://xtheater.sourceforge.net/

View File

@ -0,0 +1,13 @@
bin/xtheater
Xtheater/player/libsmpeg-1.0.0-pre1.so
Xtheater/player/libsmpeg.a
Xtheater/player/libsmpeg.la
Xtheater/player/libsmpeg.so
Xtheater/ui/libgtkui-1.0.0-pre1.so
Xtheater/ui/libgtkui.a
Xtheater/ui/libgtkui.la
Xtheater/ui/libgtkui.so
Xtheater/config
@dirrm Xtheater/player
@dirrm Xtheater/ui
@dirrm Xtheater