sysutils/polkit: Update to 0.119
PR: 256405 Reported by: Olivier Duchateau <duchateau.olivier@gmail.com> Security: CVE-2021-3560
This commit is contained in:
parent
ca252e85c7
commit
ba6b6059f6
@ -1,7 +1,7 @@
|
||||
# Created by: Koop Mast<kwm@FreeBSD.org>
|
||||
|
||||
PORTNAME= polkit
|
||||
PORTVERSION= 0.118
|
||||
PORTVERSION= 0.119
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= https://www.freedesktop.org/software/polkit/releases/
|
||||
|
||||
@ -12,40 +12,37 @@ LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libexpat.so:textproc/expat2 \
|
||||
libdbus-1.so:devel/dbus \
|
||||
libmozjs-78.so:lang/spidermonkey78
|
||||
RUN_DEPENDS= dbus-launch:devel/dbus
|
||||
|
||||
USERS= polkitd
|
||||
GROUPS= polkitd
|
||||
|
||||
USES= compiler:c++11-lib gettext gmake gnome libtool localbase \
|
||||
USES= compiler:c++11-lib gettext gnome libtool localbase meson \
|
||||
pathfix pkgconfig shebangfix
|
||||
USE_GNOME= glib20 intltool introspection:build
|
||||
SHEBANG_FILES= ${WRKSRC}/src/polkitbackend/toarray.pl
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --disable-gtk-doc-html \
|
||||
--without-html-dir \
|
||||
--with-authfw=pam \
|
||||
--with-pam-include=system \
|
||||
--with-os-type=freebsd \
|
||||
--with-polkitd-user=${USERS} \
|
||||
--disable-static \
|
||||
--disable-examples \
|
||||
--enable-libsystemd-login=no \
|
||||
--enable-libelogind=no \
|
||||
--disable-test \
|
||||
--enable-introspection=yes \
|
||||
--localstatedir=/var
|
||||
#MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
MESON_ARGS= -Dpam_include=system \
|
||||
-Dpolkitd_user=${USERS} \
|
||||
-Dexamples=false \
|
||||
-Dsession_tracking=ConsoleKit \
|
||||
-Dtests=false \
|
||||
-Dintrospection=true \
|
||||
-Dlocalstatedir=/var \
|
||||
-Dgtk_doc=false
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
OPTIONS_DEFINE= MANPAGES
|
||||
OPTIONS_DEFINE= MANPAGES
|
||||
|
||||
MANPAGES_BUILD_DEPENDS= docbook-sgml>=4.5:textproc/docbook-sgml \
|
||||
docbook-xsl>=1.76:textproc/docbook-xsl
|
||||
MANPAGES_USE= gnome=libxslt:build
|
||||
MANPAGES_CONFIGURE_ENABLE= man-pages
|
||||
OPTIONS_SUB= yes
|
||||
docbook-xsl>=1.76:textproc/docbook-xsl
|
||||
MANPAGES_USE= gnome=libxslt:build
|
||||
MANPAGES_MESON_TRUE= man
|
||||
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
@ -57,9 +54,8 @@ post-patch:
|
||||
${WRKSRC}/docs/man/polkit.xml
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}/var/lib/polkit-1
|
||||
${INSTALL_DATA} ${WRKSRC}/data/org.freedesktop.PolicyKit1.conf \
|
||||
${STAGEDIR}${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.sample
|
||||
@${MKDIR} ${STAGEDIR}/var/lib/polkit-1 \
|
||||
${STAGEDIR}${PREFIX}/share/polkit-1/rules.d
|
||||
.for i in 10-vendor.d 20-org.d 30-site.d 50-local.d 90-mandatory.d
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/etc/polkit-1/localauthority/${i}
|
||||
${MKDIR} ${STAGEDIR}/var/lib/polkit-1/localauthority/${i}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1600104913
|
||||
SHA256 (polkit-0.118.tar.gz) = 6d54e984e7072339f0d3147179e16e34e5fe0705158f259a765d772dcf78956b
|
||||
SIZE (polkit-0.118.tar.gz) = 1556765
|
||||
TIMESTAMP = 1622741145
|
||||
SHA256 (polkit-0.119.tar.gz) = c8579fdb86e94295404211285fee0722ad04893f0213e571bd75c00972fd1f5c
|
||||
SIZE (polkit-0.119.tar.gz) = 1387409
|
||||
|
11
sysutils/polkit/files/patch-data_meson.build
Normal file
11
sysutils/polkit/files/patch-data_meson.build
Normal file
@ -0,0 +1,11 @@
|
||||
--- data/meson.build.orig 2021-01-05 14:42:11 UTC
|
||||
+++ data/meson.build
|
||||
@@ -10,7 +10,7 @@ configure_file(
|
||||
|
||||
configure_file(
|
||||
input: 'org.freedesktop.PolicyKit1.conf.in',
|
||||
- output: '@BASENAME@',
|
||||
+ output: '@BASENAME@.sample',
|
||||
configuration: {'polkitd_user': polkitd_user},
|
||||
install: true,
|
||||
install_dir: dbus_policydir,
|
27
sysutils/polkit/files/patch-meson.build
Normal file
27
sysutils/polkit/files/patch-meson.build
Normal file
@ -0,0 +1,27 @@
|
||||
--- meson.build.orig 2021-06-03 13:56:35 UTC
|
||||
+++ meson.build
|
||||
@@ -129,7 +129,7 @@ assert(cc.has_function('XML_ParserCreate', dependencie
|
||||
mozjs_dep = dependency('mozjs-78')
|
||||
|
||||
dbus_dep = dependency('dbus-1')
|
||||
-dbus_confdir = dbus_dep.get_pkgconfig_variable('datadir', define_variable: ['datadir', pk_prefix / pk_datadir]) #changed from sysconfdir with respect to commit#8eada3836465838
|
||||
+dbus_confdir = dbus_dep.get_pkgconfig_variable('sysconfdir', define_variable: ['sysconfdir', pk_prefix / 'etc']) #changed from sysconfdir with respect to commit#8eada3836465838
|
||||
dbus_policydir = dbus_confdir / 'dbus-1/system.d'
|
||||
dbus_system_bus_services_dir = dbus_dep.get_pkgconfig_variable('system_bus_services_dir', define_variable: ['datadir', pk_prefix / pk_datadir])
|
||||
|
||||
@@ -318,15 +318,6 @@ endif
|
||||
configure_file(
|
||||
output: 'config.h',
|
||||
configuration: config_h,
|
||||
-)
|
||||
-
|
||||
-meson.add_install_script(
|
||||
- 'meson_post_install.py',
|
||||
- get_option('bindir'),
|
||||
- pk_pkgdatadir,
|
||||
- pk_pkglibdir,
|
||||
- pk_pkgsysconfdir,
|
||||
- polkitd_user,
|
||||
)
|
||||
|
||||
output = '\n ' + meson.project_name() + ' ' + meson.project_version() + '\n'
|
Loading…
Reference in New Issue
Block a user