Add port of libutp -- a TCP-like networking API using UDP-transport.

This commit is contained in:
Mikhail Teterin 2012-07-27 22:44:24 +00:00
parent 863cbb267b
commit b9722a5f90
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301628
7 changed files with 100 additions and 0 deletions

View File

@ -347,6 +347,7 @@
SUBDIR += libtnl
SUBDIR += libtrace
SUBDIR += libunp
SUBDIR += libutp
SUBDIR += libvncserver
SUBDIR += liferea
SUBDIR += linc

31
net/libutp/Makefile Normal file
View File

@ -0,0 +1,31 @@
# New ports collection makefile for: libutp
# Date created: July 26, 2012
# Whom: Mikhail Teterin <mi@aldan.algebra.com>
#
# $FreeBSD$
#
PORTNAME= bittorrent-libutp
PORTVERSION= 0.20120526
DISTVERSION= d4685a3
CATEGORIES= net devel
MASTER_SITES= https://github.com/bittorrent/libutp/tarball/${DISTVERSION}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= The uTorrent Transport Protocol library
LICENSE= MIT
USE_DOS2UNIX= yes
MAKEFILE= ${FILESDIR}/BSDmakefile
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
# GitHub will issue a 302 redirect, no way around that, so we
# have to allow fetch(1) to follow the redirect, which is normally
# prevented by the -A flag:
FETCH_ARGS= -Fpr
pre-su-install:
${MKDIR} ${PREFIX}/include/libutp
.include <bsd.port.mk>

2
net/libutp/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (bittorrent-libutp-d4685a3.tar.gz) = 0b4096d3a03cd171743a6f1db37e4cb1d6c8ef27bbebbc21a3eb9ee93c37b37f
SIZE (bittorrent-libutp-d4685a3.tar.gz) = 70654

View File

@ -0,0 +1,13 @@
LIB= utp
SHLIB_MAJOR= 0
SRCS= utp.cpp utp_utils.cpp
CXXFLAGS+= -fno-exceptions -fno-rtti
CXXFLAGS+= -I${.CURDIR} -I${.CURDIR}/utp_config_lib -DPOSIX
CXXFLAGS+= -Wall
INCLUDEDIR= ${PREFIX}/include/libutp
LIBDIR= ${PREFIX}/lib
INCS= utp.h utp_utils.h utypes.h
.include <bsd.lib.mk>

View File

@ -0,0 +1,34 @@
--- utypes.h 2012-05-26 22:02:05.000000000 -0400
+++ utypes.h 2012-07-26 17:21:44.000000000 -0400
@@ -2,13 +2,15 @@
#define __UTYPES_H__
+#include <stdint.h>
+
// standard types
-typedef unsigned char byte;
-typedef unsigned char uint8;
-typedef signed char int8;
-typedef unsigned short uint16;
-typedef signed short int16;
+typedef uint8_t byte;
+typedef uint8_t uint8;
+typedef int8_t int8;
+typedef uint16_t uint16;
+typedef int16_t int16;
typedef unsigned int uint;
-typedef unsigned int uint32;
-typedef signed int int32;
+typedef uint32_t uint32;
+typedef int32_t int32;
#ifdef _MSC_VER
@@ -16,6 +18,6 @@
typedef signed __int64 int64;
#else
-typedef unsigned long long uint64;
-typedef long long int64;
+typedef uint64_t uint64;
+typedef int64_t int64;
#endif

12
net/libutp/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
# libutp - The uTorrent Transport Protocol library.
Copyright (c) 2010 BitTorrent, Inc.
uTP provides provides reliable, ordered delivery while maintaining
minimum extra delay. It is implemented on top of UDP to be
cross-platform and functional today. As a result, uTP is the primary
transport for uTorrent peer-to-peer connections.
uTP is written in C++, but the external interface is strictly C
(ANSI C89).
WWW: https://github.com/bittorrent/libutp

7
net/libutp/pkg-plist Normal file
View File

@ -0,0 +1,7 @@
lib/libutp.so.0
lib/libutp.so
lib/libutp.a
include/libutp/utp.h
include/libutp/utp_utils.h
include/libutp/utypes.h
@dirrm include/libutp