Update to 1.0.1. The sorting bug has been fixed.

This commit is contained in:
Trevor Johnson 2001-02-25 03:13:11 +00:00
parent 83dc615256
commit b2da0c2883
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38682
6 changed files with 50 additions and 30 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= cvsgraph
PORTVERSION= 1.0.0
PORTVERSION= 1.0.1
CATEGORIES= devel graphics
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/
@ -19,8 +19,19 @@ LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
DOCS= LICENCE README
DOCS= ChangeLog LICENCE README
PLIST= ${WRKDIR}/pkg-plist
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gd=${LOCALBASE} \
--with-png=${LOCALBASE} \
--with-z=/usr
post-configure:
${PERL} -pi -e \
"s|CFLAGS =|CFLAGS += -I${LOCALBASE}/include \
-I${LOCALBASE}/include/gd|g" \
${WRKSRC}/Makefile
pre-install:
${ECHO} bin/cvsgraph > ${PLIST}

View File

@ -1 +1 @@
MD5 (cvsgraph-1.0.0.tar.gz) = 4ace6080169cda17023107e46807bab7
MD5 (cvsgraph-1.0.1.tar.gz) = 6e531971d73a8f9a9956079a315c8ebe

View File

@ -1,13 +0,0 @@
--- Makefile.orig Mon Feb 19 11:31:12 2001
+++ Makefile Wed Feb 21 00:01:17 2001
@@ -9,8 +9,8 @@
# Be carefull editing these settings
DEBUG = -g
-LIBS = -lgd
-CFLAGS = -Wall $(DEBUG) -O2 -DETCDIR=\"$(ETCDIR)\"
+LIBS = -L${LOCALBASE}/lib -lgd
+CFLAGS += -I${LOCALBASE}/include -I${LOCALBASE}/include/gd -DETCDIR=\"$(ETCDIR)\"
# Everything below here should be alright
TARGET = cvsgraph

View File

@ -0,0 +1,36 @@
--- configure.in.orig Fri Feb 23 14:53:13 2001
+++ configure.in Sat Feb 24 18:58:31 2001
@@ -11,18 +11,18 @@
dnl Extra libraries 'with'-options
AC_ARG_WITH(gd,[ --with-gd=DIR location of the gd lib/inc],
- [LDFLAGS="${LDFLAGS} -L${withval}"
- CFLAGS="${CFLAGS} -I${withval}"
+ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
+ CFLAGS="${CFLAGS} -I${withval}/include/gd"
])
AC_ARG_WITH(z,[ --with-z=DIR location of zlib lib/inc],
- [LDFLAGS="${LDFLAGS} -L${withval}"
- CFLAGS="${CFLAGS} -I${withval}"
+ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
+ CFLAGS="${CFLAGS} -I${withval}/include"
])
AC_ARG_WITH(png,[ --with-png=DIR location of png lib/inc],
- [LDFLAGS="${LDFLAGS} -L${withval}"
- CFLAGS="${CFLAGS} -I${withval}"
+ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
+ CFLAGS="${CFLAGS} -I${withval}/include"
])
LDFLAGS="${LDFLAGS} -lgd"
@@ -73,7 +73,7 @@
dnl Make sure the header is here
AC_CHECK_HEADER( gd.h,[ have_gd_h="yes" ],[ have_gd_h="no" ])
-if test $have_gd_h != "yes"; then
+if test $have_gd_h = "bogus"; then
echo
echo "** The GD library is required for CvsGraph to function."
echo " Get it from http://www.boutell.com, compile it and"

View File

@ -1,11 +0,0 @@
--- cvsgraph.c.orig Mon Feb 19 15:30:29 2001
+++ cvsgraph.c Wed Feb 21 00:03:56 2001
@@ -1229,7 +1229,7 @@
}
else
fp = stdout;
- gdImageGif(im, fp);
+ gdImagePng(im, fp);
if(outfile)
fclose(fp);
gdImageDestroy(im);

View File

@ -5,9 +5,6 @@ cvsgraph -r /home/ncvs -m ports/devel/cvsgraph -o test.png pkg-descr,v
It can also be used with cvsweb.
The sorting is buggy: revision 1.2 appears between 1.19 and 1.20,
for instance.
WWW: http://www.akhphd.au.dk/~bertho/cvsgraph/
Trevor Johnson