New port: math/fung-calc

The Fung-Calc is an advanced 3D/2D graphing calculator.

PR:		53138
Submitted by:	Kirill Ponomarew
This commit is contained in:
Max Khon 2003-06-10 12:07:44 +00:00
parent 2cd5526ba0
commit b21c49a18a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82667
11 changed files with 159 additions and 0 deletions

View File

@ -36,6 +36,7 @@
SUBDIR += fftw
SUBDIR += freefem
SUBDIR += fudgit
SUBDIR += fung-calc
SUBDIR += fxt
SUBDIR += gambit
SUBDIR += gap

26
math/fung-calc/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: fung-calc
# Date created: 10.06.2003
# Whom: Kirill Ponomarew <ponomarew@oberon.net>
#
# $FreeBSD$
PORTNAME= fung-calc
PORTVERSION= 1.3.0
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ponomarew@oberon.net
COMMENT= Advanced graphic calculator
USE_KDELIBS_VER= 3
USE_MESA= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
.include <bsd.port.mk>

1
math/fung-calc/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (fung-calc-1.3.0.tar.gz) = 8178d3c53be1b927e6d94bb6426de941

View File

@ -0,0 +1,10 @@
--- fung_calc/libfungcalcui/2D/polargraphmain.ui.h.orig Tue Jun 10 10:08:35 2003
+++ fung_calc/libfungcalcui/2D/polargraphmain.ui.h Tue Jun 10 10:08:48 2003
@@ -6,6 +6,7 @@
** a constructor, and a destroy() slot in place of a destructor.
*****************************************************************************/
#include <fstream>
+#include <ctime>
#include "expression.h"

View File

@ -0,0 +1,10 @@
--- fung_calc/libfungcalcui/2D/parametricgraphmain.ui.h.orig Tue Jun 10 10:10:00 2003
+++ fung_calc/libfungcalcui/2D/parametricgraphmain.ui.h Tue Jun 10 10:10:09 2003
@@ -6,6 +6,7 @@
** a constructor, and a destroy() slot in place of a destructor.
*****************************************************************************/
#include <fstream>
+#include <ctime>
#include "expression.h"

View File

@ -0,0 +1,10 @@
--- fung_calc/libfungcalcui/2D/statplotgraphmain.ui.h.orig Tue Jun 10 10:12:37 2003
+++ fung_calc/libfungcalcui/2D/statplotgraphmain.ui.h Tue Jun 10 10:12:51 2003
@@ -14,6 +14,7 @@
#include "whiskerplot.h"
#include <fstream>
+#include <ctime>
void StatPlotGraphMain::init()
{

View File

@ -0,0 +1,10 @@
--- fung_calc/libfungcalcui/3D/glfunctiongraphmain.ui.h.orig Tue Jun 10 10:14:26 2003
+++ fung_calc/libfungcalcui/3D/glfunctiongraphmain.ui.h Tue Jun 10 10:14:38 2003
@@ -8,6 +8,7 @@
#include <fstream>
#include <iostream>
+#include <ctime>
#include "expression.h"

View File

@ -0,0 +1,10 @@
--- fung_calc/libfungcalcui/3D/glpolargraphmain.ui.h.orig Tue Jun 10 10:15:36 2003
+++ fung_calc/libfungcalcui/3D/glpolargraphmain.ui.h Tue Jun 10 10:15:50 2003
@@ -8,6 +8,7 @@
#include <fstream>
#include <iostream>
+#include <ctime>
#include "expression.h"

View File

@ -0,0 +1,10 @@
--- fung_calc/libfungcalcui/3D/glcylindricalgraphmain.ui.h.orig Tue Jun 10 10:16:57 2003
+++ fung_calc/libfungcalcui/3D/glcylindricalgraphmain.ui.h Tue Jun 10 10:17:06 2003
@@ -8,6 +8,7 @@
#include <fstream>
#include <iostream>
+#include <ctime>
#include "expression.h"

7
math/fung-calc/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
The Fung-Calc is an advanced 3D/2D, yet easy to use, graphing
calculator. It is an attempt to create a complete,
user-friendly grapher with all the features needed for easy
viewing of the graphical display of expressions in various
ways.
WWW: http://fung-calc.sourceforge.net

64
math/fung-calc/pkg-plist Normal file
View File

@ -0,0 +1,64 @@
bin/fung-calc
include/fung-calc/animator.h
include/fung-calc/arclengthfunction.h
include/fung-calc/basicgraph.h
include/fung-calc/cartesian3dcoord.h
include/fung-calc/commongraph.h
include/fung-calc/cylindricalcoord.h
include/fung-calc/definiteintegralfunction.h
include/fung-calc/densityplot.h
include/fung-calc/distancefunction.h
include/fung-calc/expression.h
include/fung-calc/expressiongraph.h
include/fung-calc/frequencyplot.h
include/fung-calc/functiongraph.h
include/fung-calc/fungmath.h
include/fung-calc/fungpainter.h
include/fung-calc/fungparser.h
include/fung-calc/fungvector.h
include/fung-calc/glbasicgraph.h
include/fung-calc/glexpressiongraph.h
include/fung-calc/glfunctiongraph.h
include/fung-calc/glgraphevent.h
include/fung-calc/glparametricgraph.h
include/fung-calc/glpolargraph.h
include/fung-calc/graphevent.h
include/fung-calc/icons.h
include/fung-calc/intersectionfunction.h
include/fung-calc/mathfunction.h
include/fung-calc/maximumfunction.h
include/fung-calc/meanvaluefunction.h
include/fung-calc/minimumfunction.h
include/fung-calc/parametricgraph.h
include/fung-calc/plotmodule.h
include/fung-calc/polarcoord.h
include/fung-calc/polargraph.h
include/fung-calc/rectcoord.h
include/fung-calc/scatterplot.h
include/fung-calc/sphericalcoord.h
include/fung-calc/statinfo.h
include/fung-calc/statplotgraph.h
include/fung-calc/whiskerplot.h
include/fung-calc/zerofunction.h
lib/libfungcalc.la
lib/libfungcalc.so
lib/libfungcalc.so.1
lib/libfungcalcui.la
lib/libfungcalcui.so
lib/libfungcalcui.so.1
share/doc/HTML/en/fung-calc/animationparams.png
share/doc/HTML/en/fung-calc/animationtoolbar.png
share/doc/HTML/en/fung-calc/common
share/doc/HTML/en/fung-calc/index.cache.bz2
share/doc/HTML/en/fung-calc/index.docbook
share/fung-calc/AUTHORS
share/fung-calc/COPYING
share/fung-calc/ChangeLog
share/fung-calc/README
share/fung-calc/TODO
share/fung-calc/samplegraphs.fgc
share/fung-calc/translations/fung-calc.es.qm
@dirrm include/fung-calc
@dirrm share/doc/HTML/en/fung-calc
@dirrm share/fung-calc/translations
@dirrm share/fung-calc