Add ppunpack, a utility to decompress Amiga PowerPacker files.

Obtained from:	NetBSD
This commit is contained in:
Will Andrews 2000-06-03 04:52:13 +00:00
parent 66a77726ff
commit adb85fb929
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29138
7 changed files with 57 additions and 0 deletions

View File

@ -21,6 +21,7 @@
SUBDIR += nulib
SUBDIR += p5-Compress-Zlib
SUBDIR += pkzip
SUBDIR += ppunpack
SUBDIR += rar
SUBDIR += unace
SUBDIR += unarj

View File

@ -0,0 +1,27 @@
# New ports collection makefile for: ppunpack
# Date created: Sat 3 June 2000
# Whom: will
#
# $FreeBSD$
#
PORTNAME= ppunpack
PORTVERSION= 1.0
CATEGORIES= archivers
MASTER_SITES= ftp://de.aminet.net/pub/aminet/misc/unix/ \
ftp://us.aminet.net/pub/aminet/misc/unix/
DISTNAME= ppsmall-${PORTVERSION}
EXTRACT_SUFX= .tar.Z
MAINTAINER= will@FreeBSD.org
RESTRICTED= "No commercial redistribution"
NO_CDROM= ${RESTRICTED}
WRKSRC= ${WRKDIR}/PPUnpack
MAKE_FLAGS= CC="${CC}" COPTS="${CFLAGS}"
ALL_TARGET= ppunpack
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ppunpack ${PREFIX}/bin/
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/05/23 02:01:25 tv Exp $
MD5 (ppsmall-1.0.tar.Z) = 012c6685c386fbac129d54eb561d7ea8

View File

@ -0,0 +1,14 @@
--- depack.h.orig Sat May 22 21:55:32 1999
+++ depack.h Sat May 22 21:56:18 1999
@@ -4,8 +4,10 @@
* see accompanying file README for distribution information
*/
+#include <sys/types.h>
+
typedef unsigned char ubyte;
-typedef unsigned long ulong;
+#define ulong uint
extern ulong depackedlen(ubyte *packed, ulong plen);
extern void ppdepack(ubyte *packed, ubyte *depacked, ulong plen, ulong unplen);

View File

@ -0,0 +1 @@
Decompresses Amiga PowerPacker files

View File

@ -0,0 +1,10 @@
THIS SOURCE-CODE CAN BE USED FOR NON COMMERCIAL PURPOSES ONLY,
IN PPDECRUNCH OR TRACKER.
PLEASE CONTACT Nico Francois (nico.francois@scala.com) FOR ANY
OTHER USES.
ppunpack only unpacks PowerPacker data files. It is only intended
as an help for people who have to process Amiga-related files
on other machines, and don't want to download PowerPacked files to
an Amiga, uncompress the file, and upload it to the other machine.

View File

@ -0,0 +1 @@
bin/ppunpack