- update to 10.25

does not fix the problem generating transparent png's
This commit is contained in:
Dirk Meyer 2004-11-14 07:06:38 +00:00
parent 004c05377e
commit adb5c06c2e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121539
5 changed files with 18 additions and 24 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= netpbm
PORTVERSION= 10.24
PORTVERSION= 10.25
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -19,6 +19,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
jbig.1:${PORTSDIR}/graphics/jbigkit
# jasper.4:${PORTSDIR}/graphics/jasper
USE_PERL5= yes
USE_REINPLACE= yes
@ -48,6 +49,8 @@ pre-configure:
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/pm_config.in.h
@${REINPLACE_CMD} -e 's|<shhopt.h>|<pm_shhopt.h>|g' ${WRKSRC}/lib/pm.h
@${REINPLACE_CMD} -e 's| jpeg2000||g' \
${WRKSRC}/converter/other/Makefile
@${CP} ${FILESDIR}/Makefile.config.FreeBSD ${WRKSRC}/Makefile.config
@${LN} -sf ${WRKSRC}/lib/util/shhopt.h ${WRKSRC}/lib/util/pm_shhopt.h
@${LN} -sf ${WRKSRC}/lib/util/nstring.h ${WRKSRC}/lib/util/pm_nstring.h

View File

@ -1,2 +1,2 @@
MD5 (netpbm-10.24.tgz) = 06580a8cadb6908f95733dcbd3f4e3d8
SIZE (netpbm-10.24.tgz) = 2500156
MD5 (netpbm-10.25.tgz) = ebdf59acdd603c5ef2829df9138b8720
SIZE (netpbm-10.25.tgz) = 2521599

View File

@ -19,6 +19,7 @@ JBIGLIB = ${LOCALBASE}/lib/libjbig.so
JBIGHDR_DIR = ${LOCALBASE}/include
URTLIB = $(BUILDDIR)/urt/librle.a
URTHDR_DIR = $(SRCDIR)/urt
JASPERHDR_DIR = ${LOCALBASE}/include
LINUXSVGALIB = NONE
LINUXSVGAHDR_DIR = NONE
NETPBMLIBTYPE = unixshared

View File

@ -1,12 +0,0 @@
--- converter/other/infotopam.c.orig Sat May 1 21:44:08 2004
+++ converter/other/infotopam.c Thu Jul 22 19:19:16 2004
@@ -73,7 +73,9 @@
#include "mallocvar.h"
#include <errno.h>
+#ifndef __FreeBSD__
#include <stdint.h>
+#endif
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

View File

@ -1,6 +1,6 @@
--- lib/Makefile.orig Thu Mar 18 19:09:21 2004
+++ lib/Makefile Sun Apr 4 08:05:19 2004
@@ -34,6 +34,8 @@
--- lib/Makefile.orig Sat Oct 16 19:29:23 2004
+++ lib/Makefile Sun Nov 14 06:55:14 2004
@@ -35,6 +35,8 @@
# Library objects to be linked but not built by Makefile.common:
LIBOBJECTS_X = util/shhopt.o util/nstring.o
@ -9,14 +9,16 @@
MANUALS3 = libnetpbm
MANUALS5 = pbm pgm ppm pnm pam
@@ -74,12 +76,15 @@
@@ -76,13 +78,17 @@
$(LIBOBJECTS): %.o: %.c $(HEADERLINKS)
# Note that the user may have configured -I options into CFLAGS.
+ $(CC) -c $(INCLUDES) $(CFLAGS) $(CADD) -o $@ $<
+ $(CC) -c $(INCLUDES) -DNDEBUG $(CFLAGS) \
+ $(CFLAGS_PERSONAL) $(CADD) -o $@ $<
+
+$(SHLIBOBJECTS): %.lo: %.c $(HEADERLINKS)
$(CC) -c $(INCLUDES) $(CFLAGS) $(CFLAGS_SHLIB) $(CADD) -o $@ $<
$(CC) -c $(INCLUDES) -DNDEBUG $(CFLAGS) $(CFLAGS_SHLIB) \
$(CFLAGS_PERSONAL) $(CADD) -o $@ $<
MAJ = $(NETPBM_MAJOR_RELEASE)
MIN = $(NETPBM_MINOR_RELEASE)
@ -26,7 +28,7 @@
ifeq ($(NETPBMLIBTYPE),irixshared)
# The libxxx.so link is needed to link the executables.
@@ -104,12 +109,9 @@
@@ -107,12 +113,9 @@
# The $(SONAME) link is needed only to test the programs without
# installing the libraries (in that case, you also need to direct the
# dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
@ -42,7 +44,7 @@
endif
ifeq ($(NETPBMLIBTYPE),dll)
@@ -186,13 +188,10 @@
@@ -189,13 +192,10 @@
.PHONY: install.lib
ifeq ($(NETPBMLIBTYPE),unixshared)
# install a Unix-style shared library
@ -60,7 +62,7 @@
endif
ifeq ($(NETPBMLIBTYPE),dll)
#install a Windows DLL shared library
@@ -222,23 +221,23 @@
@@ -225,23 +225,23 @@
# directory when you compile your programs.
%_installhdr: $(PKGDIR)/include