Update to 9.30. User-visible changes in this release:

* Avoid to prepend quote prefix twice when replying to multipart messages.
* Fixed a problem with empty Content-type fields in multipart messages.
* Allow name lists for -b and -c command line options.
* Added the "showlast" option.
This commit is contained in:
Christian Weisgerber 2002-02-20 15:59:17 +00:00
parent 27e87e07e1
commit abd6f56f04
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54989
10 changed files with 8 additions and 156 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= nail
PORTVERSION= 9.29
PORTREVISION= 1
PORTVERSION= 9.30
CATEGORIES= mail
MASTER_SITES= http://omnibus.ruf.uni-freiburg.de/~gritter/archive/nail/
@ -15,13 +14,11 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rcfile="${PREFIX}/etc"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv"
MAN1= nail.1
post-patch:
@cd ${WRKSRC} && ${TOUCH} Makefile.in aclocal.m4 stamp-h.in
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (nail-9.29.tar.gz) = 2d60eff6c89ba1070ad809be3af1edcf
MD5 (nail-9.30.tar.gz) = b5e233f61b6fa9a8abf4d30b93b2bd71

View File

@ -1,30 +0,0 @@
$FreeBSD$
--- mime.c.orig Mon Nov 19 17:37:47 2001
+++ mime.c Tue Jan 29 01:17:38 2002
@@ -183,7 +183,7 @@
if ((sz = xmbstowcs(w, t, LINESIZE)) == (size_t)-1)
return 0;
for (p = w, i = 0; *p && i < sz; p++, i++) {
- if (!iswprint(*p) && *p != '\n' && *p != '\r'
+ if (!isprint(*p) && *p != '\n' && *p != '\r'
&& *p != '\b' && *p != '\t')
*p = '?';
}
@@ -319,6 +319,7 @@
return p;
}
+#ifndef HAVE_STRCASESTR
/*
* glibc 2.1 provides such a function, but others ...
*/
@@ -346,6 +347,7 @@
}
return p;
}
+#endif
#ifndef HAVE_STRCASECMP
/* One of the things I really HATE on some SysVs is that they still

View File

@ -1,15 +0,0 @@
$FreeBSD$
--- config.h.in.orig Tue Jan 29 01:14:50 2002
+++ config.h.in Tue Jan 29 01:15:46 2002
@@ -75,6 +75,9 @@
/* Define if you have the strcasecmp function. */
#undef HAVE_STRCASECMP
+/* Define if you have the strcasestr function. */
+#undef HAVE_STRCASESTR
+
/* Define if you have the strtol function. */
#undef HAVE_STRTOL

View File

@ -1,26 +0,0 @@
$FreeBSD$
--- configure.in.orig Tue Jan 29 01:13:35 2002
+++ configure.in Tue Jan 29 01:15:12 2002
@@ -130,9 +130,8 @@
dnl Formulate proper paths based on prefix
test "$prefix" = NONE && prefix=/usr/local
dnl We need these seperate to use AC_DEFINED_UNQUOTED
-test "$libdir" = '${exec_prefix}/lib' && libdir=${prefix}/lib
-test "$sysconfdir" = '/etc' && sysconfdir=/etc
-AC_DEFINE_UNQUOTED(PATH_MASTER_RC, "/etc/nail.rc")
+eval sysconfdir="$sysconfdir"
+AC_DEFINE_UNQUOTED(PATH_MASTER_RC, "${sysconfdir}/nail.rc")
dnl Checks for libraries.
if test "x$enable_efence" = xyes
@@ -165,7 +164,7 @@
AC_CHECK_FUNCS(mktime strtol tempnam getopt, ,
echo "A required function was not found" >&2
exit 1)
-AC_CHECK_FUNCS(gethostname mkstemp select strcasecmp snprintf uname)
+AC_CHECK_FUNCS(gethostname mkstemp select strcasecmp strcasestr snprintf uname)
AC_CHECK_FUNCS(nl_langinfo)
AC_FUNC_SELECT_ARGTYPES
AC_CHECK_FUNC(gethostent, AC_DEFINE(HAVE_SOCKETS),

View File

@ -6,8 +6,7 @@
#
PORTNAME= nail
PORTVERSION= 9.29
PORTREVISION= 1
PORTVERSION= 9.30
CATEGORIES= mail
MASTER_SITES= http://omnibus.ruf.uni-freiburg.de/~gritter/archive/nail/
@ -15,13 +14,11 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rcfile="${PREFIX}/etc"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv"
MAN1= nail.1
post-patch:
@cd ${WRKSRC} && ${TOUCH} Makefile.in aclocal.m4 stamp-h.in
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (nail-9.29.tar.gz) = 2d60eff6c89ba1070ad809be3af1edcf
MD5 (nail-9.30.tar.gz) = b5e233f61b6fa9a8abf4d30b93b2bd71

View File

@ -1,30 +0,0 @@
$FreeBSD$
--- mime.c.orig Mon Nov 19 17:37:47 2001
+++ mime.c Tue Jan 29 01:17:38 2002
@@ -183,7 +183,7 @@
if ((sz = xmbstowcs(w, t, LINESIZE)) == (size_t)-1)
return 0;
for (p = w, i = 0; *p && i < sz; p++, i++) {
- if (!iswprint(*p) && *p != '\n' && *p != '\r'
+ if (!isprint(*p) && *p != '\n' && *p != '\r'
&& *p != '\b' && *p != '\t')
*p = '?';
}
@@ -319,6 +319,7 @@
return p;
}
+#ifndef HAVE_STRCASESTR
/*
* glibc 2.1 provides such a function, but others ...
*/
@@ -346,6 +347,7 @@
}
return p;
}
+#endif
#ifndef HAVE_STRCASECMP
/* One of the things I really HATE on some SysVs is that they still

View File

@ -1,15 +0,0 @@
$FreeBSD$
--- config.h.in.orig Tue Jan 29 01:14:50 2002
+++ config.h.in Tue Jan 29 01:15:46 2002
@@ -75,6 +75,9 @@
/* Define if you have the strcasecmp function. */
#undef HAVE_STRCASECMP
+/* Define if you have the strcasestr function. */
+#undef HAVE_STRCASESTR
+
/* Define if you have the strtol function. */
#undef HAVE_STRTOL

View File

@ -1,26 +0,0 @@
$FreeBSD$
--- configure.in.orig Tue Jan 29 01:13:35 2002
+++ configure.in Tue Jan 29 01:15:12 2002
@@ -130,9 +130,8 @@
dnl Formulate proper paths based on prefix
test "$prefix" = NONE && prefix=/usr/local
dnl We need these seperate to use AC_DEFINED_UNQUOTED
-test "$libdir" = '${exec_prefix}/lib' && libdir=${prefix}/lib
-test "$sysconfdir" = '/etc' && sysconfdir=/etc
-AC_DEFINE_UNQUOTED(PATH_MASTER_RC, "/etc/nail.rc")
+eval sysconfdir="$sysconfdir"
+AC_DEFINE_UNQUOTED(PATH_MASTER_RC, "${sysconfdir}/nail.rc")
dnl Checks for libraries.
if test "x$enable_efence" = xyes
@@ -165,7 +164,7 @@
AC_CHECK_FUNCS(mktime strtol tempnam getopt, ,
echo "A required function was not found" >&2
exit 1)
-AC_CHECK_FUNCS(gethostname mkstemp select strcasecmp snprintf uname)
+AC_CHECK_FUNCS(gethostname mkstemp select strcasecmp strcasestr snprintf uname)
AC_CHECK_FUNCS(nl_langinfo)
AC_FUNC_SELECT_ARGTYPES
AC_CHECK_FUNC(gethostent, AC_DEFINE(HAVE_SOCKETS),