Update to 2.1.1.

This commit is contained in:
Maxim Sobolev 2002-06-21 16:42:45 +00:00
parent 520de6d8f3
commit a836ded155
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61687
7 changed files with 38 additions and 55 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= freetype2
PORTVERSION= 2.1.0
PORTREVISION= 1
PORTVERSION= 2.1.1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%,freetype,} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/%SUBDIR%/ \

View File

@ -1 +1 @@
MD5 (freetype-2.1.0.tar.bz2) = 27741388b19784be65b963a98c961bc5
MD5 (freetype-2.1.1.tar.bz2) = 31e28bb0ebf008e5ac63540c79b2b687

View File

@ -1,11 +1,18 @@
--- builds/unix/detect.mk.orig Sun Mar 4 17:10:36 2001
+++ builds/unix/detect.mk Sun Apr 8 01:13:41 2001
@@ -71,7 +71,7 @@
setup: std_setup
unix-def.mk: $(TOP)/builds/unix/unix-def.in
- cd builds/unix; ./configure $(CFG)
+# cd builds/unix; ./configure $(CFG)
$FreeBSD$
--- builds/unix/detect.mk.orig Sun May 5 13:57:06 2002
+++ builds/unix/detect.mk Fri Jun 21 15:47:35 2002
@@ -76,10 +76,10 @@
ifneq ($(have_mk),)
# we are building FT2 not in the src tree
unix-def.mk: $(TOP)/builds/unix/unix-def.in
- $(TOP)/builds/unix/configure $(CFG)
+# $(TOP)/builds/unix/configure $(CFG)
else
unix-def.mk: $(TOP)/builds/unix/unix-def.in
- cd builds/unix; ./configure $(CFG)
+# cd builds/unix; ./configure $(CFG)
endif
endif # test PLATFORM unix

View File

@ -1,18 +1,9 @@
$FreeBSD$
--- builds/unix/configure.orig Fri Mar 29 09:43:03 2002
+++ builds/unix/configure Thu May 30 11:13:41 2002
@@ -1131,7 +1131,7 @@
ac_config_headers="$ac_config_headers ftconfig.h:ftconfig.in"
-version_info='8:0:2'
+version_info='9:0:2'
ft_version=`echo $version_info | tr : .`
@@ -7732,6 +7732,7 @@
--- builds/unix/configure.orig Mon Apr 22 19:50:27 2002
+++ builds/unix/configure Fri Jun 21 15:48:06 2002
@@ -8654,6 +8654,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"

View File

@ -1,5 +1,8 @@
--- include/freetype/config/ftoption.h.orig Mon Apr 15 13:49:45 2002
+++ include/freetype/config/ftoption.h Fri May 31 15:12:09 2002
$FreeBSD$
--- include/freetype/config/ftoption.h.orig Sat Jun 8 04:05:56 2002
+++ include/freetype/config/ftoption.h Fri Jun 21 15:49:27 2002
@@ -82,7 +82,7 @@
/* */
/* Define this if you want generic cmap support. */
@ -13,8 +16,8 @@
/* By undefining this, you will only compile the code necessary to load */
/* TrueType glyphs without hinting. */
/* */
-#undef TT_CONFIG_OPTION_BYTECODE_INTERPRETER
+#define TT_CONFIG_OPTION_BYTECODE_INTERPRETER
-#undef TT_CONFIG_OPTION_BYTECODE_INTERPRETER
+#define TT_CONFIG_OPTION_BYTECODE_INTERPRETER
/*************************************************************************/

View File

@ -1,25 +0,0 @@
--- src/pcf/pcfdriver.c.orig Fri May 31 15:31:44 2002
+++ src/pcf/pcfdriver.c Fri May 31 15:16:29 2002
@@ -345,8 +345,8 @@
#else /* !FT_CONFIG_OPTION_USE_CMAPS */
/* XXX: charmaps. For now, report unicode for Unicode and Latin 1 */
- root->charmaps = &face->charmap_handle;
- root->num_charmaps = 1;
+ face->root.charmaps = &face->charmap_handle;
+ face->root.num_charmaps = 1;
face->charmap.encoding = ft_encoding_none;
face->charmap.platform_id = 0;
@@ -359,9 +359,9 @@
face->charmap.encoding_id = 1;
}
- face->charmap.face = root;
+ face->charmap.face = &face->root;
face->charmap_handle = &face->charmap;
- root->charmap = face->charmap_handle;
+ face->root.charmap = face->charmap_handle;
#endif /* !FT_CONFIG_OPTION_USE_CMAPS */

View File

@ -13,6 +13,7 @@ include/freetype2/freetype/config/ftoption.h
include/freetype2/freetype/config/ftstdlib.h
include/freetype2/freetype/freetype.h
include/freetype2/freetype/ftbbox.h
include/freetype2/freetype/ftbdf.h
include/freetype2/freetype/ftcache.h
include/freetype2/freetype/ftchapters.h
include/freetype2/freetype/fterrdef.h
@ -29,29 +30,36 @@ include/freetype2/freetype/ftrender.h
include/freetype2/freetype/ftsizes.h
include/freetype2/freetype/ftsnames.h
include/freetype2/freetype/ftsynth.h
include/freetype2/freetype/ftsysio.h
include/freetype2/freetype/ftsysmem.h
include/freetype2/freetype/ftsystem.h
include/freetype2/freetype/fttrigon.h
include/freetype2/freetype/fttypes.h
include/freetype2/freetype/ftxf86.h
include/freetype2/freetype/internal/autohint.h
include/freetype2/freetype/internal/bdftypes.h
include/freetype2/freetype/internal/cfftypes.h
include/freetype2/freetype/internal/fnttypes.h
include/freetype2/freetype/internal/ftcalc.h
include/freetype2/freetype/internal/ftcore.h
include/freetype2/freetype/internal/ftdebug.h
include/freetype2/freetype/internal/ftdriver.h
include/freetype2/freetype/internal/ftextend.h
include/freetype2/freetype/internal/ftexcept.h
include/freetype2/freetype/internal/ftgloadr.h
include/freetype2/freetype/internal/fthash.h
include/freetype2/freetype/internal/ftmemory.h
include/freetype2/freetype/internal/ftobject.h
include/freetype2/freetype/internal/ftobjs.h
include/freetype2/freetype/internal/ftstream.h
include/freetype2/freetype/internal/fttrace.h
include/freetype2/freetype/internal/internal.h
include/freetype2/freetype/internal/pcftypes.h
include/freetype2/freetype/internal/psaux.h
include/freetype2/freetype/internal/psglobal.h
include/freetype2/freetype/internal/pshints.h
include/freetype2/freetype/internal/psnames.h
include/freetype2/freetype/internal/sfnt.h
include/freetype2/freetype/internal/t1types.h
include/freetype2/freetype/internal/t42types.h
include/freetype2/freetype/internal/tttypes.h
include/freetype2/freetype/t1tables.h
include/freetype2/freetype/ttnameid.h