Upgrade to version 4.0 and allow the build of A4 and LETTER

packages.

PR:		5075
Submitted by:	Matthew Hunt <mph@pobox.com>
This commit is contained in:
Steve Price 1998-02-25 00:25:52 +00:00
parent 3d4a5438d3
commit a6d2662a76
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=9913
3 changed files with 46 additions and 12 deletions

View File

@ -1,20 +1,32 @@
# New ports collection makefile for: c2ps
# Version required: 3.0
# Version required: 4.0
# Date created: 19 March 1997
# Whom: Matthew Hunt <mph@pobox.com>
#
# $Id$
# $Id: Makefile,v 1.1.1.1 1997/03/24 19:36:55 obrien Exp $
#
DISTNAME= c2ps-3.0
DISTNAME= c2ps-4.0
PKGNAME= c2ps-${PAPERSIZE:S/A/a/:S/LETTER/letter/}-4.0
CATEGORIES= print
MASTER_SITES= http://www.geocities.com/SiliconValley/Park/2055/
DISTFILES= c2ps-30.tgz
# Also: http://www.cs.technion.ac.il/~c0928189/c2ps/c2ps-3.0.tar.Z
MASTER_SITES= http://www.cs.technion.ac.il/users/c2ps/
MAINTAINER= mph@pobox.com
MAN1= c2ps.1
MAKE_ENV= DEFAULT_PAPER_TYPE=${PAPERSIZE}
.if !defined(PAPERSIZE)
PAPERSIZE=A4
.elif ${PAPERSIZE} != A4 && ${PAPERSIZE} != LETTER
PAPERSIZE_INVALID=yes
.endif
pre-fetch:
.if defined(PAPERSIZE_INVALID)
@${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
@${ECHO} "Possible values are: A4 (default), and LETTER."
@${FALSE}
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (c2ps-30.tgz) = 27f07557444a02d56e88012e900a3bb8
MD5 (c2ps-4.0.tar.gz) = 195553258f2f18198f164ea8f66362dc

View File

@ -1,7 +1,7 @@
--- Makefile.orig Thu Jul 18 14:43:18 1996
+++ Makefile Wed Mar 19 13:19:33 1997
@@ -1,10 +1,7 @@
# Makefile for c2ps ver3.0
--- Makefile.orig Thu May 15 11:50:56 1997
+++ Makefile Thu Nov 20 22:06:51 1997
@@ -2,10 +2,7 @@
# Last modified: Sat Apr 19 1997
RM = rm -f
-CC = gcc
@ -11,3 +11,25 @@
BIN = $(PREFIX)/bin
MAN = $(PREFIX)/man/man1
@@ -20,8 +17,6 @@
FUNCTION_FONT = \"Bookman-LightItalic\"
COMMENT_DIMMING_DEGREE = 0.75
-DEFAULT_PAPER_TYPE = A4
-# possible values are A4 and LETTER
#___You don't need to change anything below__________________
@@ -39,10 +34,10 @@
install: bininstall maninstall
bininstall: c2ps
- install -m 755 c2ps $(BIN)
+ $(INSTALL_PROGRAM) c2ps $(BIN)
maninstall: c2ps.1
- install -m 644 c2ps.1 $(MAN)
+ $(INSTALL_MAN) c2ps.1 $(MAN)
compile: c2ps.c
$(CC) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c