o Update to 0.7.2

o Enable IPv6 support if available
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2002-01-20 19:01:01 +00:00
parent 2460227885
commit a0f2f87f35
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53396
6 changed files with 22 additions and 45 deletions

View File

@ -6,8 +6,8 @@
#
PORTNAME= silc
PORTVERSION= 0.7
CATEGORIES= devel net security
PORTVERSION= 0.7.2
CATEGORIES= devel ipv6 net security
MASTER_SITES= http://www.silcnet.org/download/toolkit/sources/ \
ftp://ftp.silcnet.org/silc/toolkit/sources/ \
http://www.planetmirror.com/pub/silcnet/toolkit/sources / \
@ -60,13 +60,7 @@ post-patch:
@${PERL} -pi -ne 's|doc includes|includes|;s| doc-install| |; \
s|^.*-mkdir -p \$$\(docdir\).*$$||' ${WRKSRC}/Makefile.in
.endif
# ugly, ugly hack; for some reason (configure reason), this ports
# breaks if CONFIGURE_TARGET is given as an argument
do-configure:
@cd ${CONFIGURE_WRKSRC}; ${SETENV} ${CONFIGURE_ENV} \
./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS:S/${CONFIGURE_TARGET}//} \
--host=${CONFIGURE_TARGET}
@${PERL} -pi -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
pre-install:
@${RM} -Rf ${WRKSRC}/doc/examples/CVS
@ -77,4 +71,8 @@ pre-install:
WITHOUT_OPTIMIZED_ASM= yes
.endif
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (silc-toolkit-0.7.tar.bz2) = 4c8548e1297d0ae03416afbf3986d1dc
MD5 (silc-toolkit-0.7.2.tar.bz2) = bed13685ce7bb22714f72ebb7d9771d9

View File

@ -1,6 +1,6 @@
--- Makefile.in.orig Fri Dec 21 02:51:02 2001
+++ Makefile.in Fri Dec 21 02:53:28 2001
@@ -152,9 +152,9 @@
--- Makefile.in.orig Thu Jan 17 19:25:58 2002
+++ Makefile.in Sat Jan 19 21:16:03 2002
@@ -151,9 +151,9 @@
AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
@ -13,7 +13,7 @@
#
# INCLUDE defines
@@ -529,11 +529,8 @@
@@ -528,11 +528,8 @@
-rm -rf $(distdir)
install-dirs:
@ -25,7 +25,7 @@
generate-server-key:
-@if test '!' -f $(etcdir)/silcd.pub ; then \
@@ -546,7 +543,8 @@
@@ -545,7 +542,8 @@
doc-install:
$(INSTALL_DATA) $(srcdir)/doc/CodingStyle $(docdir)/
$(INSTALL_DATA) $(srcdir)/doc/FAQ $(docdir)/
@ -35,14 +35,14 @@
$(INSTALL_DATA) $(srcdir)/doc/*.txt $(docdir)/
$(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/
$(INSTALL_DATA) $(srcdir)/CHANGES $(docdir)/
@@ -566,8 +564,8 @@
@@ -571,8 +569,8 @@
$(etcdir)/silc.conf; \
fi
-@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs sim-install doc-install etc-install
-@SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs generate-server-key sim-install doc-install etc-install
+@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs sim-install doc-install
+@SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs sim-install doc-install
-@SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs generate-server-key sim-install doc-install examples-install etc-install
+@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs doc-install
+@SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs doc-install
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

View File

@ -1,11 +1,10 @@
--- configure.orig Fri Dec 21 02:53:47 2001
+++ configure Fri Dec 21 02:54:02 2001
@@ -12572,7 +12572,7 @@
--- configure.orig Sat Jan 19 21:06:08 2002
+++ configure Sat Jan 19 21:06:48 2002
@@ -12567,7 +12567,6 @@
fi
;;
*-freebsd2.2*)
- CFLAGS="$CFLAGS -D_THREAD_SAFE"
+ CFLAGS="$CFLAGS"
;;
*-sysv5uw7*) # UnixWare 7
if test "$GCC" != "yes"; then

View File

@ -1,5 +1,5 @@
--- irssi/Makefile.in.orig Fri Dec 21 02:55:17 2001
+++ irssi/Makefile.in Fri Dec 21 02:55:28 2001
--- irssi/Makefile.in.orig Sat Jan 19 21:07:04 2002
+++ irssi/Makefile.in Sat Jan 19 21:07:24 2002
@@ -486,7 +486,7 @@
info-am:

View File

@ -1,20 +0,0 @@
--- lib/Makefile.in.orig Fri Dec 21 02:55:51 2001
+++ lib/Makefile.in Fri Dec 21 02:56:04 2001
@@ -123,7 +123,6 @@
silcutil \
silcclient \
silcsftp \
- dotconf \
trq
@@ -141,8 +140,7 @@
silcske \
silcutil \
silcsftp \
- trq \
- dotconf
+ trq
# SILC Client Library dirs