Update to 9.21

PR:		32621
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-12-08 19:41:33 +00:00
parent 73a067cf6c
commit 8607a509cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51229
7 changed files with 55 additions and 17 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= netpbm
PORTVERSION= 9.20
PORTVERSION= 9.21
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}

View File

@ -1 +1 @@
MD5 (netpbm-9.20.tgz) = a815a1f0ae94d727cb6614698f3aff28
MD5 (netpbm-9.21.tgz) = 2fae8f82a3e1d624ade166c5607265a0

View File

@ -32,8 +32,11 @@ MAN1+= neotoppm.1
MAN1+= palmtopnm.1
MAN1+= pamchannel.1
MAN1+= pamcut.1
MAN1+= pamdeinterlace.1
MAN1+= pamfile.1
MAN1+= pamoil.1
MAN1+= pamstretch-gen.1
MAN1+= pamstretch.1
MAN1+= pamtopnm.1
MAN1+= pbmclean.1
MAN1+= pbmlife.1
@ -112,8 +115,6 @@ MAN1+= pnmgamma.1
MAN1+= pnmhisteq.1
MAN1+= pnmhistmap.1
MAN1+= pnmindex.1
MAN1+= pnminterp-gen.1
MAN1+= pnminterp.1
MAN1+= pnminvert.1
MAN1+= pnmmargin.1
MAN1+= pnmmontage.1
@ -121,6 +122,7 @@ MAN1+= pnmnlfilt.1
MAN1+= pnmpad.1
MAN1+= pnmpaste.1
MAN1+= pnmpsnr.1
MAN1+= pnmquant.1
MAN1+= pnmrotate.1
MAN1+= pnmscale.1
MAN1+= pnmscalefixed.1

View File

@ -1,5 +1,5 @@
--- pbm/Makefile.orig Fri Aug 17 13:40:04 2001
+++ pbm/Makefile Wed Sep 5 00:00:00 2001
--- pbm/Makefile.orig Fri Nov 16 02:33:04 2001
+++ pbm/Makefile Sat Dec 8 00:00:00 2001
@@ -52,6 +52,7 @@
# Library objects to be built and linked by Makefile.common:
@ -36,10 +36,10 @@
HEADERLINKS = pm_config.h version.h compile.h
@@ -109,6 +105,5 @@
.PHONY: clean
@@ -110,6 +106,5 @@
clean: clean.common
rm -f thinkjettopbm.c
rm -f compile.h
- $(MAKE) -C pbmtoppa clean
FORCE:

View File

@ -1,14 +1,22 @@
--- pnm/Makefile.orig Wed Sep 5 12:10:50 2001
+++ pnm/Makefile Thu Sep 6 00:00:00 2001
@@ -155,6 +155,7 @@
--- pnm/Makefile.orig Mon Nov 12 11:41:18 2001
+++ pnm/Makefile Sat Dec 8 00:00:00 2001
@@ -149,13 +149,14 @@
# MERGE_ALIASES is additional names to be linked to the merge binary which are
# alternate names for a program whose source is called something else.
# Every name here must be referenced in pnmmerge.c.
-MERGE_ALIASES = pnmnoraw gemtopbm
+MERGE_ALIASES =
OBJECTS = $(patsubst %, %.o, $(BINARIES)) exif.o
MERGE_OBJECTS = $(patsubst %,%.o2, $(MERGEBINARIES))
LIBOBJECTS = libpnm1.o libpnm2.o libpnm3.o libpnm4.o libpam.o
LIBOBJECTS = libpnm1.o libpnm2.o libpnm3.o libpnm4.o libpam.o libpammap.o
+SHLIBOBJECTS = $(patsubst %.o, %.lo, $(LIBOBJECTS))
MANUALS1 = $(BINARIES) $(SCRIPTS)
MANUALS3 = libpnm
@@ -172,7 +173,7 @@
@@ -173,7 +174,7 @@
$(MAKE) -C jbig all
$(MAKE) -C pnmtopalm all
PHONY: merge
@ -17,3 +25,15 @@
ifneq ($(BUILD_FIASCO), N)
$(MAKE) -C fiasco all
endif
@@ -261,11 +262,6 @@
.PHONY: install.man
install.man: install.man.common
-# The following are for programs that have been renamed
- rm $(INSTALLMANUALS1)/pnmnowraw.*
- rm $(INSTALLMANUALS1)/gemtopnm.*
- rm $(INSTALLMANUALS1)/pnminterp.*
- rm $(INSTALLMANUALS1)/ppmtojpeg.*
ifneq ($(BUILD_FIASCO), N)
$(MAKE) -C fiasco install.man
endif

View File

@ -0,0 +1,16 @@
--- pnm/pnmtopng.c.orig Sun Jul 22 12:32:22 2001
+++ pnm/pnmtopng.c Sat Dec 8 00:00:00 2001
@@ -1441,8 +1441,13 @@
fprintf(stderr,"pnmtopng version %s.\n", VERSION);
fprintf(stderr, " Compiled with libpng %s; using libpng %s.\n",
PNG_LIBPNG_VER_STRING, png_libpng_ver);
+#ifdef zlib_version
fprintf(stderr, " Compiled with zlib %s; using zlib %s.\n",
ZLIB_VERSION, zlib_version);
+#else
+ fprintf(stderr, " Compiled with zlib %s.\n",
+ ZLIB_VERSION);
+#endif
fprintf(stderr,
" Compiled with %d-bit netpbm support (PPM_OVERALLMAXVAL = %d).\n",
pm_maxvaltobits (PPM_OVERALLMAXVAL), PPM_OVERALLMAXVAL);

View File

@ -11,7 +11,6 @@ bin/fiascotopnm
bin/fitstopnm
bin/fstopgm
bin/g3topbm
bin/gemtopbm
bin/gemtopnm
bin/giftopnm
bin/gouldtoppm
@ -32,8 +31,11 @@ bin/neotoppm
bin/palmtopnm
bin/pamchannel
bin/pamcut
bin/pamdeinterlace
bin/pamfile
bin/pamoil
bin/pamstretch
bin/pamstretch-gen
bin/pamtopnm
bin/pbmclean
bin/pbmlife
@ -114,17 +116,15 @@ bin/pnmgamma
bin/pnmhisteq
bin/pnmhistmap
bin/pnmindex
bin/pnminterp
bin/pnminterp-gen
bin/pnminvert
bin/pnmmargin
bin/pnmmerge
bin/pnmmontage
bin/pnmnlfilt
bin/pnmnoraw
bin/pnmpad
bin/pnmpaste
bin/pnmpsnr
bin/pnmquant
bin/pnmrotate
bin/pnmscale
bin/pnmscalefixed