- Complete repomove of www/horde to www/horde-base

Repocopy by:	marcus
PR:		ports/109425, ports/109198
Submitted by:	Beech Rintoul <beech@alaskaparadise.com> (maintainer)
This commit is contained in:
Andrew Pantyukhin 2007-02-25 01:36:23 +00:00
parent 69a9bac802
commit 80f063dbf6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=185838
17 changed files with 10 additions and 2705 deletions

1
MOVED
View File

@ -2840,3 +2840,4 @@ www/drupal-pubcookie||2007-02-19|Has expired: No maintainer
lang/tcc||2007-02-19|Has expired: is unusable; tcc -run works, but little else
www/p5-HTML||2007-02-23|Has expired: project no longer exists
audio/speex-devel|audio/speex|2007-02-23|Merged into audio/speex
www/horde|www/horde-base|2007-02-24|Port renamed for consistency

View File

@ -186,7 +186,7 @@
SUBDIR += havp
SUBDIR += hiawatha
SUBDIR += hinventory-client
SUBDIR += horde
SUBDIR += horde-base
SUBDIR += horde-passwd
SUBDIR += hotjava
SUBDIR += htdump

View File

@ -1,14 +1,16 @@
# Ports collection makefile for: horde2
# Ports collection makefile for: horde3
# Date created: Sun Oct 07, 2001
# Whom: Thierry Thomas (<thierry@thomas.as>)
#
# $FreeBSD$
#
PORTNAME= horde
PORTNAME= base
PORTVERSION= 3.1.3
CATEGORIES= www
MASTER_SITES= HORDE
PKGNAMEPREFIX= horde-
DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
COMMENT= A common code-base used by Horde applications, written in PHP

View File

@ -1,377 +0,0 @@
# Ports collection makefile for: horde2
# Date created: Sun Oct 07, 2001
# Whom: Thierry Thomas (<thierry@thomas.as>)
#
# $FreeBSD$
#
PORTNAME= horde
PORTVERSION= 3.1.3
CATEGORIES= www
MASTER_SITES= HORDE
MAINTAINER= beech@alaskaparadise.com
COMMENT= A common code-base used by Horde applications, written in PHP
#----------------------------------------------------------------------------
# You may define these options:
#
# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree.
#
# - WITHOUT_MYSQL: this port is built with MySQL by default
# but you might choose any other database
# supported by PHP (e.g. WITH_POSTGRESQL / WITH_SQLITE).
#
# - WITHOUT_IMAP: this port uses IMAP as a default authentication
# backend; use this knob if for
# example you only need Chora.
#
# - WITHOUT_LDAP: if you do not need OpenLDAP.
#
# - WITHOUT_FTP: if you do not need the VFS FTP driver.
#
# - WITH_MCAL: for mcal authentication back-end (deprecated).
#
# - WITH_IMSP: use IMSP as a preferences backend.
#
# - WITHOUT_FILEINFO: use native code to perform MIME magic lookups.
#
# - WITHOUT_GD: don't perform manipulations on image data with gd.
#
# - WITHOUT_ZLIB: don't compress pages and don't handle zip or gz data.
#
# - WITH_MAGICK: use ImageMagick to perform these image manipulations.
#
# - WITHOUT_ICONV: remove support for UTF-8 character sets.
# - WITHOUT_MBSTRING:
#
# - WITHOUT_WV if your users never receive MS-Word docs;
#
# - WITHOUT_XL if your users never receive MS-Excel sheets
# (or .ppt presentations);
#
# - WITHOUT_GEOIP don't activate MaxMind GeoIP Hostname to Country lookup.
#
# - WITHOUT_SW don't use the weather.com block on the portal page.
#
# - WITHOUT_WEBCPP: don't highlight sources with webcpp.
#
# - WITH_SRCHIGH: highlight sources with source-highlight.
#
# - WITH_ENSCRIPT: highlight sources with enscript.
#
# - WITH_RPM: handle RPM packages.
#
# - WITH_DEB: handle Debian packages.
#
# - WITH_SUPHP: Install appropriately for use with the www/suphp port.
#
#----------------------------------------------------------------------------
RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
${PEARDIR}/Mail/RFC822.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
${PEARDIR}/File.php:${PORTSDIR}/sysutils/pear-File \
${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP
CONFLICTS= horde-2.*
NO_BUILD= yes
USE_APACHE= 1.3+
USE_GETTEXT= yes # Already implied by USE_PHP =gettext, to pet portlint
USE_PHP= ctype gettext session
SUB_FILES= pkg-message pkg-deinstall pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PKGINSTALL= ${WRKDIR}/pkg-install
PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
WANT_PHP_CGI= yes
HORDEADMUSR?= horde
SUB_LIST= WITH_SUPHP=yes
.else
WANT_PHP_WEB= yes
.endif
.if !defined(WITHOUT_FILEINFO)
USE_PHP+= fileinfo
.endif
.if !defined(WITHOUT_FTP)
USE_PHP+= ftp
.endif
.if !defined(WITHOUT_GD)
USE_PHP+= gd
.endif
.if !defined(WITHOUT_ICONV)
USE_PHP+= iconv
.endif
.if !defined(WITHOUT_IMAP)
USE_PHP+= imap
.endif
.if !defined(WITHOUT_LDAP)
USE_PHP+= ldap
.endif
.if !defined(WITHOUT_MBSTRING)
USE_PHP+= mbstring
.endif
.if !defined(NOCRYPT)
USE_PHP+= mcrypt
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
. if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
. endif
. if defined(WITH_POSTGRESQL) || defined(WITH_PGSQL)
USE_PHP+= pgsql
. endif
. if defined(WITH_SQLITE)
USE_PHP+= sqlite
. endif
.endif
.if !defined(WITHOUT_ZLIB)
USE_PHP+= zlib
.endif
.if defined(WITH_MAGICK)
RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
.if defined(WITH_IMSP)
RUN_DEPENDS+= imspd:${PORTSDIR}/databases/cyrus-imspd
.endif
.if !defined(WITHOUT_X11)
. if !defined(WITHOUT_WV)
RUN_DEPENDS+= ${LOCALBASE}/bin/wvHtml:${PORTSDIR}/textproc/wv
. endif
. if !defined(WITHOUT_XL)
RUN_DEPENDS+= ${LOCALBASE}/bin/xlhtml:${PORTSDIR}/textproc/xlhtml
. endif
.endif
.if !defined(WITHOUT_WEBCPP)
RUN_DEPENDS+= webcpp:${PORTSDIR}/textproc/webcpp
.endif
.if exists(${LOCALBASE}/bin/source-highlight)
WITH_SRCHIGH= yes
.endif
.if defined(WITH_SRCHIGH)
RUN_DEPENDS+= source-highlight:${PORTSDIR}/textproc/source-highlight
.endif
.if exists(${LOCALBASE}/bin/enscript)
WITH_ENSCRIPT= yes
.endif
.if defined(WITH_ENSCRIPT)
. if defined(A4)
RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-a4
. elif defined(DJ)
RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-letterdj
. else
RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-letter
. endif
.endif
.if exists(${LOCALBASE}/bin/rpm)
WITH_RPM= yes
.endif
.if defined(WITH_RPM)
RUN_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm4
.endif
.if exists(${LOCALBASE}/bin/dpkg)
WITH_DEB= yes
.endif
.if defined(WITH_DEB)
RUN_DEPENDS+= dpkg:${PORTSDIR}/archivers/dpkg
.endif
.if !defined(WITHOUT_SW)
RUN_DEPENDS+= ${PEARDIR}/Services/Weather.php:${PORTSDIR}/misc/pear-Services_Weather
.endif
.if !defined(WITHOUT_GEOIP)
RUN_DEPENDS+= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
.endif
REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CODING_STANDARDS \
docs/CONTRIBUTING docs/CREDITS docs/HACKING docs/INSTALL \
docs/PERFORMANCE docs/RELEASE_NOTES docs/SECURITY docs/TODO \
docs/TRANSLATIONS docs/UPGRADING
CONFFILE= conf.php hooks.php mime_drivers.php motd.php nls.php prefs.php registry.php
SUB_DIRS= admin config js lib locale po scripts services templates themes util
LHORDEDIR?= www/horde
LHORDESBIN?= sbin
PLIST_SUB= HORDEDIR=${LHORDEDIR} HORDESBIN=${LHORDESBIN} \
HORDE_INC=${LHORDE_INC}
SUB_LIST+= HORDEDIR=${HORDEDIR} APACHE_CONF=${APACHE_CONF} \
HORDESBIN=${HORDESBIN} HORDEADMUSR=${HORDEADMUSR} HORDEGRP=${WWWGRP}
HORDEDIR= ${PREFIX}/${LHORDEDIR}
HORDESBIN= ${PREFIX}/${LHORDESBIN}
CONFDIR= ${HORDEDIR}/config
APACHE_CONF= ${APACHE_CNFDIR}/httpd.conf
PEARDIR?= ${LOCALBASE}/share/pear
LOG_FILE?= /var/log/horde.log
PATCHES2RM= po/translation.php config/conf.xml scripts/sql/README \
config/mime_drivers.php.dist config/registry.php.dist
SEDIN2RM= lib/Horde/Auth/mcal.php config/conf.xml docs/INSTALL \
config/mime_drivers.php.dist
.include <bsd.port.pre.mk>
.if ${PHP_VER} == 5
USE_PHP+= dom
.else
USE_PHP+= domxml
. if defined(WITH_MCAL)
USE_PHP+= mcal
. endif
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"
.if ${APACHE_VERSION} >= 20
APACHE_CNFDIR= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}
HORDE_INC= ${APACHE_CNFDIR}/Includes
LHORDE_INC= ${HORDE_INC:S|^${LOCALBASE}/||}
PLIST_SUB+= RMDIRINC="@comment "
.else
APACHE_CNFDIR= ${LOCALBASE}/etc/apache
HORDE_INC= ${PREFIX}/etc/horde
LHORDE_INC= ${HORDE_INC:S|^${PREFIX}/||}
PLIST_SUB+= RMDIRINC=""
.endif
pre-configure:
@${RM} ${PATCHES2RM:S|^|${WRKSRC}/|:S|$|.orig|}
@${SED} -e "s:/home/httpd/html/horde:${HORDEDIR}:" \
-e "s:php_value auto_prepend_file:# php_value auto_prepend_file:" \
-e "s:/home/httpd/phplib:${PEARDIR}:" \
${FILESDIR}/httpd.conf.horde > ${WRKDIR}/httpd-horde.conf
.if ${PHP_VER} == 5
@${REINPLACE_CMD} -e "s:mod_php4.c:mod_php5.c:" ${WRKDIR}/httpd-horde.conf
.endif
.if ${APACHE_VERSION} >= 22
@${REINPLACE_CMD} -e "s:IfModule mod_\([^ ]*\)\.c:IfModule \1_module:" \
${WRKDIR}/httpd-horde.conf
.endif
@${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" ${WRKSRC}/config/mime_drivers.php.dist
.if !defined(WITHOUT_X11)
. if !defined(WITHOUT_WV)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFWV::" ${WRKSRC}/config/mime_drivers.php.dist
. endif
. if !defined(WITHOUT_XL)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFXL::" ${WRKSRC}/config/mime_drivers.php.dist
. endif
.endif
.if !defined(WITHOUT_WEBCPP)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFWCPP::" ${WRKSRC}/config/mime_drivers.php.dist
.endif
.if defined(WITH_SRCHIGH)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFSRCHIGH::" ${WRKSRC}/config/mime_drivers.php.dist
.endif
.if defined(WITH_ENSCRIPT)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFES::" ${WRKSRC}/config/mime_drivers.php.dist
.endif
.if defined(WITH_RPM)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFRPM::" ${WRKSRC}/config/mime_drivers.php.dist
.endif
.if defined(WITH_DEB)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFDEB::" ${WRKSRC}/config/mime_drivers.php.dist
.endif
.if !defined(WITHOUT_GEOIP)
@${REINPLACE_CMD} -e "s:GeoIP lookup will not be performed.\"/>:GeoIP lookup will not be performed.\">${LOCALBASE}/share/GeoIP/GeoIP.dat</configstring>:" \
${WRKSRC}/config/conf.xml
.endif
@${REINPLACE_CMD} -e "s:/tmp/horde.log:${LOG_FILE}:" ${WRKSRC}/config/conf.xml
@${REINPLACE_CMD} -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:g" \
${WRKSRC}/lib/Horde/Auth/mcal.php
@${REINPLACE_CMD} -e "s:/usr/local/apache/htdocs:${PREFIX}/www:g" \
${WRKSRC}/docs/INSTALL
@${RM} ${SEDIN2RM:S|^|${WRKSRC}/|:S|$|.beforeHorde|}
@(cd ${WRKSRC}/scripts && \
${FIND} . -name "*.php" -exec \
${REINPLACE_CMD} -e "s:/usr/local/bin/php: ${LOCALBASE}/bin/php:;s:/usr/bin/php: ${LOCALBASE}/bin/php:" {} \; && \
${FIND} . -name "*.beforeHorde" -delete)
pre-install:
.if !defined(WITHOUT_SUPPORTED_DB) && exists(${LOCALBASE}/bin/php)
@if ! php -m 2>&1 | ${GREP} -q -e "mysql" ; then \
if ! php -m 2>&1 | ${GREP} -q -e "pgsql" ; then \
if ! php -m 2>&1 | ${GREP} -q -e "sybase" ; then \
if ! php -m 2>&1 | ${GREP} -q -e "SQLite" ; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with a database support." ; \
${ECHO_MSG} "MySQL, PostgreSQL, SQLite and Sybase (CTLIB or DBLIB)" ; \
${ECHO_MSG} "can be used with PHP AND Horde." ; \
${ECHO_MSG} "" ; \
${ECHO_MSG} "(If everything will run on this machine, do not" ; \
${ECHO_MSG} " forget to install the database server-side!)" ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi ; \
fi ; \
fi ; \
fi
.endif
.if defined(WITH_SUPHP)
${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
.endif
# Copy RCSID tag from conf.xml into conf.php to stop Horde complaining
@if ! ${GREP} -q -e "$$Horde.*conf\.xml" ${WRKSRC}/config/conf.php.dist; then \
${GREP} -h "$$Horde.*conf\.xml" ${WRKSRC} ${WRKSRC}/config/conf.xml \
| ${SED} -e 's#^ *<!--#//#' -e 's# *--> *$$##g' \
>> ${WRKSRC}/config/conf.php.dist; \
fi
do-install:
@${MKDIR} ${HORDEDIR}
.for REP in ${SUB_DIRS}
@${CP} -Rp ${WRKSRC}/${REP} ${HORDEDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
.if ${APACHE_VERSION} >= 20
${INSTALL_DATA} ${WRKDIR}/httpd-horde.conf ${HORDE_INC}
.else
@${MKDIR} ${HORDE_INC}
@${INSTALL_DATA} ${WRKDIR}/httpd-horde.conf ${HORDE_INC}
. if !defined(PACKAGE_BUILDING)
@(if [ -f ${APACHE_CONF} ] ; then \
${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
fi)
. endif
.endif
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${HORDEDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${TOUCH} ${LOG_FILE}
@${CHOWN} ${WWWOWN}:${WWWGRP} ${LOG_FILE}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
post-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (horde-3.1.3.tar.gz) = fbc56c608ac81474b846b1b4b7bb5ee7
SHA256 (horde-3.1.3.tar.gz) = c9e7d946f3da447444e0f39ed59e4119d1852ff16d1218bc19450f0cc1568aa6
SIZE (horde-3.1.3.tar.gz) = 5232958

View File

@ -1,57 +0,0 @@
# This is included in Apache's httpd.conf for Horde
<Directory /home/httpd/html/horde>
Options Indexes FollowSymLinks
AllowOverride None
order allow,deny
allow from all
<IfModule mod_php4.c>
php_value include_path '/home/httpd/phplib:.'
php_flag register_globals On
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_value memory_limit 16M
</IfModule>
</Directory>
<IfModule mod_alias.c>
Alias /horde/ "/home/httpd/html/horde/"
</IfModule>
#
# For security, don't serve pages from the Horde configuration and library
# directories.
#
#<Directory "/home/httpd/html/horde/admin">
# Order deny,allow
# Deny from all
#</Directory>
<Directory "/home/httpd/html/horde/config">
Order deny,allow
Deny from all
</Directory>
<Directory "/home/httpd/html/horde/lib">
Order deny,allow
Deny from all
</Directory>
<Directory "/home/httpd/html/horde/locale">
Order deny,allow
Deny from all
</Directory>
<Directory "/home/httpd/html/horde/po">
Order deny,allow
Deny from all
</Directory>
<Directory "/home/httpd/html/horde/scripts">
Order deny,allow
Deny from all
</Directory>
<Directory "/home/httpd/html/horde/templates">
Order deny,allow
Deny from all
</Directory>
<Directory "/home/httpd/html/horde/util">
Order deny,allow
Deny from all
</Directory>
# End of Horde configuration ================

View File

@ -1,20 +0,0 @@
--- config/conf.xml.orig Fri Nov 5 10:54:09 2004
+++ config/conf.xml Sat Nov 27 23:20:31 2004
@@ -276,7 +276,7 @@
<case name="login" desc="Login (su) authentication">
<configsection name="params">
- <configstring name="location" desc="Location of the su binary">/bin/su</configstring>
+ <configstring name="location" desc="Location of the su binary">/usr/bin/su</configstring>
</configsection>
</case>
@@ -932,7 +932,7 @@
<configsection name="params">
<configstring name="sendmail_path" required="false" desc="The location
of the sendmail binary on the filesystem
- [/usr/sbin/sendmail]">/usr/lib/sendmail</configstring>
+ [/usr/sbin/sendmail]">/usr/sbin/sendmail</configstring>
<configstring name="sendmail_args" required="false" desc="Any extra
parameters to pass to the sendmail or sendmail wrapper
binary">-oi</configstring>

View File

@ -1,257 +0,0 @@
--- config/mime_drivers.php.dist.orig Thu Apr 6 22:32:14 2006
+++ config/mime_drivers.php.dist Thu Jul 20 22:10:57 2006
@@ -37,14 +37,21 @@
* zip Zip files
*/
$mime_drivers_map['horde']['registered'] = array(
- 'css', 'enriched', 'html', 'images', 'ooo', 'pdf', 'php', 'plain', 'rar',
- 'report', 'rfc822', 'richtext', 'security', 'simple', 'tgz', 'tnef',
- 'vcard', 'zip',
- // The following mime drivers require external applications to be
- // installed.
- // 'deb', 'enscript', 'msword', 'msexcel', 'mspowerpoint', 'rpm',
- // 'srchighlite', 'webcpp'
-);
+ 'css'
+//UNCOMMENTIFDEB , 'deb'
+ , 'enriched'
+//UNCOMMENTIFES , 'enscript'
+ , 'html', 'images'
+//UNCOMMENTIFWV , 'msword'
+//UNCOMMENTIFXL , 'msexcel', 'mspowerpoint'
+ , 'ooo', 'pdf', 'php', 'plain', 'rar', 'report',
+ 'rfc822', 'richtext'
+//UNCOMMENTIFRPM , 'rpm'
+ , 'security', 'simple'
+//UNCOMMENTIFSRCHIGH , 'srchighlite'
+ , 'tgz', 'tnef', 'vcard'
+//UNCOMMENTIFWCPP , 'webcpp'
+ , 'zip');
/**
@@ -161,66 +172,66 @@
* Web C Plus Plus driver settings
* http://webcpp.sourceforge.net/
*/
-$mime_drivers['horde']['webcpp']['location'] = '/usr/bin/webcpp';
-$mime_drivers['horde']['webcpp']['inline'] = true;
-$mime_drivers['horde']['webcpp']['handles'] = array(
- 'text/xml', 'text/sgml', 'application/xml',
- 'application/x-sh', 'application/x-javascript', 'application/x-tcl',
- 'x-extension/asm', 'application/x-asp', 'x-extension/bas',
- 'x-extension/cs', 'text/x-csrc', 'x-extension/rc',
- 'text/x-c++src', 'text/x-c++src', 'text/x-c++src',
- 'text/x-chdr', 'x-extension/bat', 'text/x-fortran',
- 'x-extension/f77', 'x-extension/f90', 'x-extension/for',
- 'x-extension/ftn', 'text/x-java', 'application/x-javascript',
- 'text/sgml', 'text/xml', 'text/x-pascal',
- 'application/x-cgi', 'application/x-perl', 'application/x-python',
- 'text/x-sql', 'text/x-tcl',
- 'application/x-shellscript', 'x-extension/vhd', 'x-extension/vhdl');
-$mime_drivers['horde']['webcpp']['icons'] = array(
- 'default' => 'text.png',
- 'text/xml' => 'xml.png',
- 'text/x-csrc' => 'source-c.png',
- 'text/x-chdr' => 'source-h.png',
- 'text/x-java' => 'source-java.png',
- 'application/x-javascript' => 'script-js.png');
+//UNCOMMENTIFWCPP$mime_drivers['horde']['webcpp']['location'] = '%%LOCALBASE%%/bin/webcpp';
+//UNCOMMENTIFWCPP$mime_drivers['horde']['webcpp']['inline'] = true;
+//UNCOMMENTIFWCPP$mime_drivers['horde']['webcpp']['handles'] = array(
+//UNCOMMENTIFWCPP 'text/xml', 'text/sgml', 'application/xml',
+//UNCOMMENTIFWCPP 'application/x-sh', 'application/x-javascript', 'application/x-tcl',
+//UNCOMMENTIFWCPP 'x-extension/asm', 'application/x-asp', 'x-extension/bas',
+//UNCOMMENTIFWCPP 'x-extension/cs', 'text/x-csrc', 'x-extension/rc',
+//UNCOMMENTIFWCPP 'text/x-c++src', 'text/x-c++src', 'text/x-c++src',
+//UNCOMMENTIFWCPP 'text/x-chdr', 'x-extension/bat', 'text/x-fortran',
+//UNCOMMENTIFWCPP 'x-extension/f77', 'x-extension/f90', 'x-extension/for',
+//UNCOMMENTIFWCPP 'x-extension/ftn', 'text/x-java', 'application/x-javascript',
+//UNCOMMENTIFWCPP 'text/sgml', 'text/xml', 'text/x-pascal',
+//UNCOMMENTIFWCPP 'application/x-cgi', 'application/x-perl', 'application/x-python',
+//UNCOMMENTIFWCPP 'text/x-sql', 'text/x-tcl',
+//UNCOMMENTIFWCPP 'application/x-shellscript', 'x-extension/vhd', 'x-extension/vhdl');
+//UNCOMMENTIFWCPP$mime_drivers['horde']['webcpp']['icons'] = array(
+//UNCOMMENTIFWCPP 'default' => 'text.png',
+//UNCOMMENTIFWCPP 'text/xml' => 'xml.png',
+//UNCOMMENTIFWCPP 'text/x-csrc' => 'source-c.png',
+//UNCOMMENTIFWCPP 'text/x-chdr' => 'source-h.png',
+//UNCOMMENTIFWCPP 'text/x-java' => 'source-java.png',
+//UNCOMMENTIFWCPP 'application/x-javascript' => 'script-js.png');
/**
* Source-Highlight driver settings
* http://www.gnu.org/software/src-highlite/
*/
-$mime_drivers['horde']['srchighlite']['location'] = '/usr/bin/source-highlight';
-$mime_drivers['horde']['srchighlite']['inline'] = true;
-$mime_drivers['horde']['srchighlite']['handles'] = array(
- 'text/x-csrc', 'text/x-c++src', 'text/x-java',
- 'application/x-perl', 'application/x-python', 'text/x-c++src',
- 'text/cpp');
-$mime_drivers['horde']['srchighlite']['icons'] = array(
- 'default' => 'text.png',
- 'text/x-csrc' => 'source-c.png',
- 'text/x-c++src' => 'source-c.png',
- 'text/cpp' => 'source-c.png',
- 'text/x-java' => 'source-java.png');
+//UNCOMMENTIFSRCHIGH$mime_drivers['horde']['srchighlite']['location'] = '%%LOCALBASE%%/bin/source-highlight';
+//UNCOMMENTIFSRCHIGH$mime_drivers['horde']['srchighlite']['inline'] = true;
+//UNCOMMENTIFSRCHIGH$mime_drivers['horde']['srchighlite']['handles'] = array(
+//UNCOMMENTIFSRCHIGH 'text/x-csrc', 'text/x-c++src', 'text/x-java',
+//UNCOMMENTIFSRCHIGH 'application/x-perl', 'application/x-python', 'text/x-c++src',
+//UNCOMMENTIFSRCHIGH 'text/cpp');
+//UNCOMMENTIFSRCHIGH$mime_drivers['horde']['srchighlite']['icons'] = array(
+//UNCOMMENTIFSRCHIGH 'default' => 'text.png',
+//UNCOMMENTIFSRCHIGH 'text/x-csrc' => 'source-c.png',
+//UNCOMMENTIFSRCHIGH 'text/x-c++src' => 'source-c.png',
+//UNCOMMENTIFSRCHIGH 'text/cpp' => 'source-c.png',
+//UNCOMMENTIFSRCHIGH 'text/x-java' => 'source-java.png');
/**
* GNU Enscript driver settings
*/
-$mime_drivers['horde']['enscript']['location'] = '/usr/bin/enscript';
-$mime_drivers['horde']['enscript']['inline'] = true;
-$mime_drivers['horde']['enscript']['handles'] = array(
- 'application/x-cgi', 'application/x-shellscript', 'application/x-javascript',
- 'application/x-perl', 'application/xml', 'text/xml',
- 'text/diff', 'text/x-diff', 'text/x-patch', 'text/x-csrc',
- 'x-extension/cs', 'text/x-java', 'text/x-chdr', 'text/x-c++src',
- 'text/x-c++hdr', 'x-extension/vhd', 'x-extension/vhdl', 'text/x-sql',
- 'x-extension/vb', 'x-extension/vba', 'text/x-emacs-lisp', 'text/x-tex');
-$mime_drivers['horde']['enscript']['icons'] = array(
- 'default' => 'text.png',
- 'text/xml' => 'xml.png',
- 'application/xml' => 'xml.png',
- 'text/x-csrc' => 'source-c.png',
- 'text/x-chdr' => 'source-h.png',
- 'text/x-java' => 'source-java.png',
- 'application/x-javascript' => 'script-js.png');
+//UNCOMMENTIFES$mime_drivers['horde']['enscript']['location'] = '%%LOCALBASE%%/bin/enscript';
+//UNCOMMENTIFES$mime_drivers['horde']['enscript']['inline'] = true;
+//UNCOMMENTIFES$mime_drivers['horde']['enscript']['handles'] = array(
+//UNCOMMENTIFES 'application/x-cgi', 'application/x-shellscript', 'application/x-javascript',
+//UNCOMMENTIFES 'application/x-perl', 'application/xml', 'text/xml',
+//UNCOMMENTIFES 'text/diff', 'text/x-diff', 'text/x-patch', 'text/x-csrc',
+//UNCOMMENTIFES 'x-extension/cs', 'text/x-java', 'text/x-chdr', 'text/x-c++src',
+//UNCOMMENTIFES 'text/x-c++hdr', 'x-extension/vhd', 'x-extension/vhdl', 'text/x-sql',
+//UNCOMMENTIFES 'x-extension/vb', 'x-extension/vba', 'text/x-emacs-lisp', 'text/x-tex');
+//UNCOMMENTIFES$mime_drivers['horde']['enscript']['icons'] = array(
+//UNCOMMENTIFES 'default' => 'text.png',
+//UNCOMMENTIFES 'text/xml' => 'xml.png',
+//UNCOMMENTIFES 'application/xml' => 'xml.png',
+//UNCOMMENTIFES 'text/x-csrc' => 'source-c.png',
+//UNCOMMENTIFES 'text/x-chdr' => 'source-h.png',
+//UNCOMMENTIFES 'text/x-java' => 'source-java.png',
+//UNCOMMENTIFES 'application/x-javascript' => 'script-js.png');
/**
@@ -272,15 +283,15 @@
* The 'location' entry should point to the 'wvHtml' program, NOT the
* 'wvWare' program.
*/
-$mime_drivers['horde']['msword']['location'] = '/usr/bin/wvHtml';
-$mime_drivers['horde']['msword']['inline'] = false;
-$mime_drivers['horde']['msword']['handles'] = array(
- 'application/vnd.ms-word',
- 'application/msword',
-);
-$mime_drivers['horde']['msword']['icons'] = array(
- 'default' => 'msword.png',
-);
+//UNCOMMENTIFWV$mime_drivers['horde']['msword']['location'] = '%%LOCALBASE%%/bin/wvHtml';
+//UNCOMMENTIFWV$mime_drivers['horde']['msword']['inline'] = false;
+//UNCOMMENTIFWV$mime_drivers['horde']['msword']['handles'] = array(
+//UNCOMMENTIFWV 'application/vnd.ms-word',
+//UNCOMMENTIFWV 'application/msword',
+//UNCOMMENTIFWV);
+//UNCOMMENTIFWV$mime_drivers['horde']['msword']['icons'] = array(
+//UNCOMMENTIFWV 'default' => 'msword.png',
+//UNCOMMENTIFWV);
/**
@@ -288,14 +299,14 @@
* This driver requires xlhtml to be installed.
* xlhtml homepage: http://chicago.sourceforge.net/xlhtml/
*/
-$mime_drivers['horde']['msexcel']['location'] = '/usr/local/bin/xlhtml';
-$mime_drivers['horde']['msexcel']['inline'] = false;
-$mime_drivers['horde']['msexcel']['handles'] = array(
- 'application/vnd.ms-excel',
- 'application/msexcel',
- 'application/x-msexcel');
-$mime_drivers['horde']['msexcel']['icons'] = array(
- 'default' => 'msexcel.png');
+//UNCOMMENTIFXL$mime_drivers['horde']['msexcel']['location'] = '%%LOCALBASE%%/bin/xlhtml';
+//UNCOMMENTIFXL$mime_drivers['horde']['msexcel']['inline'] = false;
+//UNCOMMENTIFXL$mime_drivers['horde']['msexcel']['handles'] = array(
+//UNCOMMENTIFXL 'application/vnd.ms-excel',
+//UNCOMMENTIFXL 'application/msexcel',
+//UNCOMMENTIFXL 'application/x-msexcel');
+//UNCOMMENTIFXL$mime_drivers['horde']['msexcel']['icons'] = array(
+//UNCOMMENTIFXL 'default' => 'msexcel.png');
/**
@@ -303,13 +314,13 @@
* This driver requires ppthtml, included with xlhtml, to be installed.
* xlhtml homepage: http://chicago.sourceforge.net/xlhtml/
*/
-$mime_drivers['horde']['mspowerpoint']['location'] = '/usr/local/bin/ppthtml';
-$mime_drivers['horde']['mspowerpoint']['inline'] = false;
-$mime_drivers['horde']['mspowerpoint']['handles'] = array(
- 'application/vnd.ms-powerpoint',
- 'application/mspowerpoint');
-$mime_drivers['horde']['mspowerpoint']['icons'] = array(
- 'default' => 'mspowerpoint.png');
+//UNCOMMENTIFXL$mime_drivers['horde']['mspowerpoint']['location'] = '%%LOCALBASE%%/bin/ppthtml';
+//UNCOMMENTIFXL$mime_drivers['horde']['mspowerpoint']['inline'] = false;
+//UNCOMMENTIFXL$mime_drivers['horde']['mspowerpoint']['handles'] = array(
+//UNCOMMENTIFXL 'application/vnd.ms-powerpoint',
+//UNCOMMENTIFXL 'application/mspowerpoint');
+//UNCOMMENTIFXL$mime_drivers['horde']['mspowerpoint']['icons'] = array(
+//UNCOMMENTIFXL 'default' => 'mspowerpoint.png');
/**
@@ -325,24 +336,24 @@
/**
* RPM driver settings
*/
-$mime_drivers['horde']['rpm']['location'] = '/usr/bin/rpm';
-$mime_drivers['horde']['rpm']['inline'] = false;
-$mime_drivers['horde']['rpm']['handles'] = array(
- 'application/x-rpm');
-$mime_drivers['horde']['rpm']['icons'] = array(
- 'default' => 'rpm.png');
+//UNCOMMENTIFRPM$mime_drivers['horde']['rpm']['location'] = '%%LOCALBASE%%/bin/rpm';
+//UNCOMMENTIFRPM$mime_drivers['horde']['rpm']['inline'] = false;
+//UNCOMMENTIFRPM$mime_drivers['horde']['rpm']['handles'] = array(
+//UNCOMMENTIFRPM 'application/x-rpm');
+//UNCOMMENTIFRPM$mime_drivers['horde']['rpm']['icons'] = array(
+//UNCOMMENTIFRPM 'default' => 'rpm.png');
/**
* Debian package driver settings
*/
-$mime_drivers['horde']['deb']['location'] = '/usr/bin/dpkg';
-$mime_drivers['horde']['deb']['inline'] = false;
-$mime_drivers['horde']['deb']['handles'] = array(
- 'application/x-deb',
- 'application/x-debian-package');
-$mime_drivers['horde']['deb']['icons'] = array(
- 'default' => 'deb.png');
+//UNCOMMENTIFDEB$mime_drivers['horde']['deb']['location'] = '%%LOCALBASE%%/bin/dpkg';
+//UNCOMMENTIFDEB$mime_drivers['horde']['deb']['inline'] = false;
+//UNCOMMENTIFDEB$mime_drivers['horde']['deb']['handles'] = array(
+//UNCOMMENTIFDEB 'application/x-deb',
+//UNCOMMENTIFDEB 'application/x-debian-package');
+//UNCOMMENTIFDEB$mime_drivers['horde']['deb']['icons'] = array(
+//UNCOMMENTIFDEB 'default' => 'deb.png');
/**

View File

@ -1,17 +0,0 @@
--- config/registry.php.dist.orig Wed Aug 3 16:27:41 2005
+++ config/registry.php.dist Wed Aug 17 22:33:03 2005
@@ -347,6 +347,14 @@
'provides' => 'files',
);
+// r1.255.2.9
+$this->applications['gollem-menu'] = array(
+ 'status' => 'block',
+ 'app' => 'gollem',
+ 'blockname' => 'tree_menu',
+ 'menu_parent' => 'gollem',
+);
+
$this->applications['passwd'] = array(
'fileroot' => dirname(__FILE__) . '/../passwd',
'webroot' => $this->applications['horde']['webroot'] . '/passwd',

View File

@ -1,8 +0,0 @@
--- po/translation.php.orig Tue Jan 21 16:05:36 2003
+++ po/translation.php Wed Jan 29 23:00:27 2003
@@ -1,4 +1,4 @@
-#!/usr/bin/php -q
+#!/usr/local/bin/php -q
<?php
/**
* Translation helper application for the Horde framework.

View File

@ -1,11 +0,0 @@
--- scripts/sql/README.orig Wed Apr 27 10:56:42 2005
+++ scripts/sql/README Tue Jul 12 21:30:49 2005
@@ -84,7 +84,7 @@
PostgreSQL
~~~~~~~~~~
- # su - postgres (or whatever your database runs as... usually postgres)
+ # su - pgsql (or whatever your database runs as... usually pgsql)
$ psql -d template1 -f create.pgsql.sql
This script will create a ``horde`` database and a ``horde`` user. You should

View File

@ -1,58 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
PATH=/usr/sbin:/usr/bin:/bin ; export PATH
handle_config() {
# Try to restore httpd.conf when deinstalling Horde
if [ -f %%APACHE_CONF%%.beforeHorde ] ; then
echo "Restoring httpd.conf..."
cp %%APACHE_CONF%% %%APACHE_CONF%%.deinstHorde
sed -i.tmp -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
%%APACHE_CONF%%
rm %%APACHE_CONF%%.tmp
fi
# Backup Horde config files, if needed.
if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%HORDEDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, delete
rm -f $cf
;;
1) # config file has been updated, leave it
;;
*) # not found?
;;
esac
done
fi
}
case $2 in
DEINSTALL)
handle_config
;;
POST-DEINSTALL)
if [ x%%HORDEADMUSR%% != x ]; then
cat <<EOMSG
The horde port has been deleted.
If you are not upgrading and don't intend to use
Horde any more then you may wish to delete
the %%HORDEADMUSR%% account, which can be done with
the following command:
# pw userdel %%HORDEADMUSR%%
EOMSG
if [ -d %%PREFIX%%/%%MYADMDIR%% ] ; then
echo " # rm -rf %%PREFIX%%/%%HORDEDIR%%/"
fi
echo
fi
;;
esac

View File

@ -1,114 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# Copied from databases/phpmyadmin.
# Used if WITH_SUPHP has been defined.
PATH=/usr/sbin:/usr/bin:/bin ; export PATH
WITH_SUPHP=%%WITH_SUPHP%%
hordedir=%%HORDEDIR%%
hordeusr=%%HORDEADMUSR%%
hordegrp=%%HORDEGRP%%
hordegcos="Horde Owner"
hordehome=/nonexistent
hordeshell=/sbin/nologin
create_group() {
local user group gcos home shell
user=$1
group=$2
gcos=$3
home=$4
shell=$5
if pw groupadd -n $group ; then
echo "===> Group $group created"
else
cat <<-EOERRORMSG
*** Failed to create the $group group.
Please add the $user user and $group group
manually with the commands:
pw groupadd -n $group
pw useradd -n $user -g $group -c "$gcos" \\
-d $home -s $shell -h -
and retry installing this package.
EOERRORMSG
exit 1
fi
}
create_user() {
local user group gcos home shell
user=$1
group=$2
gcos=$3
home=$4
shell=$5
if pw useradd -n $user -g $group -c "$gcos" -d $home -s $shell -h - ; then
echo "===> Created $user user"
else
cat <<-EOERRORMSG
*** Failed to create the $user user.
Please add the $user user manually with the command:
pw useradd -n $user -g $group -c "$gcos" \\
-d $home -s $shell -h -
and retry installing this package.
EOERRORMSG
exit 1
fi
}
case $2 in
PRE-INSTALL)
if [ $WITH_SUPHP != "yes" ]; then
exit 0
fi
# Create the horde user and group if they do not already exist
if pw user show -n $hordeusr >/dev/null 2>&1 ; then
echo "===> Using pre-existing user $hordeusr"
else
if ! pw group show -n $hordegrp >/dev/null 2>&1 ; then
create_group $hordeusr $hordegrp "$hordegcos" $hordehome \
$hordeshell
fi
create_user $hordeusr $hordegrp "$hordegcos" $hordehome $hordeshell
fi
;;
POST-INSTALL)
if [ $WITH_SUPHP = "yes" ]; then
# Change ownership of the Horde directory
echo "===> Adjusting file ownership in $hordedir"
chown -R $hordeusr:$hordegrp $hordedir || exit 1
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
# Copy over sample config files unless they already exist
for cf in `ls %%HORDEDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
if [ ! -f $cf ]; then
cp -p $cf.dist $cf
fi
done
fi
;;
esac

View File

@ -1,40 +0,0 @@
************************************************************************
Horde has been installed in %%HORDEDIR%% with your blank
configuration files.
WARNING! the first user will get logged in as an administrator!
********
If you want Horde to access a database, you have to run the
appropriate scripts located in %%HORDEDIR%%/scripts/sql.
It is recommended that you change the password of the 'hordemgr'
user used to connect to the horde database.
Horde is setup by default to access MySQL.
WARNING! if you are upgrading from Horde v. 3.0.x, you have to alter your
******** database schemas. Please read the doc UPGRADING.
You can now access Horde without a password at <http://localhost/horde/>,
and you will be logged in as an administrator. You should first configure
a real authentication backend. Click on "Setup" in the "Administration"
menu and configure Horde. Start in the "Authentication" tab.
See the doc in %%DOCSDIR%% for details.
(tip: if you plan to install IMP, just keep "Automatic authentication as
a certain user", add your login to be treated as administrator, and once
IMP will be installed, switch to "Let a Horde application handle auth").
Select a log driver; if you keep 'file', do not forget to add a line
in /etc/newsyslog.conf.
Then select and configure a preferences driver.
Your %%APACHE_CONF%% has been updated,
you have to restart Apache.
When everything is OK, you should be able to access Horde from
<http://localhost/horde/>.
(If <http://localhost/horde/> does not run, but
<http://localhost/horde/index.php> is OK, then you have
to define index.php as a DirectoryIndex in %%APACHE_CONF%%.)
There is a testing script at <http://localhost/horde/test.php>.
************************************************************************

View File

@ -1,6 +0,0 @@
Horde is a framework used by several applications written in PHP.
Horde is used by these ports: mail/imp, mail/turba, devel/chora,
deskutils/kronolith, deskutils/nag, mail/ingo and deskutils/mnemo.
WWW: http://www.horde.org/

File diff suppressed because it is too large Load Diff

View File

@ -1,14 +1,16 @@
# Ports collection makefile for: horde2
# Ports collection makefile for: horde3
# Date created: Sun Oct 07, 2001
# Whom: Thierry Thomas (<thierry@thomas.as>)
#
# $FreeBSD$
#
PORTNAME= horde
PORTNAME= base
PORTVERSION= 3.1.3
CATEGORIES= www
MASTER_SITES= HORDE
PKGNAMEPREFIX= horde-
DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
COMMENT= A common code-base used by Horde applications, written in PHP