add denature 0.6.5

A HTML to PDF converter
This commit is contained in:
Ying-Chieh Liao 2004-01-13 08:45:54 +00:00
parent ae88725e1a
commit 7352addb24
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=98048
6 changed files with 75 additions and 0 deletions

View File

@ -45,6 +45,7 @@
SUBDIR += da-aspell
SUBDIR += dadadodo
SUBDIR += dbacl
SUBDIR += denature
SUBDIR += dico
SUBDIR += dict
SUBDIR += dictfmt

View File

@ -0,0 +1,42 @@
# ex:ts=8
# Ports collection makefile for: denature
# Date created: Jan 6, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= denature
PORTVERSION= 0.6.5
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A HTML to PDF converter
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/HTML/Tree.pm:${PORTSDIR}/www/p5-HTML-Tree \
${SITE_PERL}/CSS/Tiny.pm:${PORTSDIR}/textproc/p5-CSS-Tiny \
fop:${PORTSDIR}/textproc/fop
USE_PERL5= yes
USE_JAVA= 1.2+
POD2MAN?= pod2man
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= denature.1
post-patch:
@${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}| ; \
s|%%JAVA_HOME%%|${JAVA_HOME}|" ${WRKSRC}/denature
do-build:
cd ${WRKSRC} && ${POD2MAN} denature > denature.1
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/denature ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/denature.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (denature-0.6.5.tar.gz) = 4e52614fe1039779b09dc70e5aea3518

View File

@ -0,0 +1,19 @@
--- denature.orig Tue Jan 6 15:06:24 2004
+++ denature Tue Jan 6 15:08:54 2004
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -w
+#!/usr/bin/env perl -w
#
# Copyright (C) 2003 dan sinclair
@@ -15,8 +15,8 @@
use Getopt::Std;
use CSS::Tiny;
-my $fop_home = "/usr/local/fop-0.20.5rc/";
-my $java_home = "/opt/blackdown-jdk-1.3.1/";
+my $fop_home = "%%LOCALBASE%%/share/fop/";
+my $java_home = "%%JAVA_HOME%%/";
####################################################
##### Probably don't need to edit below here #######

View File

@ -0,0 +1,11 @@
denature is a perl program that attempts to convert an HTML page into XSL-FO
which it then passes off to the FOP (Formatted Objects Formatter) to produce a
PDF document.
denature trys to use any included CSS stylesheets to figure out the properties
used in the document. The CSS processing in denature is not very mature and
only handles a limited amount of the available CSS markup. The CSS support
does not handle the contextual entries in a CSS document, and the CSS::Tiny
module requires that all the :'s in a document have a space after them.
WWW: http://denature.sourceforge.net/

View File

@ -0,0 +1 @@
bin/denature