- Update to 1.99

This release reuires an useless dependency on libdbi (since dbi support
is not complete).
I'll try to make this ports libdbi-free soon.
This commit is contained in:
Clement Laforet 2004-07-31 12:16:59 +00:00
parent b2f4688974
commit 6ce2dae5a7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115145
3 changed files with 6 additions and 34 deletions

View File

@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= mod_log_sql
PORTVERSION= 1.97
PORTVERSION= 1.99
CATEGORIES= www databases
MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
@ -20,6 +20,9 @@ USE_GMAKE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
SSL_PLIST= "@comment "
PLIST_SUB+= SSL=${SSL_PLIST}
CONFIGURE_ARGS+= --with-dbi=${LOCALBASE}
LIB_DEPENDS+= dbi.0:${PORTSDIR}/databases/libdbi
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"

View File

@ -1,2 +1,2 @@
MD5 (mod_log_sql-1.97.tar.gz) = 6e5616dbb6eec5e1acd2d3fd8b42e5be
SIZE (mod_log_sql-1.97.tar.gz) = 148593
MD5 (mod_log_sql-1.99.tar.gz) = e246a3d8e96d2d62715eb34f75c7c11d
SIZE (mod_log_sql-1.99.tar.gz) = 159167

View File

@ -1,31 +0,0 @@
--- mod_log_sql.c.orig Fri Apr 16 14:47:38 2004
+++ mod_log_sql.c Fri Apr 16 14:47:51 2004
@@ -1,5 +1,13 @@
/* $Id: mod_log_sql.c,v 1.20 2004/03/05 00:30:58 urkle Exp $ */
+#if defined(WITH_APACHE20)
+# include "apache20.h"
+#elif defined(WITH_APACHE13)
+# include "apache13.h"
+#else
+# error Unsupported Apache version
+#endif
+
#ifdef HAVE_CONFIG_H
/* Undefine these to prevent conflicts between Apache ap_config_auto.h and
* my config.h. Only really needed for Apache < 2.0.48, but it can't hurt.
@@ -11,14 +19,6 @@
#undef PACKAGE_VERSION
#include "config.h"
-#endif
-
-#if defined(WITH_APACHE20)
-# include "apache20.h"
-#elif defined(WITH_APACHE13)
-# include "apache13.h"
-#else
-# error Unsupported Apache version
#endif
#if APR_HAVE_UNISTD_H