cleanup: Remove expired ports:

2022-09-30 lang/spidermonkey17: Obsolete, released in 2007 and since long unsupported upstream
2022-09-30 lang/p5-JavaScript-SpiderMonkey: Depends on deprecated SpiderMonkey 1.7
This commit is contained in:
Rene Ladan 2022-09-30 22:22:19 +02:00
parent 5cf6c59d83
commit 66873a8df8
17 changed files with 2 additions and 350 deletions

2
MOVED
View File

@ -17566,3 +17566,5 @@ sysutils/py-ansible-base||2022-09-30|Has expired: Depends on expired security/py
devel/flang||2022-09-30|Has expired: Very outdated and unsupported upstream, current version in tree is several years old and upstream is still active
devel/flang-clang||2022-09-30|Has expired: Very outdated and unsupported upstream, current version in tree is several years old and upstream is still active
deskutils/myitcrm||2022-09-30|Has expired: Abandoned project as last update was on 2012-01-15
lang/spidermonkey17||2022-09-30|Has expired: Obsolete, released in 2007 and since long unsupported upstream
lang/p5-JavaScript-SpiderMonkey||2022-09-30|Has expired: Depends on deprecated SpiderMonkey 1.7

View File

@ -223,7 +223,6 @@
SUBDIR += p5-ExtUtils-F77
SUBDIR += p5-Interpolation
SUBDIR += p5-JSAN
SUBDIR += p5-JavaScript-SpiderMonkey
SUBDIR += p5-JavaScript-Squish
SUBDIR += p5-JavaScript-Value-Escape
SUBDIR += p5-List-MoreUtils
@ -338,7 +337,6 @@
SUBDIR += snobol4
SUBDIR += solidity
SUBDIR += spidermonkey102
SUBDIR += spidermonkey17
SUBDIR += spidermonkey78
SUBDIR += spidermonkey91
SUBDIR += spl

View File

@ -1,28 +0,0 @@
PORTNAME= JavaScript-SpiderMonkey
PORTVERSION= 0.25
CATEGORIES= lang perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl interface to Mozilla JavaScript implementation
WWW= https://metacpan.org/release/JavaScript-SpiderMonkey
DEPRECATED= Depends on deprecated SpiderMonkey 1.7
EXPIRATION_DATE=2022-09-30
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LIB_DEPENDS= libjs.so:lang/spidermonkey17
TEST_DEPENDS= p5-Log-Log4perl>=0:devel/p5-Log-Log4perl
USES= perl5
USE_PERL5= configure
CFLAGS+= -I${LOCALBASE}/include/js-1.7/
post-patch:
@${REINPLACE_CMD} -e 's|libjs.a|libjs.so|' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1533748547
SHA256 (JavaScript-SpiderMonkey-0.25.tar.gz) = aed5e114926be356bb3647956726c8e906e6d95f3ba2ece4aa6da216f863686e
SIZE (JavaScript-SpiderMonkey-0.25.tar.gz) = 21405

View File

@ -1,17 +0,0 @@
--- Makefile.PL.orig 2011-10-23 12:27:21.000000000 +0200
+++ Makefile.PL 2017-06-03 21:50:44.801687000 +0200
@@ -68,13 +68,8 @@
next if ! -f $libfile;
my $include_path = $possible_install_paths{$install_path};
foreach my $c_header(@c_header_files) {
- if (-f "$include_path/$c_header") {
+ if (-f "$include_path/js-1.7/$c_header") {
my $include_dir = "$include_path/$c_header";
- $include_dir =~ s/$c_header$//;
- push @JS_INCL_DIRS, $include_dir;
- }
- foreach my $headerfile(glob "$include_path/*/$c_header") {
- my $include_dir = $headerfile;
$include_dir =~ s/$c_header$//;
push @JS_INCL_DIRS, $include_dir;
}

View File

@ -1,3 +0,0 @@
JavaScript::SpiderMonkey is a Perl Interface to the SpiderMonkey
JavaScript Engine. It is different from Claes Jacobsson's
"JavaScript.pm" in that it offers more friendly, Perl-like API.

View File

@ -1,3 +0,0 @@
%%SITE_ARCH%%/JavaScript/SpiderMonkey.pm
%%SITE_ARCH%%/auto/JavaScript/SpiderMonkey/SpiderMonkey.so
%%PERL5_MAN3%%/JavaScript::SpiderMonkey.3.gz

View File

@ -1,72 +0,0 @@
PORTNAME= spidermonkey17
DISTVERSION= 1.7.0
PORTREVISION= 5
CATEGORIES= lang
MASTER_SITES= MOZILLA/js
DISTNAME= js-${DISTVERSION}
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= Standalone JavaScript interpreter from the Mozilla project
WWW= https://spidermonkey.dev/
DEPRECATED= Obsolete, released in 2007 and since long unsupported upstream
EXPIRATION_DATE=2022-09-30
BROKEN_aarch64= fails to link: missing sbrk
BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: FreeBSD12.0-CURRENT_DBG.OBJ/js: hidden symbol `__aeabi_uidivmod' in /usr/lib/libgcc.a(aeabi_uidivmod.o) is referenced by DSO
BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
BROKEN_riscv64= fails to link: missing sbrk
BROKEN_sparc64= fails to link
LIB_DEPENDS= libnspr4.so:devel/nspr
MAKE_ARGS+= JS_THREADSAFE=YES \
PROG_LIBS="-lreadline -lncurses -lm -lpthread" \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -I${LOCALBASE}/include/nspr
USES= gmake ncurses readline
MAKEFILE= Makefile.ref
ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js
MAKE_ENV+= CCC="${CXX}"
USE_LDCONFIG= yes
SRC_DIR= js/src
JSH= jsapi.h jsarena.h jsarray.h jsatom.h jsautocfg.h jsbool.h \
jsclist.h jscntxt.h jscompat.h jsconfig.h jsdate.h jsdhash.h \
jsdtoa.h jsemit.h jsexn.h jsfun.h jsgc.h jshash.h jsinterp.h \
jsiter.h jslibmath.h jslock.h jslong.h jsmath.h jsnum.h jsobj.h \
jsopcode.h jsosdep.h jsotypes.h jsparse.h jsprf.h jsprvtd.h \
jspubtd.h jsutil.h jsregexp.h jsscan.h jsscope.h jsscript.h \
jsstr.h jstypes.h jsxdrapi.h jsxml.h \
js.msg jsproto.tbl
PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/js-1.7/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS= --exclude js/jsd
OPTIONS_DEFINE= UTF8
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUTF8}
CFLAGS+= -DJS_C_STRINGS_ARE_UTF8
.endif
do-configure:
${CP} ${WRKSRC}/config/Linux_All.mk \
${WRKSRC}/config/${OPSYS}`${UNAME} -r`.mk
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/js \
${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/libjs.so \
${STAGEDIR}${PREFIX}/lib
${LN} -sf libjs.so ${STAGEDIR}${PREFIX}/lib/libjs.so.1
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
@${MKDIR} ${STAGEDIR}${PREFIX}/include/js-1.7
@${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} \
${STAGEDIR}${PREFIX}/include/js-1.7/
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (js-1.7.0.tar.gz) = 44363f0f3895800ee6010763eae90c0d15ed28e07d783bc7b3c607ce98d8668b
SIZE (js-1.7.0.tar.gz) = 1165607

View File

@ -1,13 +0,0 @@
--- Makefile.ref 2006-07-26 21:16:47.000000000 +0200
+++ Makefile.ref 2008-06-18 17:43:04.000000000 +0200
@@ -335,8 +335,8 @@
$(PROGRAM): $(PROG_OBJS) $(LIBRARY)
link.exe -out:"$@" $(EXE_LINK_FLAGS) $^
else
-$(PROGRAM): $(PROG_OBJS) $(LIBRARY)
- $(CC) -o $@ $(CFLAGS) $(PROG_OBJS) $(LIBRARY) $(LDFLAGS) $(OTHER_LIBS) \
+$(PROGRAM): $(PROG_OBJS) $(SHARED_LIBRARY)
+ $(CC) -o $@ $(CFLAGS) $(PROG_OBJS) -L$(OBJDIR) -ljs $(LDFLAGS) $(OTHER_LIBS) \
$(PROG_LIBS)
endif

View File

@ -1,43 +0,0 @@
--- config/Linux_All.mk 2005-05-10 21:53:44.000000000 +0200
+++ config/Linux_All.mk 2008-06-18 14:26:06.000000000 +0200
@@ -41,8 +41,8 @@
# Config for all versions of Linux
#
-CC = gcc
-CCC = g++
+CC ?= gcc
+CCC ?= g++
CFLAGS += -Wall -Wno-format
OS_CFLAGS = -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R
@@ -74,7 +74,7 @@
GFX_ARCH = x
-OS_LIBS = -lm -lc
+OS_LIBS = -lm
ASFLAGS += -x assembler-with-cpp
@@ -88,16 +88,12 @@
endif
# Use the editline library to provide line-editing support.
-JS_EDITLINE = 1
+JS_READLINE = 1
-ifeq ($(CPU_ARCH),x86_64)
-# Use VA_COPY() standard macro on x86-64
-# FIXME: better use it everywhere
OS_CFLAGS += -DHAVE_VA_COPY -DVA_COPY=va_copy
-endif
-ifeq ($(CPU_ARCH),x86_64)
-# We need PIC code for shared libraries
-# FIXME: better patch rules.mk & fdlibm/Makefile*
+ifeq ($(CPU_ARCH),sparc64)
OS_CFLAGS += -DPIC -fPIC
+else
+OS_CFLAGS += -DPIC -fpic
endif

View File

@ -1,12 +0,0 @@
--- jslock.c 2007-03-29 23:55:35.000000000 +0200
+++ jslock.c 2008-06-19 16:08:19.000000000 +0200
@@ -224,7 +224,9 @@
#endif
}
+#ifndef NSPR_LOCK
static void js_Dequeue(JSThinLock *);
+#endif
#ifdef DEBUG_SCOPE_COUNT

View File

@ -1,11 +0,0 @@
--- jsopcode.c 2007-09-27 20:30:18.000000000 +0200
+++ jsopcode.c 2008-06-19 16:10:44.000000000 +0200
@@ -262,7 +262,7 @@
pc2 += jmplen;
npairs = GET_ATOM_INDEX(pc2);
pc2 += ATOM_INDEX_LEN;
- fprintf(fp, " offset %d npairs %u", off, (uintN) npairs);
+ fprintf(fp, " offset %td npairs %u", off, (uintN) npairs);
while (npairs) {
atom = GET_ATOM(cx, script, pc2);
pc2 += ATOM_INDEX_LEN;

View File

@ -1,11 +0,0 @@
--- jsosdep.h 2006-07-07 04:12:02.000000000 +0200
+++ jsosdep.h 2008-06-19 16:32:12.000000000 +0200
@@ -89,7 +89,7 @@
#elif defined(SOLARIS)
#define JS_HAVE_LONG_LONG
-#elif defined(FREEBSD)
+#elif defined(FREEBSD) || defined(__FreeBSD__)
#define JS_HAVE_LONG_LONG
#elif defined(SUNOS4)

View File

@ -1,11 +0,0 @@
--- jsstr.c 2006-11-22 09:28:44.000000000 +0100
+++ jsstr.c 2008-06-19 16:14:49.000000000 +0200
@@ -1815,6 +1815,8 @@
jsint i, j;
uint32 len, limit;
+ bzero(&tmp,sizeof(tmp));
+
str = js_ValueToString(cx, OBJECT_TO_JSVAL(obj));
if (!str)
return JS_FALSE;

View File

@ -1,118 +0,0 @@
--- jsdtoa.c 2007-01-18 00:56:12.000000000 +0100
+++ jsdtoa.c 2008-06-19 16:34:02.000000000 +0200
@@ -247,7 +247,8 @@
#define word1(x) JSDOUBLE_LO32(x)
#define set_word1(x, y) JSDOUBLE_SET_LO32(x, y)
-#define Storeinc(a,b,c) (*(a)++ = (b) << 16 | (c) & 0xffff)
+#define Storeinc(a,b,c) (*(a)++ = (b) << 16 | ((c) & 0xffff))
+
/* #define P DBL_MANT_DIG */
/* Ten_pmax = floor(P*log(2)/log(5)) */
--- jspubtd.h 2007-06-23 01:13:21.000000000 +0200
+++ jspubtd.h 2008-06-19 16:26:08.000000000 +0200
@@ -616,7 +616,7 @@
typedef JSBool
(* JS_DLL_CALLBACK JSArgumentFormatter)(JSContext *cx, const char *format,
JSBool fromJS, jsval **vpp,
- va_list *app);
+ va_list app);
#endif
typedef JSBool
--- jsapi.c 2007-10-03 16:36:48.000000000 +0200
+++ jsapi.c 2008-06-19 17:17:52.000000000 +0200
@@ -134,7 +134,7 @@
static JSBool
TryArgumentFormatter(JSContext *cx, const char **formatp, JSBool fromJS,
- jsval **vpp, va_list *app)
+ jsval **vpp, va_list app)
{
const char *format;
JSArgumentFormatMap *map;
@@ -263,8 +263,7 @@
break;
default:
format--;
- if (!TryArgumentFormatter(cx, &format, JS_TRUE, &sp,
- JS_ADDRESSOF_VA_LIST(ap))) {
+ if (!TryArgumentFormatter(cx, &format, JS_TRUE, &sp, ap)) {
return JS_FALSE;
}
/* NB: the formatter already updated sp, so we continue here. */
@@ -366,8 +365,7 @@
break;
default:
format--;
- if (!TryArgumentFormatter(cx, &format, JS_FALSE, &sp,
- JS_ADDRESSOF_VA_LIST(ap))) {
+ if (!TryArgumentFormatter(cx, &format, JS_FALSE, &sp, ap)) {
goto bad;
}
/* NB: the formatter already updated sp, so we continue here. */
--- js.c 2007-04-20 20:45:18.000000000 +0200
+++ js.c 2008-06-19 18:17:29.000000000 +0200
@@ -978,7 +978,7 @@
}
}
}
- fprintf(gOutFile, "%3u: %5u [%4u] %-8s",
+ fprintf(gOutFile, "%3tu: %5u [%4u] %-8s",
PTRDIFF(sn, notes, jssrcnote), offset, delta, name);
switch (type) {
case SRC_SETLINE:
--- jscntxt.h 2007-04-06 22:53:21.000000000 +0200
+++ jscntxt.h 2008-06-19 18:36:28.000000000 +0200
@@ -598,7 +598,7 @@
#define JS_PUSH_TEMP_ROOT(cx,cnt,arr,tvr) \
JS_BEGIN_MACRO \
- JS_ASSERT((ptrdiff_t)(cnt) >= 0); \
+ JS_ASSERT((int)(cnt) >= 0); \
(tvr)->count = (ptrdiff_t)(cnt); \
(tvr)->u.array = (arr); \
JS_PUSH_TEMP_ROOT_COMMON(cx, tvr); \
--- jsxml.c 2007-04-19 04:18:25.000000000 +0200
+++ jsxml.c 2008-06-19 18:49:44.000000000 +0200
@@ -1058,7 +1058,10 @@
free(array->vector);
vector = NULL;
} else {
- if ((size_t)capacity > ~(size_t)0 / sizeof(void *) ||
+ if (
+#if JS_BITS_PER_WORD == 32
+ (size_t)capacity > ~(size_t)0 / sizeof(void *) ||
+#endif
!(vector = (void **)
realloc(array->vector, capacity * sizeof(void *)))) {
if (cx)
@@ -1153,7 +1156,10 @@
JS_CEILING_LOG2(log2, capacity);
capacity = JS_BIT(log2);
}
- if ((size_t)capacity > ~(size_t)0 / sizeof(void *) ||
+ if (
+#if JS_BITS_PER_WORD == 32
+ (size_t)capacity > ~(size_t)0 / sizeof(void *) ||
+#endif
!(vector = (void **)
realloc(array->vector, capacity * sizeof(void *)))) {
JS_ReportOutOfMemory(cx);
--- jsarray.c 2007-09-29 01:29:52.000000000 +0200
+++ jsarray.c 2008-06-19 19:12:02.000000000 +0200
@@ -1051,10 +1051,12 @@
* Check that its size does not overflow size_t, which would allow for
* indexing beyond the end of the malloc'd vector.
*/
- if (len > ((size_t) -1) / sizeof(jsval)) {
+#if JS_BITS_PER_WORD == 32
+ if ((size_t)len > ~(size_t)0 / sizeof(jsval)) {
JS_ReportOutOfMemory(cx);
return JS_FALSE;
}
+#endif
vec = (jsval *) JS_malloc(cx, ((size_t) len) * sizeof(jsval));
if (!vec)

View File

@ -1 +0,0 @@
Spidermonkey is the JavaScript interpreter from the Mozilla project.